IDO老徐,坐标深圳,测试经理,干了十年测试,公号"简尚" ,博客isTester.com ,关注「软件测试从业者综合能力提升 & 职场人每日进阶」,个人微信957863300

编译的 Ruby 缺少 openssl 支持的解决方法 (已解决)

上一篇 / 下一篇  2016-05-27 13:23:32 / 个人分类:IDO杂谈


y&s@9cH*KU\0

Vw6|9q7zi_/d0

前提:编译安装了ruby2.3.0。 51Testing软件测试网:p i{HjY`

然后安装gem时, 会有错误提示:

Iq-I H~7z6z0

ERROR: While executing gem ... (Gem::Exception)

};n5v$`.c,Z,Q&\)w5k0

Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources

d)M o1dMVQKD0

重新编译发现, make的输出中有

S2b/n6fk1\Q0g5U~2p0

configuring openssl

*T-J Z O6zGM0

Failed to configure openssl. It will not be installed.

\m?%q4fD3p0

如上字样。

)g'?v? o}:c }0


pM3MY!}nE\ x0

A2O8a*E$?;{0n0

然后重新配置, 在运行configure时加上了openssl路径信息即可。 正确编译的姿势如下:51Testing软件测试网?0f`'wW.Hg{(t

$./configure  --with-openssl-dir=/usr/local/ssl
$make
$sudo make install

再次安装gem,无报错信息。编译成功。51Testing软件测试网G[9tqos


:@4jtM}%G ?M0
51Testing软件测试网 M bQs3X;aNQ!J


TAG: gem openssl Ruby ruby

 

评分:0

我来说两句

显示全部

:loveliness: :handshake :victory: :funk: :time: :kiss: :call: :hug: :lol :'( :Q :L ;P :$ :P :o :@ :D :( :)

xuquan

xuquan

IDO老徐,坐标深圳,测试经理,干了十年测试,公号"简尚" ,博客isTester.com ,关注「软件测试从业者综合能力提升 & 职场人每日进阶」,个人微信957863300

日历

« 2020-07-08  
   1234
567891011
12131415161718
19202122232425
262728293031 

数据统计

  • 访问量: 587025
  • 日志数: 370
  • 建立时间: 2012-06-04
  • 更新时间: 2020-06-24

RSS订阅

Open Toolbar