Robot Framework被误会多年的秘密

上一篇 / 下一篇  2020-03-30 15:59:20

今天我们主要聊一聊,RobotFramework被误会多年的秘密。经常也会到许多同行,在拿Robot Framework与Pytest或其它同类测试框架作对比,我认为这个对比本质上是没有任何意义的,萝卜白菜、各有所爱,只有找到适合,并能用较低成本就能解决当前团队面临的问题,这才是关键所在。
  至于框架之间的对比,笔者主张的观点:“存在即合理,每个框架既然它存在,必然在它存在的意义和价值,当然也有他们各自的优点以及劣势,当前市面上也并没有一款框架能做到十全十美,满足所有人的需求,只有明确自己的问题,找准靶心,以解决问题驱动才是王道!”
  回归到今天的主题,大部分人在一开始用Robot Framework都存在一个误解,认为Robot Framework只支持Python2,其实这是对Robot Framework兼容性存在的一个较大误区。Robot Framework其实很早就已经支持Python 3了。
  之所以市面上一直有这样的误区,是因为Robot Framework对应的官方编辑器RIDE由于一些历史原因,只支持到了Python 2.7,那么也就导致如果你在使用Robot Framework时,如果是用RIDE来管理RF测试用例,那么之前的版本确实是只能用Python 2.x版本。但如果你并不是采用RIDE 而是用其它编辑器或插件比如Pycharm或VS Code,或者直接命令行的形式来运行RF测试用例,那么即使用Python 3也是可以的。
  值得庆幸的是,在2019年1月20号,Robot Framework RIDE发布了1.7.3版本解决了此前RIDE一直无法兼容Python 3的问题。也就意味着Robot Framework不管是采用何种编辑器,都已经是可以支持Python 3了。
  1.Robot Framework RIDE 1.7.3+ 新特性
  在Robot Framework IDE 1.7.3+版本中,显著增强的功能有:
  兼容Python 2.7 and >=3.6。
  运行任何wxPython版本(2.8.12.1、3.0.2在Python 2.7上)和4.0.4用于Python 2.7和> = 3.6。
  得益于wxPython的AUI模块、窗格、标签、工具栏是可拆卸和可重新定位的。
  文本编辑器现在具有自动补全功能。
  树窗格上的测试用例,具有新的官方图标,并在运行或暂停时设置动画。
  树窗格上的测试用例名称过长的名称用“…”进行缩短。并且在工具提示上可见。
  在测试套件级别的树窗格上,上下文菜单允许在文件管理器中打开文件夹,并删除只读文件属性。
  如果未选择任何测试,将确认继续运行所有测试。
  像快捷键F8一样可以运行测试,现在快捷键F9可以用debug的日志级运行它们。
  最新的RIDE版本已经到了1.7.4.1,详细可阅官网介绍:
  https://github.com/robotframework/RIDE/releases
  2.Robot Framework RIDE 1.7.3+ 安装、升级
  最新版本1.7.3.1基于wxPython 4.0.4,此时的wxPython也是支持Python 3.x,安装过程也很简单。
  1. 采用pip安装
  (1)打开命令行提示行,安装或更新Robot Framework版本:
  pip install -U robotframework
  (2)安装wxPython 4.0.4版本:
  pip install wxPython==4.0.4
  (3)安装或更新Robot Framework RIDE版本:
  通过pip安装最新版本:pip install -U robotframework-ride
  通过pip安装指定版本:pip install robotframework-ride==1.7.3.1
  通过pip安装所需依赖:pip install -U -r https://github.com/robotframework/RIDE/blob/master/requirements.txt

TAG:

引用 删除 sunnysun1   /   2020-03-31 18:59:00
3
 

评分:0

我来说两句

显示全部

:loveliness: :handshake :victory: :funk: :time: :kiss: :call: :hug: :lol :'( :Q :L ;P :$ :P :o :@ :D :( :)

Open Toolbar