mac安装robotframework遇到了一个史上最恶心的问题,而且没有解决

上一篇 / 下一篇  2015-09-27 14:56:29 / 个人分类:robotframework

一.安装RobotFramework

1.安装Python,easy_install

mac自带Python和easy_install

2.安装robotframework

方法一:sudo easy_install robotframework(此方法需要翻墙)

方法二:因为方法一需要翻墙,在一般情况下无法完成,所以可以去下载.tar.gz包

            >>>tar -zvxf .tar.gz

            >>>python setup.py install

(尽量用easy_install安装,不然可能会出现版本不对应的情况)

二.安装 Jython

1.到官网  http://www.jython.org/downloads.html   下载Jython.jar

2.>>>java -jar jython.jar (可以在官网查到)

  出现窗口,然后根据自己情况安装就好,一般都是,next到底然后finish,就是需要注意的是,安装的时候,要注意安装路径

3.设置环境变量:

  1. cd~

  2. vi.bash_profile

文件内添加:

  1. export PATH=/Users/{your own username}/jython2.5.3/bin:$PATH

warning!!

  1. 网上有个版本是:
  2. export JYTHON_HOME=/Users/{your-mac}/jython2.5.2
  3. export JYTHONPATH=$JYTHON_HOME/Lib
  4. 等到source之后,jython--version不起作用
  5. 根据上面可以设置成功的环境变量的,改成:
  6. export JYTHON_HOME=/Users/qinhuang/jython2.5.2
  7. export PATH=$JYTHON_HOME/Lib
  8. 命令连vils都无法识别了

查看jython是否安装成功:

  1. jython--version

三.安装RIDE

https://github.com/robotframework/RIDE/wiki/Installation-Instructions

里面有安装信息

1.安装wxpython

1.1根据信息,去http://sourceforge.net/projects/wxpython/files/wxPython/2.8.12.1/ 下载wxpyhton

1.2双击安装

2.安装RIDE

>>>sudo easy_install robotframework-ride

3.运行ride

shylocks-MacBook-Pro:~ shylock$ ride.py

wxPython not found.

You need to install wxPython 2.8.12.1 with unicode support to run RIDE.

wxPython 2.8.12.1 can be downloaded from http://sourceforge.net/projects/wxpython/files/wxPython/2.8.12.1/

会有这样的提示。


查了好久,终于查到wxpython安装在哪里:/usr/local/lib/

/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7这个目录下并没有site-package

/Library/Frameworks/这个目录下并没有Python.framework

python 安装路径  /usr/lib/python


根据网上的提示:

如果出现错误:ImportError: /System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core_.so: no appropriate 64-bit architecture (see “man python” for running in 32-bit mode)
说明python为64位,wxPython不支持64为python,需要强制使用32位:

执行 defaults write com.apple.versioner.python Prefer-32-Bit -bool yes

说明,在/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/wx-2.8-mac-unicode/wx/_core_.so这个路径下存在wx-2.8-mac-unicode/wx文件。经过安装过过后的mac,python没目录下,病没有wx-2.8-mac-unicode这个文件夹。

进入过python的交互模式

  1. shylocks-MacBook-Pro:usr shylock$ python
  2. Python2.7.6(default,Sep92014,15:04:36)
  3. [GCC4.2.1CompatibleAppleLLVM6.0(clang-600.0.39)]on darwin
  4. Type"help","copyright","credits"or"license"formore information.
  5. >>>importwx
  6. >>>wx
  7. <module'wx'from'/usr/local/lib/wxPython-unicode-2.8.12.1/lib/python2.7/site-packages/wx-2.8-mac-unicode/wx/__init__.pyc'>

查看了wx得安装目录中,有wx-2.8-mac-unicode这个文件夹

把wx-2.8-mac-unicode这个文件夹复制到上面应该有得目录下。可是仍然提示,找不到。


robotframework虐我千百遍,我待robot framework如初恋,可是还是没有解决这个问题!!!


TAG: RobotFramework Robotframework robotframework

Shylock的个人空间 引用 删除 Shylock   /   2016-09-02 11:44:40
问题解决了:
今天在弄环境变量的时候不小心把jython的环境变量弄没了,然后在添加jython的环境变量时,发现,我之前因为老提示没有安装正确的wxpython版本,添加了一个export PATH=/usr/local/lib/wxPython-unicode-2.8.12.1/lib/python2.7/site-packages/wx-2.8-mac-unicode/wx/__init__.pyPATH
仔细看了下,环境变量的格式是错误的,把它注释了,robotframework启动起来了
Shylock的个人空间 引用 删除 Shylock   /   2016-03-07 22:55:14
原帖由liu8050于2015-12-09 17:29:50发表
我已经解决可以在 mac 上运行 ride 了,可是运行后,就会报 python 意外退出,很恶心的


还会报python以外退出呀。兼容性还是有待提高。
我的估计是和mac的版本有关系
Shylock的个人空间 引用 删除 Shylock   /   2016-03-07 22:53:57
原帖由lt176762674于2015-12-09 14:54:27发表
请问你后来解决这个问题了吗?

应该是和mac的版本有关,我尝试了好久,最终还是没有解决。只能在win7上使用了
liu8050的个人空间 引用 删除 liu8050   /   2015-12-09 17:29:50
我已经解决可以在 mac 上运行 ride 了,可是运行后,就会报 python 意外退出,很恶心的
引用 删除 lt176762674   /   2015-12-09 14:54:27
请问你后来解决这个问题了吗?
 

评分:0

我来说两句

显示全部

:loveliness: :handshake :victory: :funk: :time: :kiss: :call: :hug: :lol :'( :Q :L ;P :$ :P :o :@ :D :( :)

Open Toolbar