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1. &I QuickTest Professional 8 Tutorial
Bl ™| QuickTest Professional Tutorial - 4 = ;L QuickTest i E’IISF%??"‘P ﬁ' fac gl By [P |
PV prl#F QuickTest 7| ﬁ“ﬁ”[’“u R A A o R R R [Efl1 e

"] QuickTest i I' HIRUSHEAYAFTL ~ — 4& Windows " [FH= + Visual Basic /" [F=4 ~
ActiveX 1 fil:Fi ~ “HipFIFE
*= P'Hﬁ’ﬂl;ﬁfﬁ\»%ﬁvpﬁ {7 | QuickTest = [ IE (¢ ~ B ~ STFrfIRETHIN -

BRI O A 5 TR0 | QuickTest [ IFHHYERTY] Mercury SIS =4 F1E0
S H GG I EEEIE (script) -

1.1 iﬁ[ B 17 Tutorial

£ P55 O [ - A1 | QuickTest T Mercury FEESHI Ak 17
Spgy o b G I EEYEIA (script)

F‘ﬁ,;%,;gﬂt JPIJF|€J§5E;[/ e yfj:HJ gﬂxﬁzwryl ,igguzfm F[ U ﬁ%’g‘k 17

®  QuickTest Professional /i @ Pk | VEVIREEREE = ERER A ) i J,chkTest ERRIE A
Hd ~ EE QuickTest fili [ /i 1 ~ I'J % Mercury Tours # 5 {ﬁ*ﬁ

W SRR PR SRR > 2 BRI E Keyword View fitfl /1A o

W SRE TR A o B R S RV A T A R A R A

W E AR ST R T R A R R R RL B

W SR AN o BT IR D SR R T R A

ol R DA S o LR R e

W QU s AR R PR U

W NIRRT THI S SRR TR R SRR R
PRI © @ SPIRET T H R 2T QuickTest Uyt -

—E
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2. QuickTest Professional /i

21 FIEHEROE
fﬁaijp{a;gnm m N TR v R A T ?p[j:iapﬁ;{g’g‘ R JEﬁfJ‘iﬂE?Eﬁﬂﬂﬁ'JE' QTF;,;@;-; SR
o (RN T RSO ALY P R (] > 2 S AR T T (e T
=1
™ QuickTest i | utIEE o3 » = Sl (build) SEPRy 4 FOER R i - i
PYETRIG0 RRAIRVRTE & 5 R -
I'} QuickTest $#h /7 [Z% » #E== * 7 JZE- £ > QuickTest ﬁﬁi}%ﬁﬁf;ﬂg@éb(ﬁ?é&ﬁ%gaﬁﬂ s
QuickTest =~ = JHFEEH 270" -

F RIS
[k (Fast) QuickTest v 7 JHJFEE » 7 HIFERE R 2 -
ﬁ‘ﬁjﬁg(Reliable) QuickTest & - ﬁ'flfjiﬁu%a‘ﬁﬂﬁ{l‘ }}’p”g’ﬁfjﬁnli?ﬁl[ﬁjﬁmgm‘e’ AR S O
L -
frETH QuickTest fi'I'} Esﬁimﬁ[{ ERREEA
(Repeatable)
[g=Eal QuickTest fi' I'| =4V » SR HIFGIORZEIE: » I IR ™ 7
(Programmable) SUHIpUEYR o
?{,ﬁ/pfj QuickTest fi'I'} J ?m/ﬁl NHIREVEE > W TR S puAnE Jrjrﬁ: o
(Comprehensive)
FIie] QuickTest i I') €1 KIff ™ IR 4 - S ER R roff =) 7 or= sasied «
(Reusable)

22 A
QuickTest EJEUE}LW}’T%EEUH AR
1. GV v
R e R R R T QuickTest kLR 7 et -

g o ORI PR T RE - RN e R O
B -
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[l r’ﬁ\*%ig]?ﬂﬁgp » QuickTest FIUF%‘#& » Y1 Test Settings ( [Test] > [Settings] ) I'| ¥
Options !t ( [Tools] > [Options] ) - I'/fEf QuickTest gﬁ“’ ROGRER (T Y
Lo [ fﬁ\’iéﬁgﬁfn‘g’?:# “» QuickTest i Object Repository £LI"| {1 itz Gy B30 -

2. IRV

Eﬁ*fﬁ\’%ﬁfﬁcﬁ%ﬁﬁf@‘}ﬂﬁé (PR P > QuickTest ?77} Keyword View f[iI'] %frﬁﬁfﬂﬁh‘
R SRR IR o B B T RRHRL D = 18 T SRS PO = > Al PREE - W8
st Clink) > FRLEF g e -

3. AR A
W R L R R R R QA P Rl R
AL
W RHEIVRIE (hard code) BErTJIVES 5 R | S PRI IS A FEFS «
m P (logic) FYALIE[ (conditional ) gt » T 155 PIHIFIORS «
4. SRRV IS (debug)

T [R5 S SRR (A (= o 1 bR 4 o
WO -

5. TrFVYIE R AR B R 4
ABETERE - QuickTest v PSR EY RLIES AR RIS - Ay im0 oy
R

6. TR
SIPTRIREER T PURRRL 45 LV R ORI ©
7. IpifilE (defect)

YN 2 Quality Center (TestDirector) - JI<fi I é@fﬁﬁlﬁf}ﬂﬁggllﬁﬁu Quality
Center ( TestDirector) EIU?}’H’T&"[HI > Quality Center ( TestDirector ) £l Mercury El@iﬂﬂg:f@ﬁﬁt;l

— Et
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QuickTest EEI‘F'L“[‘
T A F ?F[%ﬂgﬂﬁlu %H—Z[: I/F , mJ“E?ﬂ‘ 3 R QuickTest l;[ jﬁ]%{,[ o
P pUf EiRL QuickTest o= il «

Title bar & Recording - QuickT ezt Profezzional

Menu bar
File toolbar
Debug
toolbar
Testing
toolbar
Action
toolbar
wwielcome: Mercum Tours
val,_j Welcome: Mercury ..
: u- uzerMame "mercurny' Enter "mercury’’ in the "uzeiMame" edit box.
- pazswornd SetSecure :"4082386e35ea... i Enter the encrypted sting "4082986e392a469e70d
Test pane— -] Sigreln Click. 2.2 Click the "Sign-In'"' mage.
- -4 Find a Flight: Mercuny
I omPort Select "Mew Vork" Selectthe "Mew Yok item in the "fromPort” list.
frombdanth Select "Dec" Selectthe "Dec" itemn in the "frombdanth"™ ligt
Select gt Selectthe 23" item in the "fromDay" list,
Registered users can sign
Data here to find the lowest fare
Table — participating airlines.
User Marme:
4

Status bar Active Screen

QuickTest i = i) i &y A* FlpS7 i
B Title bar : = | lﬁrﬁE[juéﬁ’«}éﬂi fiY €74
B Menu bar : B QuickTest fuZf

u File toolbar : ﬁ,lygﬂ W& F{ CI SR
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Open  Print Data  Results  Options Object
Table

Repository

New  Save Active Debug Test Quality  Object
Screen  Viewer Settings Center Spy

Connection
B Testtoolbar : GV 4 F{fJ‘E'JEIij ST
Split Start Analog
Record Stop Action  Transaction Recording
it
Start New  Insert End Low-Lewvel
Run Action Checkpoint Transaction Recording

B Debug toolbar : SRF[ZVH] 4 Iié?ﬁiﬁﬁff'm@j S0

Step  Step  Clear All
Into  Out  Breakpoints

Pause  Step  Insert/Remowve
Over  Breakpoint

= fieaT- VWS QuickTest [ Debug toolbar fL 1 ¢ &=y o 0 I JRE [View] >
[ Toolbars] > [Debug] # Debug toolbar ' -
7= P ST ERRNAL A BRSO DS SRR pUTYR > 52 % QuickTest

Professional User’s Guide -

m  Action toolbar : & i HIEUIPREEE: - 1) fRE RS (action) o
(list) {0 ohgmp B HIEVET A 1R g e o
Action List Display selected action

|ﬁ Test Flow

Back
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s H BT SRR QuickTest [ Action toolbar fL 7 ¢ 2[4 o a7 IRk [View] >
[Toolbars]) > [Action]) 3 Action toolbar ‘il

Hi i FEVRI A Fp e reusable fY external action - ]| Action toolbar ik FIESEE=. - B[
FIIEI%E'/][ FIEYR %xﬂ QuickTest Professional User’'s Guide -

B Testpane : & i Keyword View I'] > Expert View -

B Active Screen pane : FA' Active Screen -

B Data Table : /s SHIRYEI 4 850 (Fy & TR URVRIups s 127 [l Global v
9t > &— {f# action Pj%’“ BEIPUErR & -

B Debug Viewer pane : {525 SRS 4 Bﬁfﬁﬁ (debug) - Debug Viewer pane E[Jfb' Watch
Expressions ~ Variables I'] ¥ Command -

=L H BT SRR QuickTest ff Debug Viewer (L @i fiv o B0 I'JREE [ View] >
[ Debug]) Z Debug Viewer i o

lﬁiﬁ["” I%ﬁ'ﬁ ey % ¥ QuickTest Professional User's Guide °

B Status bar : 27 J[FVHIF poTE -

B fepuii *Er{ == Test I'J% Standard = £'%]] »

[} Debug toolbar %’7 F chkTest Professional User’s Guide iy " Debugging Tests | :ﬁ’[ Qﬁf[l%ﬁ?ﬁ%ﬁ
BH o

Z¥* Action toolbar F‘?& Vﬂ%’iﬂﬂ?ﬂﬂ%‘%ﬂ?{: = U*?y ZiE = F]l;.1JF

& 2509 > QuickTest 4 Hd i [;{@gé l@i/[“’\'ﬁﬁﬂ@{ﬂ ey o ﬁ%ﬁr 4 QuickTest
Professional User’s Guide fiv " QuickTest at a Glance ; #i] -

B T SPOR IR GE - T QuickTest uffl ™ | /7 frape! !

2.4 ffi*'] Mercury Tours #{y5 ﬁﬁ!‘
Mercury Tours #tifyY5 ﬁ?ﬁi# (A5 E &kglqﬁ/yﬁp J;{ﬁﬁ" EERE JF”T"‘ S fﬁgﬂ Mercury
Tours &[4 b E"F' VEFGS o
ﬁ%ﬁ‘%ﬁﬂﬂj‘ [HIEGE~ ™ Mercury Tours Efy A= -

241 [ERREPTEEE
gL ? | Internet Explorer FrH - ﬁ%fﬁci?wﬁ] TRy o US> R R e
B B s - R e SIS P O RLGRE e
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24.2

AP IS O
1. F'#J?%‘Internet Explorer s Eﬁ [Z:])> [1ﬁ]§ fRE SR ] > [m*ﬁ'] .
2. %T Cila ~ =@ ] phipy CFiahskonsy ) $6 0 ‘E?[E' I Y f’% e [EFJE/[ °
3. KIEUE‘J FIEaR RS 5 ] Vi LR puii 1 EAEATERR ] 2
3
EEED%EE] Erie i LTS A BY1E B P R T REEERTE
—1EH BT
v fddkin)
¥ ZE
[~ SRE F e R O
|l E )
—ialsEEhTTRE LR
EEEC | EREEL |
EEREEL - 253 EPEREMETR] - T ]
TZEE THY GEkRLEE] =
e | Ew |
4. Eﬁi‘ (Ed) #& l'n%w%iﬁ" Tdfjf tfﬁfuﬁj[fil
7= j’/fﬁ‘/-"/Mercury Tours 5’5?7777[?7;/‘
rj: fay

HLEGS! Mercury Tours FET > &5 F = g ?4 &

ifﬁf? lsz[“

]

1.

Mercury Tours #i ﬁj;ﬁ‘jﬁff’,‘ :

5 Mercury Tours {5

» (1AL Mercury Tours #fyli

Ias r"ncﬁ@%ﬂﬁ%gﬁlﬁ“ IFJ"NPYURL : http://newtours.mercuryinteractive.com

F‘f{ [iFMercury Tours# i FiE! -
i

glﬁ * M| Mercury Tours r’f’\'/U\ZEJ%l%I:P'J P =

& Mercury Tours fUFiFIiE [REGISTER] $#£: - (il J? [Register] sff1 -

7+ [User Information] ﬁ? P | H =R f,ﬁ% ™

T -

Ef?:"%ﬁ? (H PRI o o T

-10 -
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Eﬁp SUBMIT #4 - Mercury Tours rF“LI' ’]i“Eg’iq’lf} El o }%%Eﬁ [SIGN-ON] % > %"F'ﬁj‘?ﬂ,‘
[Sign-on) Afif! « iy * HIMIGEPIVR" I H [R5 5> [SUBMIT] #4 - [Flight
Finder] Affff! %‘ﬁ?ﬁéﬁﬁj’?ﬁfo

3. %% Mercury Tours #fyJigHy
- [Flight Finder AfF il - #h It i s BErHT R -

1=#i > 7 Book a Flight S{F1 » ™ S HE HAVFER T [ B0 8 e BrpIEf
T B A H[Q{ﬂ rg;fg[pjg}ﬂg“ﬁ,iﬂ N (N 'l ﬁ.?n ”lF BB
8888888888888888) -

4. ERFREE
ek b RIEh (i ¥ [Flight Confirmation AfF1 R [LOG OUTY #22 i AR
1 i [SIGN-OFF] ##" -

eyl [Sign-on] AFFIEI#TE * Mercury Tours @l -
5. F—*fdfﬁfﬁ%ﬁ%&'

ST U HIRL 88 = Mercury Tour BTSSR » 457 ' I B 1] Quick Test S
7

- 11 -
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3. #HWFHI

3.1

3.2

E.}’fﬁ;*&%&ﬁﬁf}fﬁﬁ%ﬁ[E'J’f?ﬁ'ﬁ@?“ﬁ?j » QuickTest %’ﬁ%ﬂéa,&"ﬁ\'ﬁﬂﬁéf%ﬁ’ D 2 | 3

ﬁl for e [ HER IR R A % %'TIET:I[J QuickTest 7+ Keyword View f[1I" J?Jﬁg’lfﬁﬁk‘%gﬁ FIEEHI 2 foogs
(E=H B (steps) -

HGOEVEL A 7 fusE

TR F'J E[j"ﬁg far FI VEHFET ) QUICkTeSti_‘f fay F[ IS 3=‘j~<l§|j o

&F‘ﬁ]ﬁﬁzﬁ = P pYRE B %:& FE§J[ N

W @Iy Mercury Tours #(j ﬁﬁﬁiﬁ? [EE il I ol (S ﬁ%?ifj% "% “Rfi "] Mercury

Tours #J] “ﬂn{ﬁ*’!‘ g
B [HYpecRLE Y] Internet Explorer BT ﬁ%f’ﬂci@wﬁ CEIER RS § VIR o ﬁ%?if NETE
[T p Nt

m G O

G
- N S f’”"ﬁ%@@!* R4 7 Mercury Tours ﬁﬁjﬁr{ﬁfﬁf@ﬁ“ Fatss (New York) [

# &1 (San Francisco) fiVBSE! -

1. %~ QuickTest ™ fF 'E?ﬁ ffit = Frp R4

BRI ‘E’F?chkTest %Eﬁ ] i{F[] > [#4=¢& ] > [QuickTest Professional] >
[ QuickTest Professional] -
7+ [Add-in Manager] 2% [Web Add-in] -~ = 2Vif &y add-ins - i &Eﬁ% [OK]
e T;Jﬁ;f [ Add-in Manager] ﬁl[ﬁh » 37 QuickTest Professional = ﬁlﬁil

1= 31 : QuickTest Professional rﬁ‘ﬁa&fﬁnﬁf JEE 7 g IVRY add-ins -

e [Welcome] i » i [Blank Test] -
e E’!: [File] > [New] - AvhLEF ™ T 29 Hi9 [New] %! -
QuickTest Professional F“ Sl ES Bl A &

B {50 QuickTest Professional =5% 'E‘Tifv ﬁ%g‘ [Help) > [About QuickTest
Professional] % F1fj#l * ~FIEadd-ins < 132 % #E ¢ [Web Add-in] - 024 F‘Fﬁ%
Ffji"?;ﬂg?f%]fflTQuickTest Professional » §k 7+ [Add-in Manager] >3 [Web Add-
in] -

-12-
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gﬁﬁ [File] > [New] - FykLfF ™~ =% Fiv [New] ###* - QuickTest Professional
FAI, [ = B A A

FEC B #0 QuickTest Professional [H » 4 H[7% [Add-in Manager] - GfiffE
[Tools] > [Options]) - i+ [General] FI#># [Display Add-in Manager on startup] >
“ — xRS QuickTest Professional Bﬁﬁ{[‘:ﬁﬂ [ Add-in Manager] Elgf[ﬁﬂfﬁ’ 1o

2 ﬁﬁthﬁﬁﬁfﬂfﬁﬂ%ﬁ'ﬁ‘Mt

E [Test] > [Record]) ﬁ&ig’r“* 219l FpY [Record]) #& - %’?F'ﬂ?ﬁf [ Record and Run
Settlngs] ?Tﬁfﬁjﬁii

m 7 [Web] fi& > 2Z [Open the following browser when a record or run session
begins] -
ff- [Type] ™ % WL 2 [FUBBTAR > = = 7% [Address] i

ttp://newtours.mercuryinteractive.com -

ﬁ?ﬁgﬁ [ Do not record and run on browsers that are already open] == [ Close the
browser when the test is closed] iﬁ_ uf_,glfﬁuli;,‘a_ 1o

Record and Bun Settings

Mizrazaft Internet Explarer |_

hitp: A Anewtours. mercunpinteractive. com |_

® 7+ [Windows Applications] FI&% > ~J:# [Record and run on these applications
(opened on session start) ] - [f ”j RIEIVE |ﬁp Y [F o

IRl I ot SR H R R (41 Outlook ) (o«

-13-
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Record and Run Settings

B2 [OK] -
QuickTest F’ﬁr'ﬂ?ﬁ%ﬂﬁ‘%ﬁ'%@ﬁj‘ Mercury Tours Fﬁﬁ‘fﬂ? I Fﬁlﬁfi%?ﬁﬂ?ﬁ?ﬁﬂi o
3. ﬁ * Mercury Tours Web site
7 [User Name] = [Password] FE?J‘ fﬁ\‘fg{ﬁ’?’lﬁ:%?]ﬁ@ﬂ'ﬁ” ;S{-{ﬁ;‘ﬁfﬁ o
%’,‘fﬂj [Sign-In] -
F'ﬁjhli% [ Flight Finder] ﬁfﬁfl o
4. fa? FE[T BIERR|
TR
Departing From : New York
On : Dec 29
Arriving In : San Francisco
Returning : Dec 31

Service Class : Business class

A A EJ[Jﬂ[’ﬁi“F?,’?EIF%@ ’ ‘IF&%!T% [CONTINUE] F'afJTJT [ Select Flight] fff! -

-14 -
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3.3

EH: TefE PRI SR UEGEE [View Calendar] #E  PNELG S G- W Javafiuf]

B o [0 12 E R ¢ Java Add-in - ﬁ%@j\iu@ﬁéﬁ@o

FIbsi &V * PR add-ins FifE [Help] > [About QuickTest Professional] - forelsfggh * fity
add-in > o= EIREFIF | ET T QuickTest Professional

s
|ﬁ«7{ gl%@ ’ E’!‘p [CONTINUE] #&: > F'ﬁj?%‘ [Book a Flight] FI[1 -

ﬁﬁa‘T B M\ng,ljfﬁm‘»

PR RO SRR A T RS (R R R B -
i 8888888888888888)

7+ [Billing Address] /3% [Ticketless Travel] -

£ AF i [SECURE PURCHASE] #% » Biffiy [Flight Confirmation] FF ! -

L R 595?%[ fhfe

ﬁ%ﬁ SRR &Iﬁg [BACK TO HOME] [p'Z] Mercury Toursiﬁﬁjﬁf’!ﬁ’lﬁﬁlﬁl °
@»LF%”@J

7+ QuickTest » Bls# ™ 2% -iY [Stop) & » fiiH6ad -

el sy TR T BSRIUES (T QuickTest =SR] gk ™ [Record]
s E| [Stop] D [FE AU o

fwer e VA

I [File)] > [Save] H */i&ﬁ“ S -py [Save] & F'#JEFIS{ [Save] % ﬁ:"ﬂ;ﬁ‘ylﬁiﬁ 0
b~ fli [Tutorial] P& SKRESTS i £15% [Recording] -
253 [ Save Active Screen files] -

B [ % W £7% (Recording) #037s QuickTest i S| -

ST Keyword View [ IFIE 4

pi

V4 [ - QuickTest “F}H" Ui - [ (=R s > 25 Keyword View ') %l

Excel I‘P%Eﬂﬁ“méﬁ R B -

“ Keyword View [iop] 15 gt i€ 21 i3 -

[item] : I FETF@%?“Ev%ﬂﬂ@?iﬁllﬁ'ﬁéf%ﬁﬁ?rH'JEUElfJﬁ (F QHF [+ (test object) ~
E'"Pi% (utility object) -~ Eﬂ%’ﬂl‘—‘mi (function call) ﬁ‘)’}’ﬁ‘ﬂi (statement) ) -

[ Operation] :Elfiiﬁﬁrﬁﬂj YR Fiﬁmﬂjgm‘ﬁ gk (Click) ~ #3V (Select) -
[Value] : (=925 (argument) ’FJ@['E'}'?*F]’EE%T ORI PR 5 SRR T 5 -

-15 -
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m  [Assignment] : fji" [E[ABEE -

B [Comment] : ™R HIEREIA Flrp Elfiéfﬁjéo

B [Documentation] : [ IFss % B e fffih it (et BRI Y -

=y (R N E%LI B g IR PR o o PUR TR R RS EL S  FI B 2R

= ];M;h%]j‘»jd‘ﬁ}iﬂ (I

T2 [View] > [Expend AN A IR 4 o — {1 -

Ikern

-

,_‘ Welcome: Mecay Tours

- ﬁ Weleomz: Mercury T ours

I g ame
- pasEwond

'__| Signdn

v ,,'__"1 Fitnd & Fight: Hemcwry

- 5= FaraParl
= fiomM onth

&= farD ay

i) firFights

Cperatichr | Y alue

ar_'] Select aFlight Mercury

] reserveflighis

- ‘E‘] Btocis a Fligri: Mercurny

e R tickeiless
@ buylights

- Jj Flight Carfirnation: Mercury :

-8 harme

ESet E"memur}l"
‘Cetfecire ANERENNTEE
Dick 2.2

Seect Mew Tok!
Sdect 'Dec”

=PI e

ESeled 'Een Francisca!
Gmect  Dec”

iSeect DT

‘Seen CRusies
iOick 22

Cich 12,2

Ga “Micale”

ESB: E'Unnes"

S 1734

i5e N

Click 2.2

;Chck

q'__“| Welzoma: Mercury T ours ESync

Diacumentation

EEnbsr "mzncry'' in the "uzsiM ame" edil bow
Enter the encrypted zhring "'40828201 2351 2e8be N 11722020
Clck te " Sigreln” image.

éSeEcl ilern "Hew k" nthe "fromPor” s

Sel=ctilem "Dec” nthe "lromorkh" Il

[ B lsct itern "20" in the romD oy fat,

' Selectilarm "San Fiancizzo" ik e taPart'! izt

ESelal::t ilern "Dec" nthe "okl anth" ist.

Selzctitern 31" in the toDlan” lisk

Select radio button " Busnes:" inthe “wervClazs’ radio button oroup,
*Click the 'findFlighis” image.

Click the tescrveFlights” mage:

Enter “Micoke’ in the “papeFiztl" edit box

Enter "Jaoresz" ik the Vparsl 220 edit bow

Enter “12345 "in the “creditrumbes edit box

{5el e state of The "tickelless' check bos to"ON'"
Clck the "bupFlighi=" image.

Click the "homa" imaga.
;"-'-'ait for e Wb page to synchronize befoie conbnarg the run.

B, Keyword View & Erperl Wiew

m¢ww

| FH R ~H\E[ TR o

R

Hl%’!fi

[reserveFlights] ;

5 {7 Keyword View [ i ﬂF‘?

gﬂqaﬂp .

= R

[[l:[J BBk PR #t@ﬁjﬂpﬂgﬂln

N @l%%‘iﬁfﬁﬁé (e BR > 7+ Mercury Tourﬁe{ﬁf’!ﬁ’lﬁ [ Select a Flight: Mercury) lﬁ n{ﬁgl

[tem

Cperation

" alue

Dlocumentation

-;----g,'j Select a Flight;

- ™3] reserveFlights

bl ercuny

Click

2.2

Click the "rezerveFlights" image.
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RS LR R

L2 wl]

i Action] Actionl L [[algr =Y £7)

A wieleome: Mercury Tours Welcome: Mercury RLILEIFRS VA Y
?[fgf °

43 Welcome: Mercury Tours Welcome: Mercury Tours f‘\i_%ﬁ:‘ﬁ' [ £

userName %L edit box i £ -
Set fL 7t il edit box kU -
mercury FfkLbkjE = Ui -

-‘,'“ BE | zert ame iSet 'mercun"

B password SetSecurs!"4082820183 . | password *fL edit box iu €74 -
SetSecure i{&iﬁ]’[ﬁ* edit box = VRS [
P e JJJLITLL]%fEIijjJ—F'J‘: o

4082820183... H[l kL [ s «

5] Signin Ok 22 Sign-In L g o 78 -
Click L7 iﬁéﬁfﬁﬁ%‘[ @faﬁg = p':}gm (o
2, 2 PPk [ e PLRIRE P X, Y AR

TR 3011 BT Keyword View F7gfian (Rt » 25 s ISR (i TS - A1
FIRIE B -

Y& Keyword View %’TF;I%’E'% FIEYF ﬁ%iﬁ% QuickTest Professional User's Guide
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4. FS T IARE A
Hi o RS B > QuickTest f BT 1A= sl i g SREpogi = 0 2 v ok

4.1

%

BSR4 ffh i Bl -

RN
B o oy TERGRHIRVRTE ) SR ARSI A -

1.

= QuickTest 2 (ITTMIEASIF YR 4

571" QuickTest ivF'EJ?T E’!I‘E [F'ﬂﬂﬁ] > [#4='& ] > [QuickTest Professional] >
[ QuickTest Professional] -

m BRI - R [Open Existing] -
B [HYN2H Iﬁ‘@kkﬂﬁjﬁ% » fE [File] > [Open] fhlRliiE ™ 219[ Hiv [Open] #%: «
7 [Open Test] S/t - 32 I " Recording , HREHI+ » SRR (HITF] -

TR D 7 s A N

QuicKTest fi | 45 3t o e WESAH B 11« 4 SR » A st o )
SR -

Eﬁf{ [Tools] > [Options]) :#{& [Run]) FI& > 7+ [Save step screen capture to test
results] ZFif[1 > ZE [Always] -

RirZ [OK] F—j‘%ﬁfJ [ Options] fﬂé%ﬁl?jﬁ‘ .

e = = POTRR

R [Run] 2 - @hLEEE [Test] > [Run] - F':,%JFFIT [Run]) “§¢§“HEJ?LT .
%33# [New run results folder] > & %' %ﬁg@gﬁlsﬁﬁuﬁg% e

K2 [OK] %%FJfJ [Run] é“‘:’j‘ﬁijﬂ/ﬁlfgj .
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;F;zgui?jeit F'afl’?fr {ﬁ~‘EffJ?¥HEﬁ?%§ G 2 T ?_EIJ%‘%M [ G RREE QuickTest J]1f7 i i F IR
ﬁl: FllFj 2 QuickTest {1 Keyword View ¢t ffi f <1 g » 473 |1 = roafassl
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42 SIPTERESEHEN

“Fif,‘ QuickTest = S 3FZVI 4 > %‘*g[‘ﬁr fsrygu ﬁgjﬁlrﬁ

Results tree

Test results details

Iteration summoar

Status summary

~ IR RS

B 5 BEES testresults tree o I

E- Recording [Resl] -

Test Results

Recording Results Summary

. E& Recording Tkeration 1 (Row 1)

Test: Recording

Results name : Fes
Time Zone: Eastern Standard Time

Run started: 4/17/2004 - 14:04:25
Run ended: 4/17/2004 -14:04:38

lteration #

1

Status

Passed
Failed

Warnings

?%ﬁ”{hw

= MR B R R AT«

Pt o 2O R SRR PR R e TR ()

T s - R ﬁ”r‘émfjﬁﬁ—wﬁﬁg I q«g‘ll—i fuh A o i r;r%#_' QuickTest N [ﬁ Ay

PR RN LR W (5 > B VUG- W

(iteration) -

JT_—{E? ?‘T

YRR (Vo ORI A - D

N W RN -

b P P TS ~ P B

SRR = SY TR PR WV ot i R PRERLEEEY PRS- T 35

[k 53 fm

o

PP QuickTest i '] (AT UsREpo i (B IRV A - Bl | R R « 48 *fﬁﬂﬁ'g’:&

QuickTest £/~ JHZ 4l 4 f JF_,\Elﬁg\l | 7;,’5. fap

1 A RS

S, TR TR - 7 R e e vt

R
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i test results tree » % [f|(+) [ Test Recording Summary] > [Recording lteration 1 (Row
1)] > [Actionl Summary] > [Welcome Mercury Tours]) > [Find a Flight: Mercury] -

# IV test results tree |11V ["fromPort":Select "New York”] -

Results tree

Test results details

Active Screen
image

B Aecording [Res1] - Tesxt Aezults
Fie “iew Toos Help

FETRRARA +~~ 7|

= T Test Recording Summay ;I
@ Rur-Time Data Step NEIITIEZ
= Recording Treration 1 L s
= D Recording evation | (Row 1) "fromPort":Select "New
El- 48 Actionl Summary -
= ﬁ Welcome: Mercuey Tours YD rk.

- {j Weleome: Mercury Taurs

s | I W TR I

g ek
o "fromPart " Sekect "New Yar Object Details Result  Time
E-:l "Framfontn" Select "Dec"
o= "FromDay" Salect 23" "o mPot"Select ?:I'E':‘ 44182004
E—j "tePort" Select "San Franrisco” Wz il Y E:: -18:03:42
E—j "teMonth" Select ‘Do o
E—:l "temay™ Select "3 1" LI
ﬁ "zervidass" Select "Busimess" FLIGHI FINDEHR ﬂ
| “findFlights" gk,

o8 Sslect & Flight: Meroury lJze our Flight Finder to search for the lowest fare an pa

19 Book aFight: Marcury you've haooked your flight, dan't forget to wisit the Mercur,

19 Ficht Confirmation: Marcury reserve lodging in your destination cily.

ql’j Welcome: Mercury Tours

Flight Details
Type: & Round Trip < One

P assenigers: IEI

For Help, prass FL

Departing From:§ Mew ¥ork hd

One ﬂ,pr | |18 =
Arriving In: | Zurich 'I

Returning: | Anr "I 19|= |:4|j
| r

[Rzady [ | 4

PRI W it e = i - T3 BIRE -

B SRR Testresults tree & F— [EW ERRLERY

u ‘F[f“bﬂ Test results detail @ ¥LE TV ER > IS

[ | *F[* kL Active Screen : i [FHIEEH R FE{}EEE‘V* PR

F',”%ﬁ%j test results tree _FAYAHE! qgﬁli , f’n\’%’ﬁr& [Active Screen] [l Z][#hk "’;Eﬁﬁfj:ﬁf}?l . ’5,[
'“Eﬁfﬂi test results tree FAVIFESH R (R [P FEGE S RN o R ET E'}'Eﬁf’fjiﬂf&'l

It s E#”inﬁﬁ%"ﬁ?i SIS o T PRI Eﬁfﬂi test results tree iy
["fromPort":Select "New York")] - [Active screen]) r]ffmﬁﬂ‘ BeAE=f=pY [Departing From]

A -
R R
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Eﬁfﬁf’_ [File] > [Exit] -
ST o e IR T S AR

.
N
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5. B AARY
TR PR o g - T RS2l Mercury Tours & ﬁjﬁlﬁf#,‘f%ﬁfﬁleﬁgwgliﬂuﬁ%ﬁﬁgm o %
) Ia}qﬁﬁﬁﬂ ﬁ@\gf ﬁfg;ﬁ*ﬁl SR SE LT *FEE”

5.1 U'Ejg;[fgﬁg*, %’Jﬁlfﬁgiﬁ
QuickTest Professional # i I'] ™ EI%‘%‘@ E’!,‘

o R A i fy]
@ﬁéﬁ%g\, E’J[‘ ﬁ%ﬁ, PPl 75@3, % [ radio button ﬂ?\, Pl v
ﬁ%ﬁl}rﬁ ﬁ@\, E’J[‘ ﬁ@\, @IH, g E ﬁ@\ @IH e VR RL
?%Fﬁﬁﬁgfﬁﬁ ﬁ@@h?hfﬁﬁﬂﬁjﬁf ﬁ@@f%ﬁfi JFA ﬁf;.#pﬁ
;{ﬁfj ﬁ%g\, E’J[‘ ﬁj‘qg‘, ;Fﬁgl PR ﬁ\ﬁ\l ;[ﬁgf #h FI\JEﬁ i “&fwﬁijg I i_ﬂ[ A j I—’p‘{g’ﬁfjig_l,ﬁ:,
(link)
ey ﬁ@‘, %ﬁgl RS R ﬁ@\, F:f B .“g‘;ii_?\, Dt ',;;UIF:I* By Thpud 3
wﬂ]}ﬁﬁﬁ%g\[%ﬁ E{z[ |:/L 3[ INpae
R I
FIRRAET | FEVAIEI ARG | W R GDRUE O - K0 L R
I AR
IJPE
ORI AET | SRR | AR R AL
[ T
= f A F‘%
Accessibility i | |dentifies areas of | Check if the images on a Web page include ALT
ﬁl %!T a Web site to properties, required by the W3C Web Content
check for Section | Accessibility Guidelines.
508 compliancy
XML 11@*, Elﬁ ﬁ@ﬁ XML (A9 | =8 1 XML ﬁﬁi)}ﬁg\l %El H\;}fﬁg\lﬁ AU XML %
PJF'FkI’ XML JT;E\EIJ%E?Q;,ﬁgT %jijﬂgﬂéﬁﬁ ;[ﬁgl mfpﬂ’g[[ EIJF[U
XML {F -

(i) e SARTSRE B A B 4T P A A S T A B B R R
77 RN, B E L B
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7= : When QuickTest creates a checkpoint, it assigns a name based on information inside the
checkpoint—the checked value, for example. The checkpoint name remains unchanged, even if
you subsequently modify the information on which it was based. Keep this in mind when looking
for checkpoints displayed in the Tree View. However, note that QuickTest may shorten the name
displayed in the Tree View.

fela— W R ’Iﬁ:ﬁ[@ﬁ ﬁ%?ifj% QuickTest Professional User’s Guide ©
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rEeles
[ilﬂla%ﬁ,ﬁﬁ EN %‘*Ii Book a Flight A1 1 A5 i iy Ry ‘Elﬁfgg\%“ by A
1. %~ QuickTest ™[ J’?S‘ I'Recording | JH[Z40 4

00 QuickTest 2 F'EJF’F’ %!1 [F'ﬁJiIF'}] > [#=VE& ] > [QuickTest Professional] >
[ QuickTest Professional] -

u f@ﬂ[‘ﬁﬁ?#@&’fﬂﬁlﬁiﬁ‘ . Eﬁp [ Open Existing] -
W BRI R - B [File] > [Open] @Rl 2] pY [Open] £ «
it [Open Test] S5y i - 2 MM " Recording ) WEHIE » SRR [Open] -
2. JFHIEYEIE bRy €140 T Checkpoint ; V4
E’![‘E [(File] > [Save As] - iRV A o fipsy " Checkpoint ; -
3. FEI?J [ Active Screen] flLfF lpf]gu
(Y INESE A | QuickTest*F “~ 4y [Active Screen] - gﬁgj S'%[| Hi [Active Screen]
e @ RLEEE [View] > [Active Screen] -

4. EIVEIE A R
RIS S A s e oo Ot

7+ Keyword View |1 > 5[|(+) [Action1] > ["Welcome: Mercury Tours"] > ["Book a Flight:
Mercury"] -

Elﬁ?ﬁﬁ?ﬁ = 1E I RS RRL ["passFirst0” Set... ] fﬂ[ﬁ' VR Bl ivpETY
[“"passFirst0" Set...] ™ [ B0 | iR 467 i o
{%?Viﬁfﬁ?ﬂﬂ%*ﬁﬁiﬁéz » 7 [Active screen] F‘%E? [Book a Flight] AffF1 - iy = B Ivpats
ﬁc“ﬂﬁ’ﬁn%ﬁziﬁ;@ﬂs o (AT I 2 & Pt T First Name edit box f{1 e

5 gi- [[ﬁ‘@ﬁ‘éﬁﬁgﬁgﬂr

#f [Active Screen] f[ifi First Name edit box Eﬁiﬁ'i{%@% # WV [Insert Standard
Checkpoint]) - F‘F'EJ‘T’PF [ Object Selection - Checkpoint Properties] fj’ﬁ [ﬁjlgil

Il
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Object Selection - Checkpoint Properhies

E---E_ﬁ "wiebT able : Home
=58 webTable: 5IGN-OFF
El---ﬁ "WebT able : Pleasze review your travel itinerare and

Elﬂﬁ "WebTable | Please review your travel itinerary a
El---ﬁ:_;ﬁ WebTable : Summary
E---ﬁ "WebT able : First Mame:

ﬁ%l?—,’d [ WebEdit: passFirst0] ¥L#5v % » Eﬁfé’_ [OK] -
F’ﬁﬁﬂ?i{ [ Checkpoint Properties) faafﬁ:?,;ﬁlgﬁ o

#" Checkpoint Properties

dizabled 0
hitml tag INPUT
innertest

name pazzFirstl

readonly

ST PR
(] [name] ﬂiﬁ[’lﬁ'?’l N R
B [Class] RLgil# ORI - WebEdit F i i L[ edit box -
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i [Typed Mt 19 [ABCY [ 47 it ALl ik
S5 P21 QuickTest f it [FFRET IS [0 i A RETE ') Rt

e il |

htmitag | INPUT INPUT il HTML R fiH 1S INPUT 442

innertext &iﬁﬂé‘ﬁﬁﬁjfli > innertext fIYfifl RL4f% o ﬁ%ﬁ,
R A8 0 B TURL kL

name passFirst0 passFirst0 1§||:a' edit box iy {7 -

type text text fL. HTML ’Fli[ﬁﬁ%ﬂ li?['[ﬁ* INPUT P2t pio
FRE]

value <ft:x> T lﬁl[a{ edit box i * pud 4 -

(SRR 4 [ ooy g2

}}f@“?ﬁ?ﬁl@??&f@ ] ﬁn&&ﬁfﬂj [OK] - QuickTest F‘ﬁ?} B VA R i — (MR

i

v‘,rj Book. a Flight; Mercur_l,lé

¢- paszFirstl Set "Micole! Enter "Micole" in the "passFirst0" edit box,
i 2Firstl : CheckPaoint 'passFirst0] Check whether the “passFirst]” edit box has the proper
BB passLastd et MJones'”! Erter "Jones" in the "passLast] edit bos.

6. [ HIEA
Eﬁf{ [File] > [Save] ﬁ&ﬂ&ﬁf{j 2F)Fpy [Save]) & -
B {s\'ﬁﬁ. “JLI‘U—FISJW%’@ i ﬂ’?}%}fﬂﬁfjﬁﬁg\l g’g]‘
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5.3 WA E
&iﬁl’[ﬁ‘%ﬂfé ’ fﬁﬁfj’ﬁ@ﬁ'“ [k gﬁ ik %ﬁﬁﬁ%ﬁﬁﬁf' fsgiadi (link) 1) [ pogisl
R SR OB~
Lo EVRE BT
i+ Keyword View 1 > 5ff|(+) [Action1] > ["Welcome: Mercury Tours"] -

T =

2V Keyword View f[1ji ["Book a Flight: Mercury”] AfffE1 - 7 [Active Screen] ﬁ%ﬁiﬁ][ﬁ'
A O -

2. - ﬂafﬁ{ﬁ‘gﬂi%ﬁgﬁ
% [Active Screen)] H{=— #H# 3%’»};;6?,% » 33V [Insert Standard Checkpoint] %’?ﬁﬂ
?'9( [ Object Selection - Checkpoint Properties] é’%ﬁﬁ;ﬁﬂ?ﬁ o pIE g A T ] ’%Tﬁ?[}f@
i BLEIVIOPIE =G T- AR

Object Selection - Checkpoint Properties

E"'ﬁ Fage : Book a Flight: kercun
E---E_ﬁ wehTable - Home
E---ﬂﬂ “webTable : SIGM-OFF

Eﬁ WwebTable | Pleasze review your travel itinerary and mak
E---E_ﬁ YWiebT able : Please review your travel itinerary and
LB webTable : Summary

Eﬁf{ [ Page: Book a Flight: Mercury) (7 H¢H) w.&&ﬁ% [OK] -

# %F'ﬁj‘?ﬁf [ Page Checkpoint Properties] %ﬁﬁﬁl@f o
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&' Page Checkpoint Properties

load time

nurnber of images
nrnber of link.s

I HTL source. EQRHTMESooces. |

= BT LE0E =l A S e

Fﬁf R > QuickTest %’jrﬁ@} SHTF ORI OB > RS O i i’[‘fﬁfﬁ‘ﬁﬁ
T R -

QuickTest s fi i link 19 URL I'f 5 [l FFURHILEL ) 7 T <
HoE o K [0K] -
QuickTest F"ﬁi Book a Flight: Mercury sfftf1 ™ 1~ {148 f gﬁ
vnE'I Book a Flight: MEFCUF}'E Check. gEheckF'l:-int["EDDk... gEheck whether the "Boak a Flight; Mercuny' wWeb page has the
3. R A
B [File] > [Save] pyRLE " /5] i [Save] ##* -
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54 fified
&;F%I’[ai%ﬁﬁ o %ﬁ@j@ ER Jﬁf‘ﬁg}%ﬁ firfh & ["Flight Confirmation"] A1l [fL_F}H'EFJ
["New York"]) -

1. ERIg iﬁﬁg\, %’!ﬁlf‘l,—ﬂﬁfj
7t Keyword View |1 > 5f](+) [Actionl] > ["Welcome: Mercury Tours"] -
23V Keyword View f[ifiy ["Flight Confirmation: Mercury"] Fff! - i [Active Screen] %’7%7
2. @j@%{ﬁﬁ&ﬁ
7+ [Active Screen] f[i - :#3V%: Departing, ; » HpY TNew York ; -
SEREIVAYY 3#]@6?[% Eﬁf;:?_ [ Insert Text Checkpoint) F'afjflg% [ Text Checkpoint
Properties] ;Tﬁ:f,ﬂ}ﬂ Tfirf o

&" Text Checkpoint Properties

Checked Test |_

o iz

Fil}‘ [Checked Text] 15l ™ £+ =& H H[E\ﬂj » 7 [Constant] #i# p%’g% o3 TV A Y
o iﬁ% HiEkL QuickTest v = = 4 E\Hj‘ﬁ’?g,w[ﬁ@ (SREEE
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% [OK] RIS -
QuickTest (7 % HIHHI 4 T b [ S 4 b S & S 4 i 1o [Flight

Confirmation: Mercury"] Afggir ™ »
v{j Flight Caonfirrnation: M... EEheck EEheckP‘uint[”Ne... EEheck whether test in the "Flight Confirmation: Mercun' Web p
3. (W MR

R [File] > [Save] viLRE " 215 iy [Save] #E -
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5.5

W 245
?iiﬁf[ =R rﬁj{j%‘*@ﬂ - |ﬁ%#‘ﬁ%§‘%ﬁ 1;%3 [ Book a Flight: Mercury]) nﬁgl Ft[ﬂ[ﬁﬁllﬂﬁ?ﬁlfjf%?
£ o

Lo EVRE AR

i+ Keyword View 1 > 5ff|(+) [Action1] > ["Welcome: Mercury Tours"] -

# IV Keyword View f[1f% ["Book a Flight: Mercury"] aﬁE[ o 7 [Active Screen]) F‘ 2 aﬁE[
Ui e
ERE Rl

7t [Active Screen] {1 > 7 57— |[41ﬂﬂi3:ﬁ1]%?% = (New York to San Francisco) —270— %ﬁ
hig}; (B JREIV [Insert Standard Checkpoint] -

F"f f'1% [ Object Selection - Checkpoint Properties ] a:jﬁﬁfi[fi,. 0

- B JtzF B IVpUEL WebElement: 270 » lﬂﬁij £ F;IE’J*EE F— gy WebTable $7{F » 5V
WebTable: New York to San Fransisco -

Object Selection - Checkpoint Properties

E---E_ﬁ WwiebTable : Home
=-5H webTable : SIGN-OFF
El---ﬁ WwiebTable : Please review vour travel itinerary and

: Eﬁ “WiebT able : Please review your travel itineram a
Eﬂ ‘WebT able Summar_l,l

EEC 8 En [Active Screen] b oV J%TQ”JQT@:EEFF o B [OK] -

%%F'ﬁ?ﬁr [ Table Checkpoint Properties] ‘;’éfﬁ—pﬁl@f » B %Zﬂﬁiiffﬁpq[ J“'Fk[' o
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2385 Table Checkpoint Properties

v 12/29/20
v CLASS v PRICE
¥ Buzinesz |v 270
v 12031720 |

v CLASS v FPRICE

v Business [» 270
o1 o

L+ Mew ok to San Francizco IE

e

FHERLS O WS Sk e RS AR - S O R T v
AR B RLE SRS - BT EIV Vs o

ok Ao RE IR ™ TN SO > SRETESY S T 5‘;3(-/“%55 T, ﬁfi 270 %
R SR o HFERG T QuickTest %ﬁfa:%ﬂ%h"ﬁ * i -

Mew Yok, 12429420
FLIGHT CLASS P'EHEE
Blue Skies  Coach v 270

San Franc 12434520
FLIGHT CLASS PRICE

Blue Skie  Coach 270
1

Pacerninean

B ¢ S Ry SR S o §) R A IR -

%‘Tiif [OK] Fﬁﬁﬂfﬁi‘ﬁlﬁpﬁ?]ﬁﬁ °
QuickTest Fﬁfﬂﬂﬂ%’«}éﬂi fl1 > ["Book a Flight: Mercury"] FIf1™ i b ﬂﬁi?&ﬁﬂﬁg‘l Eﬁ
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gEheck gEheckF'u:uint["B oo. . gEheck whether the "Book a Flight: Mercun Web pag

vﬂ Eook a Flight; kercum
Eﬂ Mew York to San Francizco Check, EEheckF"Dint[”Ne... EEheck whether the content of specified cellz in the "M

Enter “Micole" in the "pazsFirst0" edit box.

Set "Micole"

3. @R
%’![““ [File] > [Save] phlifE T 23] Hpv [Save] $E:

1=
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5.6 iﬁﬁﬂ

R B
&iﬁl’[ﬁ‘uﬁ,ﬁé”\ﬂ% R 07 6 TR - 5

H'V

1. "wefil7El Keyword View g 7T HIEH 4

1 [View] > [Expand AT fRL7 | [ Y s ol - 1 Keyword View iy s

AR

R S

Item

Operation | alue

Documentation

- jWeIcome tercum Tours
w48 Welcome: Mercury Tours
q"m uzertame Set "mercuny’’
i q“m paszsword SetSecurs: "4082986239. .
i b Signdn Click 2.2
¥ q',__"] Find a Flight: Mercury
&= framPart Select  "Mew York”
- 52| fromi anth Select  ("Dec"
- ] fromDap Select  "29
-] toPort Select "San Francisc...
-] tobdonth Select "Dect
-] toDay Select e
8 servClass Select "Business"
i b findFlights Click 2.2
- ",—j Select 5 Flight: Mercury
. -1 reserveFlights Click. 2.2
Page checkpoint — q',_j Book. a Flight: Mercury Check CheckPaint["...
Table checkpoint ﬁ Mew York ta San Fr..: Check CheckPaint[". ..
M pagsFirst] Set "Micals"
Standard g'? passFirstD Check CheckPaint"..
checkpoint -1 passlastd Set "Jones"
--TBE creditumber Set "12345"
- ticketless Set "o
o] buyFlights Click 22
Text checkpoint — é__"'l Flight Confirmation: Mer... : Check CheckPaint["...
_ T home Click.
------- Lo I welzome: Mercury Tours | Sync

2. BER TR

K2 [Run] 4L [Test] > [Run] > @I [Run]
results folder] -

HiZ [OK] -

3. ARG

yvg%lﬂ o
HRESE LB QuickTest ¢ F I

SR

Enter "mercury’’ in the "uzerM ame'" edit box.
Enter the encypted string 40823862 3%ea469e 71
Click, the "Sian-In" image.

Select itern "Mew York" in the “fromPort” lizt.
Select itern "Dec" in the "frambdonth list.

Select item "29" in the "fromDay’ list.

Select itern ""San Francizca' in the "'toPort" list.
Select itern "Dec' in the "tobdonth' list.

Select item 31" in the "taDay' list.

Select radio button "Buziness" in the "servClazs"
Click the "findFlightz" image.

Click the "rezerveFlightz" image.

Check whether the "Book a Flight: Mercuny' wWeb
Check whether the content of specified cellz in th
Enter "Micole" in the “pazsFirst]" edit box,

Check, whether the “pazsFirst]" edit box haz the [
Enter "Jones" in the "paszsLaszt0" edit bow,

Enter "12345" in the "creditnumber” edit box.

Set the ztate of the "ticketLess" check box to "OF
Click the "bupFlights" image.

Check whether test in the "Flight Confirmation; ke
Click the "home" image.

‘Wit for the Web page to synchronize before conl

253 [New run

IR A
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Hi: QuickTest ¥ S IZVRIH » WIS SR b1 7 F RIS » [ = Ve i U
kL Passed » “HERLTL - B E [l friHTkL Passed - R fiEEAA AL Failed » %)
1;?@7 %ﬁFailed o

4. WA B
T+ test tree 5fE](+) [Checkpoint Iteration 1 (Row 1)] > [Actionl Summary] > [Welcome:
Mercury Tours] > [Book a Flight: Mercury] -

+ TV [ Checkpoint:"Book a Flight: Mercury") -
rﬁ,i%gm [ Details] giﬁﬁ E IR Mﬁ@ E,hzf JPw\E'X?%\' » TP E lﬁ@* Eﬁﬁ@ﬁ el fing

HF 455y [Details] ﬁiﬂfﬂ I R e e A A B AN
IR E I E S AT ! o RS AL T 5 R A E b RfoaE UL passed ¢
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E Checkpoint [Hez1] - Test Hesults

== 7|
Mheckpairt Summarsy

- Tine Dtz Standard Checkpoint "Book a Flight:
o R Mercury": Passed

_ ¥ welcome: Mercury Tours Date and Time: 4/19/2004-10:37:27

qrj ‘alcome: Meroary Tours
qrj Fird a Flight: Mzrcury i
&1 Select aFicht: Mercury Details
- o ) Bonk & Flight: Mercury

Fage Check
E- w# HH Mew vork bo San Franciseo
TE 'paccFirctn":Sek "Niccle” Property Name
,f! passFirski [oad time
q- 'passLastd’: Sek "lones
B ‘Credimumber'; Ses * 123495
&7 "HickefLess™ St 0N
G 38| "busyRichts™ Cick Checking the links captured addresses vs. the expecied one:
H- o* o] Flight Corfirmation: Marcury :
{j ‘Weloome: Meroury Tours Hiil 5 =T

number afimanges

nurmber of links

Home
Fligghts
Hotels

5. ’lﬁﬁj?«)fﬁ’lﬁﬁ‘[ R
it test tree iV [Book a Flight: Mercury] FfF 1 fil(+) [New York to San Francisco] -
F# 9V [ Checkpoint:"New York to San Francisco"]) -
7 [Details s 0 ') € 2 AR i BIFOREAPHR = ') T SRRSO
PR PO 1 B PR RS Y2 E R ORANE T Y R ) F["'f{\i?f[ﬁ'?‘
’Fﬁﬁ%ﬁl g’!ﬁﬁﬁl FOAR A i o BRI AT o B A Eﬁﬁ@%%‘ £, passed o
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Standard Checkpoint "New
York to San Francisco":
Passed

Date and Time: 4193/2004-10:37:27

Details

Yerification type: String Content. Settings: Exact match -
OM; Ignore space - OMN; Match case - OFF. Results:
Checked 1 cells; Succeeded: 1; Failed: 0

—
—
.
T
—
—
—
—
—
—
4| |

6. Aw AR A
7t test tree fiy [Book a Flight: Mercury] AffE! 5tif(+) [passFirst0] -
™ 3# 3V [ Checkpoint:"passFirst0"] -

7+ [Details] E{‘ﬁ?"'ﬂcﬁ‘ Pl %ﬂﬁlfil?—ﬁ%l?‘%ﬂﬁ# SR L R o g R (L
([ o FIsg b BT E ) Tt RS ERIES - B TR RO RL passed -
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=
Standard Checkpoint "passFirst0®:
Passed
Date and Time: 4/15/2004-10:37:28
Details
passFirstl Results
Property Name Property Yalue
html tag MFLT
innertext
narne passFirstd
Type temt
value Micole
[

7. MY 3*’1;%@ E’!ﬁuﬁ‘,%‘\l

it test tree iU (+) [Checkpoint Iteration 1 (Row 1)] > [Actionl Summary] >
[ Welcome: Mercury Tours] > [ Flight Confirmation: Mercury]) -

+3# 9V [ Checkpoint:"New York"] -

7+ [Details]) gi,lfr*‘rﬁ prlEEy s )[ﬁj E’ﬁzur,fl:%%\' ) IW}@HQ/J 7[}%3 E’ﬁa PRt ESEEY
[}j?ﬂ 1 BT ﬁ%g\ E’!“p JﬁHé,J L passed -

Text Checkpoint "New York": Passed

Date and Time: 4/15/2004 -10:35:08

Details

Text Checkpoint captured *New York®™ betwean Departing and
to San Francisco 12/

batch case: OFF

Exact match: OFF

lgnore spaces: Ok

8. FRPfRRIRS B ot
Rt [File] > [Exit] tfRHIZSRHH i -

f
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6. ("

6.1

B (R ’frﬁ PRI P 278 T [RIFIRR TR o SRR By =i R

R F['f’ FERI T 10 32 T [ Ellﬁféﬂ e *ﬁw%’“@f?ﬁ NI o f I R T

El%f}{jzﬂ 10 A 7 [file el ot ey ? Pl [P Jﬁ%ﬂ v | ‘ }115‘9?*%! JHNE el

e SRESAE QuickTest fruseg| B @* 51057 [ﬂ Y S ] (e SO chkTest =]
2Rl ‘ﬁt%" 1T ] ILI:_], 10 L’?*?H = 10 h%??*E?f,TEFfF'U‘?EUE;ﬁT °

TR R

RO SRR T RS | ORSR RV fl o ERSRL B
i+ SLE 5 TR SR © (PSR « g v B0
PRI IO RSB R B T g0 e I WU R ) T o S
R

1. %= QuickTest ™[ JFIF I Checkpoint | JHZ¢Hl 4

571" QuickTest M'EJ?T %!TE [F'ﬂﬂﬁ] > [#4='& ] > [QuickTest Professional] >
[ QuickTest Professional] -

u f@ﬂ[‘?ﬁ]ﬁ?@iﬂ]ﬁﬁﬁiﬁ > K [Open Existing] -
m EIM=RITECDE R BE [File] > [Open] @RlfliE™ S5l [Open] #7% -

7+ [Open QuickTest Test] tfﬁf,;ﬁ%l[fil 1Ay T Checkpoint | JHIEVI4 - ’Zﬁ&&ﬁ_
[Open] -

2. JFHIRSEIA BYEss €55 T Parameter | R4

R [File] > [Save As] - ifll¥l 4 7 fim5 " Parameter ;-

3. ﬁ“g?i [ Active Screen] jgﬁﬂflgﬁm

(XU A UchkTestJF "~ Hjv [Active Screen] > E,!,“f* 23] Fp [Active Screen]
e p‘/f;%ﬁ [View] > [Active Screen] -

4. ?ﬁgf.% [Data Table] ﬁr'ﬁjflgiﬁfj

847 QuickTest ™ 4327t fl [Data Table] - ik~ =5 1Y [Data Table] #¢ »
fcgp_ [View] > [Data Table] -

5. EIVEIBH{HUY S

7t Keyword View f[1 - 5f(+) [Actionl] > ["Welcome: Mercury Tour"] > ["Find a Flight:
Mercury"] -

- 40 -



oldsidney 5 25l http://iwww.oldsidney.idv.tw

+ Keyword View F]l&#‘““"fromPort"*F WY [Value] 6 - JREF] %J‘E‘af al ﬁ%ﬁl_l . %'7
?T [ Value Configuration Options] gmfﬁfpﬁlgi[ o

Yalue Configuration Options Ed

6. Ry
Eﬁfé’_ Parameter o J[ifF=— < » faiEp’ 0[S Erffd 2V 5 (New York) lF”P f' taralins

% 3#is [Data Table) jf_,,[[n = iFﬂ AEE T S ll—&gﬁu@ﬁ §-QuickTest iy Data Table f[1
‘a‘vqg

1= [Name] #f ¢ %“L i p_ltem » ﬁ% % X 55 departure -

DrataT able |_

hE [OK]) Ffaﬁfbﬁﬂgiﬁ‘ > QuickTest FT& Data Table [ 1§} departure ZEeffch > &7 5 F5 7
% New York fiufifi - [ New York Fﬁﬁ%@?ﬁ[{%’}ﬁﬂi Fhi= E\ﬂj R pup BT [l fifi o

-41 -



oldsidney :‘:’;%??ETF—TJ http://www.oldsidney.idv.tw

- ‘ Achonl
- i‘ﬁfaburnac Mercuy Taurs
." o Wekame: Maroury Tous |
‘_J Frdd & Fight: Memup

iSalect EDalaTable{"d... ESBIed itam £the valus of the apecisd Data Table coumne b he * fomPok”
lect E"Dec" 'Selev:'t item "Diec' ' in the "flomd oeth " list.
E frarnDay S-:Ind inag {Selectitem 20" in Boe "lromDay ot

0
New York, ] Flight Detailks

rIF-pnrhuP |_ Type: & R

i —
Global AER, Aclive Smeen

fﬁJEﬁﬁ%ﬂﬁ B= - T Keyword View plifiosd (= o ¥ 25 Vi > PR RS
[ "fromPort" Select "New York") - Z7- > iFHWEUE:% L ERAg Y 5 [fromPort Select
DataTable(“departure”, DTGlobalSheet)] - ?5] &’!‘ [ Value]) ﬁ}ﬁh"ﬁﬂj » [Value] #ighd
F"f@’?ﬂl[l* q%"[“”’?ﬂ » F A l%ﬂﬂﬁ*ﬁ“'n\*ﬂ&é‘r[ RERNII N fifi}L7$-Data Table f[1fY
departure gt f[1IZVE o

New column in
Data Table

62 HivRIAIE" R

JifEhL » QuickTest %«7 ‘- Data Table [ 1% 2l o 7 F50H - o %’* 17+ Data Table flrp™ R1 %
S nALEREOR] > F QuickTest i1 [l M LGSRl R £ -

1. 7 departure h}ﬁl’iﬁﬁﬁj‘ R 27%vE
i departure ffi % pu37 5 > g CPortland
MY 5 i"??g’a’nj‘ MSeattle | -
™ [Enter]) -
2. @R
Eﬁ" [File] > [Save] fAvhLBiEE" S5 Ffiv [Save] #6*

6.3  [SIUE[BEr AR
5 TR RRB S D™ 8 1= (AR S O TR el (R RO e 7 %
Ly v;i-njgﬁ, g o ﬁﬁ g’g—ﬁ:aeg\r]’ I “:J*FI S ﬁ%&#‘ﬁ:ﬂbgrl USRS N o

E

1. (& Jﬁ%@ Eﬂ,‘
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7t Keyword View |1 > %f](+) ["Welcome: Mercury Tours"] > ["Flight Confirmation:
Mercury"] -

ﬁ;&&ﬁ%?ﬁ%f,% » 33V [ Checkpoint Properties] - F'aﬂ?% [ Text Checkpoint Properties]
S -

& Text Checkpoint Properties

Checked Test |_

et

o

2. B TR B R
+ [Checked Text] v [Constant] ## ﬂjp][ﬁ%ﬁﬁ "New York ; » i J[ZVAI4 2 V0
[ > ag Y A i RS ED T New York )
uE [ Parameter] o

Eﬁfé’_ [ Parameter Options] ¥4 » F'ﬁj’?? [ Parameter Options]) %ﬁiﬂﬁlgfl o
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Parameter Options

DataT able |_

T [Name] S #(EE]EHHI e FdepartureJ }“F'I LIFJ,[[_{—“I’ 3@3[ %ﬁﬁlgj departure ﬁﬁ"ﬂ‘ H lElfJ
> A5 RLbG RO -

{52 (OKY SIbf  #=0 ipsny -

fi o PR 4

i [File] > [Save) (ALEiE " =511 [Save] 4 -

6.4 ETTOIM D BEUHIRHORR
FU o (BTG S5k pY T Parameter | JIEVAI A 7 - QuickTest %’T[El t| Data Table 1
departure fig¢ ofifi > e = EIEETA

1.

2.

5 T Parameter ; JIEVH4
215 A9 [Run]) ﬁ&i&f [Test] > [Run] - ﬁﬂ?ﬁf [Run]) fﬁfﬁjﬂﬁlgﬁ o
7Y [New run results folder] - JEI%?’E'HEI%I’QEJ °
RirE [OKY Bl HIEHI 4 - ﬁi‘hﬁﬁ“uﬁ' ’ F’TE' I EV?EUE*@??%J@EA
A A
B |teration 2 :

it results tree |1 > HLfH(+) [Parameter Iteration 2] > [Actionl Summary] >
[ Welcome Mercury Tours]) > [ Flight Confirmation: Mercury] -

TV [ Checkpoint:"New York"] -
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B Parometer [Resl] - Test Results

File “iew Tools Help

FETRRARAQ |+ =

Test Parameter Summary
B run-Time Data
-,.r['h Parameter Teeration 1 (Fow 1)
-3¢ Parameter Leration 2 (Fow £
M- ﬁ SkartUp Browser
- X ' dckionl Summary
=] xi Wielcare: Mercury Tours
gr_"l Welcame: Marcury Tours
qrj Find 2 Fhight: Mercury
H- q,rj Select a Hight: Marcoury
- xﬁr_ﬁ Book a Flight: Mercury
=] ,,-q.r_"l Fhoht Confirmation: Mercury
o i'f Checkpoink "New ¥ork”
W "home"- Smart Identifica
™ "harme": dick
B & Welcame: Mercury Taurs
H& Pararmeker Ikaration 2 (Row 2

4

For Help, press FL

|

?
N - || d
Text Checkpoint "New York™:
Passed
Date and Time: 4/19/2004-14.44:09
Details
Test Checkpaoint: coptured "*Fordland® between
Departing end to San Francisco 12f
latch case: OFF
Exact metch: OFF
lgnore spaces: QR
-
Flight Confirmation & 2004-04-19311965
Departing A
Portland 10 San Francisco
1202972004 g 5:03 w' Blue Skies Airlines 560
Busineze -
o | ;

Ready

[ I 2

I Jhﬁg\, %’!ﬁ'l'ﬂ [ Details ] ﬁi;f#‘ » B

W SRS o o)) e
kL Portland -

Iteration 3 :

it results tree (1 > Hff](+) [Parameter Iteration 3]

Portland £ [fi] Eﬁfuji‘gll BEff o BRI

&7 HpY [Application] [fi/[F‘HI » BT BB SRR

> [Actionl Summary] >

[ Welcome Mercury Tours] > [Flight Confirmation: Mercury]

# IV [Checkpoint:"New York"] -

?ﬂﬁﬁ Bﬁm [ Details ] Et{fr*‘ fl1 > Bf= Seattle B30 [ fi Ef”u%_féf, BEf@ > el ) =y 5

B R - G

£ Hpv [Application] E%F‘H' s BRSBTS BB

L Seattle -
PJ R SRR o 1 A g BEORER ¢
Iteration Expected Text Actual Text Result
#1 New York New York Checkpoint Passed
#2 Portland Portland Checkpoint Passed
#3 Seattle Seattle Checkpoint Passed
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Vet R T 0 @ A R BURLEBEAY > (BRLEYT SRS SR SRR R
ELRY o SERLP BT RBIIAD - b v AR B OB (AT S A B
e e TR POROE » S ST ARRH B B QuickTest | IEHRIETAAS A B
BOSER R BT R TR -

3. BRI
i [File] > [Exit] RIS pOw i -
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7. E L

7.1

T BT B s X |2 §== Data Table ZWHEVRIA4f IR0~ 7 FJF'SJ‘?EIJ?:*??H{SI ° fﬁJ’F%i
By » o i ] (R A it PRI E] Data Table o iy = P PRIBI T | H RS A 9 s R R 7]
Z[ - QuickTest ﬂ"}{ﬁj’ ViR 7 Runtime Data Table -

FRGIRFL o O AR (] FIREE ORISR B FIR ] - R
J—p\ﬂﬂﬁ?ﬁrﬁig’f:ﬁ? jt11Z] Data Table » fi ™ [P il H;EJFJ 5= A E J—Jﬂﬁf?:'ﬁr'}ﬁ?p SRR o

- (i
B TR ) B PG R BT SR [REOTIRERY » o B L PR
O WY S R R AL -

B f’ﬂ\‘}[ﬁ’%’ﬁ ¢ [ Select a Flight: Mercury]) E{ﬁEJ IV SR E]‘%; » 3 S TSV pUES R f%"f%‘ﬁ[;@?
iﬁ?’ﬁﬁﬁl REFOFFITRRN © D= e > JRSHIA R 1 F7 [Select a Flight: Mercury ] Afff1 =2
RS E f%?% » 4 k@5 [Book a Flight: Mercury) _F&= frugg f%?% o

1. %= QuickTest ™[ JFIP,‘ ' Parameter | JH[ZVHl 4

00 QuickTest 2 F'EJF’F’ %!‘5 [F'ﬁJiIF'}] > [#=VE& ] > [QuickTest Professional] >

[ QuickTest Professional] -
u f@ﬂ[‘?ﬁ]ﬁ?@iﬂ]ﬁﬁﬁiﬁ > K [Open Existing] -
W IR BE [File] > [Open] @RlfiiE™ Sl [Open] #7% -

7+ [Open QuickTest Test] tfﬁf,;ﬁ%l[fil MR T Parameter | JHIEVRIA ’Hil&EﬁL
[Open] -

2. JFHEVEIE By 5% T Output , HIEVETE
&ﬁé [File] > [Save As] u’-{ﬁ’?ﬂﬂ%%ﬂj:&ﬁ@?} MOutput ; -
3. ﬁ“g?i [ Active Screen] le_FﬁJflg%]a@

32 ¢ 12 QuickTest 1 %Y [Active Screen] - Rl ™ 2!%] H{iy [Active Screen]
e p‘/f«c%fﬁ [View] > [Active Screen] -

4. EVEIEEY S

7+ Keyword View f[1 - 5f(+) ["Welcome: Mercury Toirs"] &> =" Bi# ["Select a Flight:
Mercury"] 5 “[ﬁ Flo IHLH[[EI [ﬁ [rf“ k7 [Active Screen] -

7+ " Active Screen | f[1 - ~3’V$EL 270 > {EELT & ¢ $ﬁ@%‘_ DINEAS #E%F'% SR E I
[Insert Text Output] - nFF ?S{ [ Text Output VaIue Properties ] rfﬁf[ﬁlﬁil
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& Text Output Yalue Properties

upu Tot |

5. ?éﬁﬁ?&"@
E’!,‘g [ Modify) ##&* > F'#Jff!% [ Output Options] ;’“‘:’ﬂﬁﬁﬁfl@f o

Output Options

DrataT able |_
Select_a_Flight_M eru:ur_l,ll

7+ [Name] #ight %’75%;7—7 Select_a_FlightOutput_Text_out > }{ﬁ’iﬂ d5y depart_flight_price -
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Ao ’J@EF%EEJ ) %ﬁ,ﬁ [OK] : QuickTest %’7& Data Table f[1[1* depart_flight_price 4
_f.

1= : 7+ Data Table I depart_flight_price fijfiik fuay— (= ¢ 8= (R R -IVIH pofia |
fifl—270 o T #=H - 57— 7~ QuickTest BRLE IV H - BVl —270 > {HRLE 43572 ~ =
o i R Y VR - 25 hE]| Data Table fl1 -

QuickTest F’-"f.‘i VBB [ b R -
6. I”%I-%’F‘,ﬁ%ﬁ B
& Keyword View f[1 > 5f# (+) ["Welcome:Mercury Tour"] > ["Book a Flight: Mercury] -

7 [Checkpoint "New York to San Francisco"]) _'—E’!,‘giﬁgﬁ[% 3#V [ Checkpoint
Properties] H:FJFFI% [ Table Checkpoint Properties] ’;Efi—*,;ﬁﬂ?irf 0

%!1_:)1—‘ o BT (HEASERUREE ) > 7 [ Configure value] HI%,F [ Parameter) - §kiz
# ™ [Parameter Options]) %" - BF JFT [ Parameter Options] H—Fl’ﬁja" °

Parameter Options

DrataT able |_
MHew York_to_5 an_Frar‘u

& [Name] _'\}"‘(*EFI'HI Z TV depart_flight_price -

Eﬁfé‘_ [OK] [H'?U [ Table Checkpoint Properties ] hfﬁf,ﬁlgi,] gy Ulﬁ'ﬁﬁ‘ﬁ Eﬁl I
R = R R
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33| Table Checkpoint Properties

v 2 J s

Mew York 12/29/20
FLIGHT CLASS
Blue Skies  Business Parameterized value
San Franc 12431420
FLIGHT CLASS
Blue Skieg  Business

I:'.:wm:hnnnr

™ [OK] Fér%ﬁfj [ Table Checkpoint Properties] fﬁfﬁ:ﬁﬂﬁlgﬁ o
7. [REHERA
%’,‘ [File] > [Save] ﬁ&i&l!‘““ 2 Fpy [Save]) f& -

72 HE ST ERRE 4
HN o oS RS AT -

1. %5 TOutput, IR+
#7299 [Run] 5302 [Test] > [Run] - B [Run] S -
=T [New run results folder] > ﬁﬁgét'ngl%ﬁaj o
R COKY FUFh = RERI A o Hirgh= st gl F{E""J TR ! -
2. fwkEE G RV (run-ime data )

7i?EU:@1’?F7JﬁJ§4HI ’ gﬁ i# results tree i Run-Time Data » |i'I'| ri%wﬁ[l E R
SVEfofE i o ) 2 depart_flight_price 5 (18 T [FIFVRSE (14
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B Output [Res1] - Test Results

Test Output Summarsy

B antineoza [oe [
B v [ Output Tteration 1 (Row 13 | |departure | depart_flight_price| ~

f[h Oukput Tkeration 2 (Row 23 270/ [N
- o @ Output Tteration 3 (Row 3) Fortland

| 3 |Seatte
4

3. KRR B
E’!ﬁg [View] > [Expand All] -

3V [Output Iteration 1 (Row 1)] > ["Book a Flight: Mercury") > [ Checkpoint:"New York
to San Francisco") -

EER: T [Details] i1 > B A Ao BURLEREY -
[l » g Iterations 21I') % 3 » 7 [Details] gi,ﬂ‘ﬁfll , J];‘—Eg} B~ R -

4. AR B
iz (File] > [Exit] AR Bow s -
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8.1

8.2

PRI R

o BB U AR TR 5 L4 QuickTest T
PP R AT R R~ R s

Py Ok

iﬁiﬁ;ﬁﬂjﬂ*ﬁ F ko QuickTest [ I'JF(P [P FIFVEHEHIT 1+ - P I T RIpL S o Tkt
PIFFROTE ~ TR PRy RS RO e R PR RS

e

PR AT BT B © R0 R TRECY 1 ) - A f s

Il o fora— 7 i fjl E'Jfﬁﬁf'ﬁ"ﬁ F A3 ﬂ%ifj% QuickTest Professmnal User’s Gmde

(EHEIERE e
B {ﬁ\}{fj’?ﬁ;ﬂ ~ W ﬁﬁgf B j\ﬁﬁ;g%mﬁ FIHA I—.J[PE[’B‘F ,ﬁaﬁf{r Eﬁ‘ﬂfvpﬂﬂﬁ?j
iy o i R G B R A 1 e S E RS [y TR E[

QEJ °

R BORpE PPy A A T R FUVIEORSTRUL B 1 -

7 QuickTest ™ fif JFIP‘ "' Recording ; Y=+
571" QuickTest YdF'EJ?T %!TE [F'ﬂﬂﬁ] > [#='& ] > [QuickTest Professional] >

[ QuickTest Professional] -
B B g’@iﬁlﬁlu Ki5# [Open Existing] -
W BRI - KEE (File] > [Open] fkipiiz = S1) Y [Open] ##: -

7 [Open QuickTest Test] tfﬁf,ﬁ}ﬂ[fiv. 15V T Recording | JH[EVRIA - ’Iﬁ&&ﬁﬁ
[Open] -

SRR A P37 b €88 [RegExpression] R4 4
£ [File] > [Save As] - J{iHIE¥HI 4 %5 " RegExpression , -
ﬁ“ngr?i [ Active Screen] lej'ﬁJflgﬁrv

(2L A UchkTest‘F "~ Hv [Active Screen] > E,!,“f" ~ 2] Fp [Active Screen]
e p‘/i%ﬁ [View] > [Active Screen] -

EEIVEIE f,ﬁﬁ] %’Jﬁlfﬁ? P

7+ Keyword View f[1 - 5ff(+) ["Welcome: Mercury Tours"] & %' E’!,‘g ["Select a Flight:
Mercury"] ?Fﬁfl ) EJ[Ji?[’[E‘%[ﬁEJﬁH'&J& [ Active Screen] -
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“ [Active Screen] - I'[IfiEE L7V ] 11] 12/20/2004 » F| 1B SERE 20
[ Insert Text Checkpoint] - FJffPr [ Text Checkpoint Properties] ;mT—F[ﬁI?i,l

5 ] ]EJJE'Jﬂ"% ERN L TSR Y
7 [Checked Text] Eﬁf{ [ Edit Constant Value Options]) #&* > F'q:ﬂfﬁr [ Constant Value
Options] %q‘ﬁ‘ﬁﬁlﬁiﬁ o

Constant Yalue Options

“+ [Value] figft - ﬁ!?inj“ [0-1][0-9]/[0-3][0-9]/200[0-9] - F%Jg QuickTest ]'] MM/DD/200Y ¥ 3~
FE S I b

3% [Regular expression] i rﬁ”’iéﬁlf e Tf;,lj ol v 2 ffi —"ﬁj’ﬂu ﬁﬁljﬁp R 3] SEL %ﬁ
# [No] -

= EpeEEE [Yes) QuickTest ¢uHFRT 7 » 41 ([) ~ (=) ') (1) e j&d
e N

ot “LL?EF%"“[’@_’[ ) Eﬁf%’ [OK] E‘%Efj [ Constant Value Options) ;’“’é%ﬁﬁl@f JpIE] [Text
Checkpoint Properties] ’;‘:j*ﬁ:f,ﬁj;ﬂ [firf o
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& Text Checkpoint Properties

Checked Test x| = = =

(0-1][0-9)/[0-3][0-9)/200[0-9] |;T

HirZ [OK] Fﬁﬁf] [ Text Checkpoint Properties ] éﬁﬁ%ﬁlgﬁ o

QuickTest Fﬁ&?ﬂﬂ%ﬁ'ﬁ‘ﬂi flr» ["Select a Flight: Mercury" F1fiv™ 407 & 34 gﬁ
fer e VA

R [File] > [Save] Rtz T 25 i [Save] #¢ -

83 BT SHIRLA PR R PR
B SRR R A o 20 R TR -

1.

2.

7 T RegExpression | V4

R 2915y [Run] #%2: » prRlRE [Test] > [Run] F'aﬂ?% [Run] é“éfﬁrﬁﬁ‘riffi‘f °
37y [ New run results folder) i?ﬁfg'%ﬁ?ﬁlﬁﬁtfﬁﬁ%\' FIER €7 -

R (OKY -~ Bl eh = IRV A - ek ol - "FE“*J T g -

AT AR A R R A
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T results tree » % ff(+) [ Test RegExpression Summary] > [ RegExpression Iteration 1
(Row 1)) > [Actionl Summary]) > [Welcome: Mercury Tours]) > [ Select a Flight:
Mercury] -

9y [ CheckPoint:"[0-1][0-9]/[0-3][0-9"] -

B HegExpreszion [Hesll - Test Fesults

Tect RegEvpression Summary
BE Aun-Time Data
E’. RegExpresdon [beration 1 [Row 1)
- ,; @ ictionl Summary
= Jﬁ Welooms: Meroiry Tours
E rj Wielcarme: Meroury Tours
BE "ucorhlame®:Sek "meroary”
B "pacosordiSersace "H0220850
i A "sign-In":Jick.
E qrj Find 2 Flight: Marcury
IS "FromPort"Salect aw ork"
L5 "FromPonth Sslect *Dec
= "rorDay" Selact 20"
15 "eoPoet'iSelect "San Franciszo"
o=| "boManth":Zelact 'Dec"
I=] "oyt selact 21"
JF "eopuClacs"iSelect "Business"
fbe B RndRlighes" i Chek
|: ,rqr_hl Salact 2 FllgH: Mercury

Text Checkpoint "[0-1][0-9]/
[0-3][0-9]/200[0-8]": Passed

Date and Time: 4/19/2004 - 18:78:05

Details

Tt Chackpoirt: capiured "12/29f2004" hetween
san Francisco and SELECT

Fegular Expression ; OR

Iaich case: OFF
Exact match: OFF
Ignare spaces: O

rn flight from the selections below Yourtotal price will
ect to fly on a diferert airline for both legs of your

12/29.2004

oo
nes 360 5:03 non-stop
E e roine o

E "rcscrchllghts".Cick
qr_hl Boak o Flight: Mercury
qr_hl Flight Confirmation: Meroury

qr_hl “Welcarne: Meroury Tours

rr?w@WﬁE%W%ﬁu%Fﬁﬁ‘wﬁ“ R R R R Y
Fo Y T BT -
pum_f.ﬁ;%l:aj*éﬁﬁﬂ P T RO P I R B g
3. WA B
By [File] > [Exit] BFHAIRSR UM -
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0. SRRV s % fWph

9.1

9.2

9.21

= chkTest Fl1 Action kL~ fifi' I BEET R M| (reuse) fiofed | Hifb ’5' vt — il = SRRl
A WEVEIA L CF - W Action £155 Actiond o i I LRI - J%UE& % & Actions » &
TR R VSRS (= R BYREETHI ] -

0 % e

Mgy~ b RS » okyf ST IR A ) 55 I (] RIS S
Ao

BRI

LI

PSS 1SR 2 SR RS PR A - SRS e Tt ME FIHTEEEpY L

! T e S FOH > BT AR TS S (W A s
(E NS TURD N P e e T L S T *qa‘ s 5&’%&‘%"@'&% 1§

Lfr
L[I

FUSIRRIE ST oL TR % T Jf =t e o
[~ RS R L= R T g e o

B TR N Jﬁjﬁ"%ﬁfﬁp‘/* ]| M iR E g b L e Eﬁﬁ&ﬂ%ﬂ%]ﬁﬂ%ﬁﬁﬂi % }F‘ff‘

pfe:

[

] Eﬁf{ [insert] > [New Action] pvkL™ 259 [Insert New Action] $4% -
] E’![‘E [Step] > [Split Action] ﬁ‘/ L7 2% Fp [Split Action]) ##4 ©

| &ﬁé [Insert] > [Copy of Action] F‘}ﬂ& Action F¥ ,Eyﬁggf,% » IV [Insert Copy of
Action] -

| E’!‘ [Insert] > [Call to Action] F{&f\_@ Action l—g’;‘ YFJEEJI% E9 [Insert Call to
Action] -

s e
B P (WS R -

HEHIZ R T
1. %~ QuickTest ™ fF 'E?ﬁ ffst = Frp RV £
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ﬁ?‘iﬁj@é CERENRIEA A L PR L -
2. Fﬁ%g@;{ Mercury Tours #3 ]“qu’fﬁf’![‘

BORBUH ) G W TARNRNE R ) BUR RO o T A
7] % 5 actions » SRR o 7 4 R | Al ORI e

R PO -
R [Test] > [Record] fyRtifise =5y [Record] 5% - il [Record and Run
Settings) faéj‘ﬁ—jﬂﬁlgi”[ o

Record and Bun Settings

Microzoft [nternet B xplorer |_
hittp: A riewkars. mercuryinteractive. com |_

B 7 [Web]) Frss Eﬁf’aﬂ [ Open the following browser when a record or run session
begins] -
7+ [Type] FHIHEE G [PURETE - = [Address] 4 flifa *
http://newtours.mercuryinteractive.com -
232 [ Do not record and run on browsers that are already open] I'] % [Close the
browser when the test is closed] i -

B 7 [Windows Applications] FI& > 2:# [Record and run on these applications
(opened on session start)] > i~ ]%ﬁf"“%ﬁfl N R AR

B [OK] -

QuickTest F’ﬁf’ﬁj?ﬁ%@‘“ﬁg > BT Mercury Tours FiE! > 2 il sAShlEHIE -
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3. ﬁ‘ Mercury Tours

7 [User Name] I'] ¥ [Password] ﬁi?” EN [/H'jﬁ:tF ff=s Jfﬁ? o

%{Gﬂ_ [Sign-In] -

F'ﬁj’?ﬁ‘ [ Flight Finder] ?l'ﬁfl 0
4. ﬁﬁa’?‘ R

By SRR

[ Departing From] : New York

[On] : Dec 29

[Arriving In] : San Francisco

[Returning) : Dec 31

lﬁ%twg[%@ ) Eﬁ# [CONTINUE] - ﬁﬂ?{ [ Select Flight) {I’ﬁfl o
5. EEMET

}%;E?@ ’ Eﬁp [CONTINUE] - F'aﬂ?% [Book a Flight] fff1 -
e

i R R

Eﬁp “]'ﬁ FI' 1y [SECURE PURCHASE] F';:FJ‘T?,‘ [ Flight Confirmation] {]’ﬁEl o
7. |p'E[ [Flight Finder] ;{ﬁgl

& [Flight Confirmation] Afff1 ™ % - ¥ [BACK TO FLIGHTS] - [p'%] [Flight Finder]

W -
[ [Flight Finder] Afffft it | M350 - BRI == oDRLIl - Frpn - g il Rl
FR TR

8. e

RIEE T S0 Ep [Stop] HE s -
9. EHIRHI A T ActionA

RrZ [File] > [Save As] - JRHIEVHI# @i 55 [ ActionA

9.2.2  JTHERIF S8
RO ORI B0 3 2 RIS ¢ SRR T RS o (e
)FEIFJ,II Flfﬁ[ °
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LT (R R AT
7+ Keyword View - 4 ff/(+) [Action1] > ["Welcome: Mercury Tours"] -

2. SFHIRVEIA 51H5 T EhE
#3v ["Find a Flight: Mercury”] A1 - j&ﬁg [Step] > [ Split Action] Jiy LR ™ £'5]] -
i [Split Action] $#&* » q'ﬂ‘?if [ Split Action] %TF:F}E‘FJ?J;{ o

Split Action

3. T Pl g
7t [1staction] f[if [Name] mar'vjﬁﬁa’.j‘ 2 Sign_in o
7t [1staction] flif¥ [Description] )h“ﬁh_"ﬁ“ : Enters user name and password to sign
in o
7t [2nd action] f[ifiy [Name] ﬁéﬁ@ﬁ‘ : FlightOrder -
7 [2nd action] f[if% [ Description] )h"ﬁ"ﬂ_"ﬁi?]“ : Chooses and purchases a flight -
FUEREE W FHRE T - B [OK] Fér%ﬁfj [ Split Action] fﬁfﬁ:—"ﬂﬁﬂgﬁ > 7 Keyword View ngt'?
A -
%’,‘fﬂj [View] > [Expand All] ffﬁfﬂ@[’[ﬁ‘éﬂfﬁfﬁlm?{ - =¥ > [FlightOrder] E*JI"E%WF#EJ?F'E‘?E&E
ﬁJ'EEF%ﬁBﬂ [Find a Flight: Mercury] FffE1 -
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93 E FHIE
Bl SR - ETORACe 2 2 SRIITEE] Mercury Tours FIEIOH B » RIETRIRYEI 1o
SR R - TR

1. jﬁ‘ g =
Eﬁfg [Insert] > [[New Action] ﬁ‘/ﬂ g T 2] Py [Insert New Action] " » F'ﬁ]?ﬁf
[ Insert New Action] ‘éi%fﬁjﬂ;ﬁ’ﬁl firf °

Inzert Call to Mew Action

A ction]

“ [Name] ﬁﬁr’ﬂ_‘ﬂlﬁ‘ fi{= 7 ReturnHome > 3V [ At the end of the test] ﬁi&gﬁfﬂf
COKY - BRI it % » SRVl 4 Jek i o f T MIMTPTEETY ReturnHome f3 = -

2. IR
THERIBR 2 I (Flight Finder] Aff! -

ﬁ%E?J‘ Mercury Tours fisfit- Chttp://newtours.mercuryinteractive.com ) i*"ﬁ‘ ’ EJ[J%’?F'#J?%
[Flight Finder] S

Rl I QuickTest et fif o ') (i) I 7151 (b -
3. 7@l [Record and Run settings]

E'H™pv [Record and Run settings ] ﬂ?iﬁz’& [ Open the following browser when a record
or run session begins] - '] QuickTest %‘7 Elﬁﬁﬁﬂ’?%ﬁﬁﬁiu r’ﬁcfﬁi\jﬁmﬁé_ﬁfo Tiﬁr’ﬁcfﬁ.}ﬂ
Fol = BFISPRIOTBIBS b SREUIOTHOE [ - T ) o0 SRR L -

E’!,‘E [Test] > [Record and Run Settings]) F'#JTJ% [ Record and Run Settings] ;TFF%@

P -
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Record and Run Settings

Microzoft Intermnet Explorer |_

hitp: A Anewtourz. mercurpinteractive. com |_

7t [Web] FI35 > %V [Record and run test on any open Web browser] - ’IF&E#,‘E
[OK] -

4. #5] ReturnHome F)[™=
it Keyword View f[1 » ZIV#i{iy ReturnHome F{™
Eﬁ [Test)] > [Record] ﬁ&i&ﬁ“* SlI-pY [Record] &
“t [Flight Finder] AffFr b R %32 158y [Home] - [p'Z] Mercury Tours fiUFTEl
REBEET S [Stop] HHE LR -

5. [plrgg [ Record and Run Settings) F%{L_

I ikl "S5 ReturnHome F7['5f AR 1 »” [Record and Run Settings ] Em]%y& ) fﬁlﬂﬁﬁ—i
(R g,@g QuickTest I 4+ U= « ERGIAHREEI 4 H32 - Pl QuickTest 7Y
s VTGN - SBIBE Mercury Tours FiF1 > 5l | if{ [Record and Run Settings]

%Jtcl;r[ﬂl’ﬁlqk i JF%J& o

E’!‘L [Test] > [Run and Record Settings] - [ JTF [ Run and Record Settings] amT—F[;ﬁJ
e

[ﬁjﬁ.‘i [Web] FI&5 > 232 [Open the following browser when a record or run session
begins] - fﬁ:—r% http://newtours.mercuryinteractive.com i+ - [Address] Hg" (1 > &#,—,g
[OK] -
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6. @ HIEA
HiZ [File] > [Save] prhlRipE ™ =90y [Save] #E" - @l 4 -

9.3.1 }fgé/’%%é‘ﬁﬁ’f//ﬁ/E//ﬂf/gf//t— (Reusable Actions )
El’?FEFJ'EIfJF[JFJI'FDE'J]E'ISJE*J["': (Reusable Actions ) ﬁ'?"ﬁ*@*“%ﬁﬂlﬁ@fﬂg\’r (function) - ’5[ 5F |
P 7 LRV O I DR SRS~ TR o
(Reusable Actions ) = JREciikf'T) ,igﬁf;,l“ E[| = EAFHORIRR A o P L R
ol I LEl S PRl 4 =PI ] gl =kl i e £ I FVEs = (Reusable
Actions) - 1 > Iﬁ:’&iﬁﬂﬁa‘%ﬁﬁﬂlﬂ’?@ﬂ' fY Sign_in I'J % ReturnHome ;m‘ﬁ’ T E RS A
fli o ﬁﬁj’“i%ﬁéjﬁi[rﬁjglfJghf‘Ev el e LR E R R ffl P IfVEs (B (Reusable Actions )

I
1. }{ﬁ’ Sign_in g f‘EF%{L_F‘}FI‘ FIF™[pYEs (= (Reusable Actions )

7+ Keyword View |} ?FE&‘F] Eﬁ; Sign_in $RxZE TV [Action Properties] > rF"fF J’?ﬁ‘ [ Action
Properties] ;qLﬁ Vﬁ”?i[ E’FM [Reusable action]) JR&f ™ [OK] - HEypH ,Eu?*,ﬁ;bﬁlgiﬁ » 1=
i NEEEPUFEL ﬂin&&lﬁ% [ Do not show this dialog box again] - k™ [OK] - [

P T ® [ 2! O 78 s e

2. @ Sign_in ;15[‘6

EH o AR SRR T Keyword View Ff Sign_in g = o
i SR (g [ £ i) M9 (Reusable Actions ) i » €755 Keyword View
R - A ST SRR o ) 7 AR (Reusable
Actions) > I'| ALY ﬁ[ﬁgﬁ["eo

ﬁ Test Flow j

ﬁ T ezt Flong

(= Reuszable Actions

@,, Sigr_in

felhwmp! Sign_in il {57 | FL B T FEE T nE IV Sign_in g {ElER T

it [Action] ™ iEHI1 - 23V [Test Flow] #iEpI'[HIE]FU4 iy Keyword View 7 e
3. }{ij’ ReturnHome “JI%TJ&E‘}FFJ{FU MIpvEh (= (Reusable Actions )

%} ReturnHome [ (%= > EiHE#H R 175" 2
4. [@FEHEEE

HrZ [File] > [Save] fhLiE ™" 29[ HiY [Save] #% -
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9.4

9.4.1

]ﬁ‘k ol JiFLtE‘I

ﬁ' e - —r“/IJF"JYEUE;l@I'[E‘iE%‘]‘ ’ FIJFFF’{BE%J?JEE*J]"E’ g R LA |ﬁ§aﬂ|§]@n§ &

= E'[JFJ' g~ ”‘ZE‘[J: Al SREEC i AR s BT AR R 2 T

ARV 4 Hflgﬁ“ T VB[

gl £ ?ﬁ%ﬁﬁﬁqﬁ TR JIE T R lﬁ HEA A > )2 iufsasT @ F’* 7z AR SN =R

FWF’*JIH'“T@”’T ORYRLE IR < i e P[IFU“‘F“%‘E*JI'E’zﬁl*gﬁ[‘ﬁ%‘%‘\ﬁ&p\é%p@mh,
bR Uk pUEVRT £ HI TR ISR LAUEA [ o PRI @u R T P

i A MEFJ B EIVHE’%EJI‘ far Flgllrsnlsrfgwpp SRR i )

TR TN RUBGR 1 Fﬁ* — [ ActionA fs[EWEI 4 > £ fl1 Sign_in I'|  ReturnHome f{ ™=

AR FTIA R A (1P L= R Rl 4 plpgs i) oy 2 FlightOrder g[S (o7l

ERIETERE

777 e (call) fropf
f]i ) r’ﬁ\ﬁﬁ’,l\Jp‘—‘PL[EIfﬁjfk‘ » §21 ActionA [ 1V Sign_in = ReturnHome e Jﬁ‘ ActionB f[1 -

1. 'F?SL EEHIE R4 5% 7Y ActionB
f@yp,’a‘»g\?lfgﬁm"e, ﬁ%iﬂ% "RFITIER A PR L -
2. 5 PEPURY Sign_in g
K [insert] > [Call to Existing Action] » HJfif [ Select Action] i -
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Select Action

<Current Tesgty

® boort 7]

%‘I‘E [From test] ‘pi%ﬁfl () #4250 [ActionA] HIEVRIH <K% [Open] - [1F)
[HIEl E'Jp’lfj;‘w(‘E (reusable actions ) F%Eﬁ 7 [Select Action] %TFZZFVEJ‘F'LTHI o
HIV Sign_in fih{®ix o 7 [OK] - Sign_ |n[Act|onA]F#J|":%"H',, TRV A puE s s

]ﬁl{@g&* .

s R Keyword View flP] Sign_in B> fifgn! Sign_in Bf= > &0 1)
[ACthn] (EEEFIIF I geEy Slgn in FI{' Eluf/‘['—ldé{[ ll:-E IFJ Ii‘]]f:?%lﬂj s fgvp,ﬁ FZ/I 5 I:ITF[ JEF[ I;\I_EJ r'?:;EJ
FPRCREORIBEE (ActionA) FfiEsifsast -

ZIV [Action] & HTF 1IFv Test Flow [l EUdfiv Keyword View -
3. jﬁ P LAY ReturnHome Fr‘Jl‘E

(R 2 > K ActionA HIZREIT (1Y ReturnHome (5% > 45 * R4 poget 4
4. EFHEVEE

E’!,‘ [File] > [Save] ﬁ&f«c%!‘““ 25 -py [Save] ##&: -
5. F%”EIV'F'@!F[E\J ReturnHome f (=

Eﬁfé’_ [File] > [Open] - IV ActionA 14 > /™ [Open] -

#} ReturnHome E |‘E&|!r: NI g £ [‘J”'Fk,‘ o
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7 Keyword View > 37V ReturnHome E#Jf‘EEIquaH ’ w.&&ﬁé{ [Insert] > [Step] >
[Comment] - F'#Jffj% [ Insert Comment] %ﬁﬁﬁﬁmﬁ > A szﬁji% o

Inzert Comment

]

ok ] coced | Heb |

ﬁE?J‘ : Return to page used in first step of the test » %33 [OK] -

ap Fé_tﬁjé’:yp‘k :

o FetumnH ome

{,,E_:' Comment éHeturn to page uzed... Comment
v & Find a Flight: Mercury ¢ Retumn to page uzed in first step of the
|| best,

3 Home Cick Click the "Home" link.
b J;j Welcome: Mercury Tours | Spnc Wit for the ‘Weh page to spnchronize befar

6. R
Bis [File] > [Save] frRipE ™ S'5] iy [Save] ## -
7. B RU ReturnHome B S sy U] O 4
Miz# [File] > [Open] - 2V ActionB [z + - # [Open] -

%f ReturnHome[Action Al [l B~ ™ I AR [y > it ) 2] i R IR 4
(ActionA) flip ElfJﬁ%_tEJ%“JH S PT P  PEIEEI A (ActionB) e

7+ [Action] = &7 > %#,{i{ [Action] &%V Test Flow [HIZ['FL4 iy Keyword View -

9.42 77~ [FEHHIHF
#7 % B FlightOrder vkl 1: -

1. F'?*EJ’]?%L (R 4
Tﬁii}['fsx‘%\ﬁg"‘ﬁ’ﬁﬁf'%’ ﬁ%ifj%‘ RGN E PR L -
2. ]T;’ﬂ FlightOrder g { =k 4
&ﬁg [Insert] > [Call to Copy of Action] - F'#J’?% [ Select Action] ‘;ET%—‘"F,;,?;JEV”, o
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Select Action

<Current

@ Actort 7]

RipE [From test] fjdtt | odpy [RET] #5220 [ActionA] JIEVHI 4 sz [Open] -
MI%: CActionAY SHBSHIA: il JRERD P =B & [Action] FEHIF - =L HEZIVEY
gﬁfﬁ,sjﬁpzjﬁgga =+ [Action description] |1
#V FlightOrder (= fi£ [Location] 1% [Atthe end of the test] %H#™ [OK] -
[Sign_in [ActionA]Y sy L f HRRHI A (R Ty o 1> NI * Ao S P
e o (T SO (R -

3. {%d¥ Copy of FlightOrder g%

7t Keyword View f[1 - 5f(+) [Copy of FlightOrder] > ["Welcome: Mercury Tours"] >
["Find a Flight: Mercury"] - B2 "fromPort"fiv [Value] fif " ’}-lij’ﬁﬁ"ﬂ[lﬁlﬂf@ﬂ?’%
London i > 7+ &ﬁfx_ﬁ_ Keyword View £l &3] o

4. JKj Copy of FlightOrder g {=4v%(| Sign_in gis{*=1 i
fﬁc?fj CEPEVRIT A $ho s PO EERLE S Sign_in FI=l % F ¥~ Copy of FlightOrder fi(™= > {fIhL
SO - B SS RS [ 7 [9EY (% (Reusable Actions ) [ i » FRELTIF] i fiv
"= (Reusable Actions ) vt L= LIV FlRLIERERY - F7l | B s 8= 0 SR ) g
iﬁﬂf‘gﬁ [EWIE: o
it Keyword View H#2v Copy of FlightOrder fs (™ » ;-[51' HHGHE] Actionl F (D % > JRET
1 Sign_in fih =4 4550E] Actionl Fh{=Y & iﬁﬁ—i— SO .suI;;,E[‘—‘]’ Copy of FlightOrder (%
BeE] Sign_in fih[EL T o

- 66 -



oldsidney 5 /=15 http:/Awww.oldsidney.idv.tw

5. MIB=HIERIA: 1P Actionl
5 BRI & 0 € TR Actiond s « (RN fl1- LRI)% b R
(& BTl ;a\.,u\;gj_jﬁ " Copy of FlightOrder g% » §Riz ¥ {=I6* Actionl (=« Flit » i
I} Actionl i 1 -
- Keyword View f[1 - Eﬂ‘ 3 Actionl §RiEET [Edit] > [Delete] F5fLip ™ i iy
[Delete] 8 - iz ?J £l #7 [Yes] -

6. @ HIEVA
iz [File] > [Save As] JRLEiz T = bfy [Save] fE - HRVHI 4 7%
[ActionB]) -

7. AR FlightOrder f 'Rl iy = k{iie
K2 [File] > [Open] -3V ActionA > Kl [Open] -

B [FlightOrder] > ["Welcome: Mercury Tours") > ["Find a Flight: Mercury"]) > iﬁﬁﬁp
07 ActionB {Euﬁ“éaﬁﬁ]]ztzf]||r;<clsrgﬂl',g§i*%%ﬁv 7+ ActionA JFIEVHI 4 Hlf\_ ‘%ﬁq el ]
(ActionA fitat! ﬁgﬁﬂ%’!ﬁ%ﬁ& New York) -

95  EiiE{ERy

iy 2] ActionB VR4 R # (Data Table) f > fﬁv%‘?éﬁfﬁﬂﬂ“ﬁ[ﬁj {F# : Global
Copy of FlightOrder ~ Sign_in [ActionA]l'] & ReturnHome [ActionA] -

AU [gpea2 € vk # (Data Table) - [ [View] > [Data Table] mﬁﬁ%ﬁ%‘ A S

7 Global ~ [‘P%HlpJﬁ;{v[i{rH (FIFSI (02 1pY < 59] Global ey A<l 1'E £] 5 ETevR ﬂEU
BVRIH {7 55 pUgE > el L [ o [a*;m‘effrwjzw%e %)
S—S“TE%H » A Tg[@ﬁ SURIA = 1 ﬁ’E\iJ% ) ﬂ—“g‘[ﬁ]"Eﬁqj@%L 757 o

=EC: S|gn in [ActionAJ== ReturnHome [ActionA]~ ]"ﬁ%h%ﬁ% BV P9 RAGED T (EARYER
o+ PIBAE T T [T TRV 0 DR ROAR MR AL T e -

B frf 45 FlightOrder g — (v » 1)1 B! PHZ N R D - 00 [
CIRBS IR

_"'L

1. F';ﬂ?ﬁ‘ ActionB JH[Z 4
B89p ActionB @mf’ﬂf’g% E’!Tg [File] > [Open] #3Z3V ActionB J{[ZHI4 » JRedd ™
[Open] -

2. EIEIEE

% (+) [Copy of FlightOrder) > ["Welcome: Mercury Tours") > ["Find a Flight:
Mercury"] -
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it Keyword View f[1 » Eﬁfzj’_ ["toPort"] f[i%ﬁfi [Value]) it » gy ™ f%@(rf“*;c%’%. , %'7
F#EJEIP( [ Value Configuration Options] ’;aj»ﬁ:ﬁ@?j;; o

Yalue Configuration Options Ed

San Francizco

L Enmrent actian sheeh{|EEal|

iy =R
4% Parameter > i"‘rff;‘%*mﬁﬂrllﬁ [DataTable] - 9f& it [Name] At - i~
ArrivalCity -

ol T pUs YR ﬂ{ﬁ Copy of FlightOrder gs{ =i Hlpusegrevk] > ARl [Location
in Data Table] |1+’ 2V [ Current action sheet (local) ] -

™ [OK]) Fﬁﬂf] » [Value Configuration Options] é“éfﬁ:f,ﬁflﬁi”[ o

QuickTest F‘f FIg%7: Copy of FlightOrder = =11 ArrivalCity Al » i &' 57— STevwf] ik
kL San Francisco -

3. BHCHEHEER

[fil— GEWEE T [l S NAE W fﬁJElfJi*‘j%gilffLT ﬁfﬁ'ﬁ’m B e R R NS R RV E TR
(e -

: Keyword View [1 > :ZXV ["fromMonth"] - (MR 2 fugifV] » SRGE | Vs - ﬁﬁ
fﬁgl?’i i [\Value Configuration Options] ’;Efﬁ:—'ﬁ@grfr'ﬂ?ﬁﬁ& s FI#F T [OK] ﬁlj » HAFIEY

[ Current action sheet (local) ] -
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7t Keyword View ([1 » 5V ["toMonth"] -~ [FIERIAFH BR 2 pURI » S I s g™ -

ﬁ%ﬁ‘gr%r[ [ Value Configuration Options] hT—F[ﬁJEAF F%& FI# ™ [OK] fj F'J s MLIFIEETY

[ Current action sheet (local) ] -
4. ETRRIRIE " REEVR
TEEPRIA E’!,‘g Copy of FlightOrder F125 -
7t ArrivalCity fii i fua7= ?/]Jﬁ‘ Portland =™ [Enter] -
g (departure) ZPEE (arrival) fi#ft 1o lﬂ‘ Oct »
5. R TR RO RRR] £

T?%]’ZE:I » QuickTest | %%%inf?~ SRR A g e ) oD QuickTest i ™| Copy of
FllghtOrder PRI A FVETE R LS e R A

%t Copy of FIightOrderEﬁf‘%ﬂ‘Eiﬁ@(F (S Z3V [Action Call Properties] - ff Jf!Sr [ Action
Call Properties] ﬁﬁﬁl@]

Eﬁg Run 1 -

i

Action Call Properties

ZT [Runonallrows] - [BYEF U E > B [OK] ﬁrgﬁfﬂ» BiSF | EEE [OK] FTJ
FJ;fJ [ Action Call Properties] ;’“‘éﬂﬁﬁfy@,{

6. @ HEEIA
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EIY [File)] > [Save] H *fﬁ_&ﬁf“ 2FFpy [Save]

i e FER S — EIEVREA it‘ 7 Mercury Tours %l'ﬁ‘r’g‘ AT ISR ¢ B IRESERLY
Dec 29 - Dec 31 f&London Z|| San Francisco ; 7= 3=$E1kL7 Oct 29 - Oct 31 f§-London ||
Portland - f# i 7 i Home ilief {7 1A«

TSI S (R O
%*i’ﬁfﬁwAmmBH it R w¢'§ﬁw~f’wﬂfmm@my@@§@s
TR BT OVRERR T HIRLT ] Copy of FlightOrder | v = Zrevf| -

1. #u= ActionB J[E %%
I ol -
R SRS [Run] @ RLE2V [Test] > [Run] - B [Run) B i -
7V [New run results folder] 5 7R TRNHN | 15 £78
Rl COKY -~ HRIRSHT 4 b Sk 1 IRPTIRRSE e -

2. AR
A EEAHE N o T RS AR S 1 Done > 5
TR b b R e g )

H B [Test ActionB Summary] > [ActionB lteration 1 (Row 1)] - :#3V Copy of FlightOrder
Summary (= S ET PET T [ G PR ?c?~1ﬁ|[iﬁi]glﬁ[ﬁ5ﬁh_’ IR

BRI 712 E 2 £ AL (2

_-EH
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3.

B ActionB [Res1] - Test Results

ﬁ Tesk ActionB Summary

- m Run-Time Data
5 E@ ActionB Teration 1 (Fow 1)

Copy of FlightOrder Results Summary

- @ Sigr_n [Actiona] Summary
= B ory of FlightOrder Summary

Action: Copy of FlightOrder
Run started: 4/19/2004 - 21:40:22
Run ended: 41 9/2004-21:41:01

Iteration # Results

1 Done

p Done

Status

Passed
Failed

W¥arnings

PR R

i [File] > [Exit] %%FTJ?EU?:@%F#E@( °
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10. F=g ML
L PR RAS J = P VR g SRR QuickTest It i pvih = o

101 Fﬁ]i’ﬁ‘?ﬂﬂ%‘ s A =
RSP GRS 7] QuickTest Rt A s RS 1 A -
PR ) O e B 1 e

1 RIS

BRI P2 O - ELIFDH H Y i e po s | ﬂﬁ%ﬁ%’g‘ (R AP
[0 20 25 R e e PR QuickTestRLFY £ it i -

L [P object reposnoryﬁk“ » IR {R4AY object repository 5150 TJ[,E% QuickTest
Ui o SR PR Fﬁ% FUETR] o Pl fEUE'J?"EF%EIWf%l?“ » B {EFIEVRI A E e TR object
repository » i’ I'| ffi "' [ iy (shared) object repository =1 » & % il E[J A H E'J[ﬁj*
i object repository -

IEQDH Téjéﬁ:é?{ rd(FIJ’[‘JI'FDEIFE%E@@?C i
o152 g, chkTest flfsie a2 [ H g (shared ) object repository f5i=¢ » G %

(IR 4 H 2]~ fi object repository - i EJ%“ PO E B e RRE - e
fsd— [l object reposnory PSRRI )

wrﬁ%[ﬁéﬁwggﬂ ’ ﬁ%ifj%‘ QuickTest Professional User’'s Guide -
2. SRR
PRI AR = B SRETNRE (G BERIHRE 4 ) -
3. [ R
R G S BB IR  GUIPAfE ~ Al UL T
/LH?F‘H W L CRVRL R (g™ 1 vl B s o g

L

H B R ) ) R AR VI

IR [P R R (BRI n da ) -

SR ITERS R 1 RS S I - IR > Sy

QuickTest Professional User's Guide -

4. TRep (BN RIAYER)
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10.2

10.2.1

10.2.2

SRRRVEI S IR0 | ITERIRVEI il T8 T ] IR e

=¥ QuickTest Professional User's Guide °

TRV
i P PR S TR (28 BT 2T ATRNR R ) BT P A
Eﬁjfﬁﬁt{;p TIPS o

S FTRREH

ARSI R e PR A T e
[ HL il (defects)

(BP0 ™| Quality Center (TestDirector) - i I' HRE{H{IIE 1 %] Quality Center
(TestDirector) fl1 (Quality Center (TestDirector) L Mercury Interactive fiz¢ 2!
= v[[ﬁfﬁlf’fﬁflﬁ'gﬁﬂ ’ ﬁ%%jﬁf QuickTest Professional User’'s Guide ['] = Quality Center
(TestDirector ) fu¥ () -

IV e R
FRIFVEH %%%11‘? QuickTest Professional fiugy@t » ' I'[ SBR[ BRI - -

L i
&5 4 =] > QuickTest Professional “Jf{H I'| ™~ fud {F :

QuickTest Professional Installation Guide

FUHE b 5E QuickTest Professional

QuickTest Professional User's Guide

I'} step-by-step v = i {1 "] QuickTest Professional i~ fléﬁf“‘\]ﬁﬂ?ﬁﬁ%ﬁﬂ[ o [P R =)
(User's Guide ) 4t =4 =] (Tutorial ) EIF%’,%EIEIU{}’?* °

QuickTest Professional Object Model Reference

HifH QuickTest Professional fufs{F - VBScript % ~ methods I'] = #&3fy]

EI]Z[
QuickTest Professional Shortcut Key Reference Card

FETI TP S g4 -

AL ERRT
B SR SRR R

ReadMe (available from the QuickTest Professional Start menu program folder)
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Provides the latest news and information about QuickTest Professional.
B What's New in QuickTest Professional (available from Help > What's New in QuickTest)

Describes the newest features, enhancements, and supported environments in the current
version of QuickTest Professional.

B QuickTest Professional Context-Sensitive Help (available from dialog boxes and windows)
Describes specific QuickTest dialog boxes and windows.
B QuickTest Professional User’'s Guide (available from Help > QuickTest Professional Help)

Provides step-by-step instructions for using QuickTest Professional to test your application
or Web site. The User’s Guide describes many useful testing tasks and options not covered
in this tutorial.

B QuickTest Professional Object Model Reference (available from Help > QuickTest
Professional Help)

Describes QuickTest Professional test objects, lists the methods and properties associated
with each object, and provides syntax information and examples for the methods.

B QuickTest Professional Automation Object Model Reference (available from the QuickTest
Professional Start menu program folder and from Help > QuickTest Automation Object
Model Reference)

Provides syntax, descriptive information, and examples for automation objects, methods,
and properties. It also contains a detailed overview to help you get started writing QuickTest
automation scripts. The automation object model assists you in automating test
management, by providing objects, methods and properties that enable you to control
virtually every QuickTest feature and capability.

B Microsoft VBScript Reference (available from Help > QuickTest Professional Help)
Includes Microsoft’'s VBScript User's Guide and VBScript Language Reference.

B Mercury Tours sample Web site (available from the QuickTest Professional Start menu
program folder and also from the QuickTest Professional Record and Run Settings dialog
box) and the Mercury Tours Windows sample flight application (available from the
QuickTest Professional Start menu program folder)

The demonstration applications for QuickTest Professional and the basis for many of the
examples in the documentation. The examples and instructions in this tutorial are based on
the Mercury Tours Web site (http://newtours.mercuryinteractive.com).

B Technical Support Online (available from Help >Technical Support Online)
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Opens Mercury Interactive’s Customer Support Web site in your default Web browser. This
site enables you to browse the knowledge base and add your own articles, post to and
search user discussion forums, submit support requests, download patches and latest
documentation, and more.The URL for this Web site is http://support.mercuryinteractive.com.

B Support Information (available from Help >Support Information)

Presents Mercury Interactive's Web site and Customer Support site, information on user
discussion forums, and links to information on Mercury Interactive's offices worldwide.

B Mercury Interactive on the Web (available from Help > Mercury Interactive on the Web)

Opens Mercury Interactive’s home page in your default Web browser. This site provides you
with the latest information about Mercury Interactive and its products, including new
software releases, seminars and trade shows, customer support, and educational services.
The URL of this Web site is http://www.mercuryinteractive.com.
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