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1. &I ™| QuickTest Professional 8 Tutorial

1.1

#3112 QuickTest Professional Tutorial - # = {' ;L QuickTest FUpIESE = E' favsf iy [P ]
PV prl#F QuickTest 7| ﬁliﬁuf’w P R A A o R R R [Efl1 e

"] QuickTest i I' HIRMSHEAYAFTL ~ — & Windows " [FH=4 + Visual Basic /" [F=4 ~
ActiveX JE Il ~ LIPS -

4 P s R 0% QuickTest i FIF (™ ~ #hi  STPRIRSRHHL -

BRI O A 5 TR0 | QuickTest P IHHYERT] Mercury BEEES =4 p1E0
SPG > FoV G P R (seript)

i 1% Tutorial
H PRI O [HTH 7 W1 | QuickTest *FtFU3T Mercury SRl =45 o
SHg - L SRR IR Csoript) -

AF"I';%‘E&’YI: _{FIJFIQJ%\I;EJ/ % H'IJFHJ gﬂxﬁzfﬂ@m ,i?EU:i;[ﬁ E NE ﬁ#’g‘k 1o

m  QuickTest Professional fif /i © F4 ' IFIRES = Enf¥po ]« /137 QuickTest Azt
A~ 2AECE. QuickTest fif ™[ /i i~ ' % Mercury Tours #¥ {5«

W RGINRRIA A AR S o 2 SRIRERIE Keyword View fit (il /17 -

B SRS A e R A ) AR A T R -

W AR R BRI SRR vk R R YR L R -
B mgxgirl = L R e N T RSy S R e
W PR FEORRR - Rl

I R e I L R R

W ORPRIRVEE TS 2R RPN TS S SRR R
™ ﬁ?ﬁﬁ'q'g@ : ﬁ% PRI S ] R DTFW‘ QuickTest fluey7 -

—E
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2. QuickTest Professional /i

21 [IEHEA
P 3 R e T R R e
Jore RS 2 RIREAE Y o £ kL TR RO TR R S R PR e ol (SR R
=
fjl "] QuickTest [ I'| Ui ARV > 27 ST (build) Py 4 poish R s > i
FIEvRa i ™ ARV 4 & =R -
I'] QuickTest #h=HIE¢ » #iE== » 7 JHJFEE—~ B2 > QuickTest ﬁﬁi@ﬁgﬁ@gﬁfﬁ%ﬁggaﬁﬂ T
QuickTest F=* = JHFEEH 270" »

F R
Pl (Fast) QuickTest = JEEE=~ T HESHE TR 27 -
ﬁjﬁfé(Reliable) QuickTest & - ﬁ'fl@iﬁﬂ%ﬂa‘ﬁ]lﬁ{l‘ )}’p’g’ﬁlfﬂﬁnﬁﬁl[ﬁjﬁﬂgﬁ|"E’ Al R S O
g
frETH QuickTest "I’} gﬁmﬁl{ R
(Repeatable)
FrAE QuickTest i I' A=V Ay, ¢ » EEHIEIEYRI S ﬁ R T Tl [
(Programmable) U o
?,ij/ﬁlfi QuickTest fi' I'J ?m/]a IRV o W R RS AR Jﬁrﬁ: o
(Comprehensive)
FIffm] QuickTest [i* I' ETHII ™ NIRRT 4 > JIF0EER RN AOI R ] 7 =Rl -
(Reusable)

2.2 WSS
QuickTest F{Jﬁ”gﬁﬁf;‘@nprl AR
1. GV v
R e R R R T | QuickTest (LR 7 S poiefpo -

g o P S P S R - RN e R T O
M
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il ﬁ”wﬂ@gﬂﬁgw "~ QuickTest FI‘JFEQ’L’ Y[l Test Settings ( [Test] > [Settings)] ) I'] %%
Opt'ons hf 't ( [Tools] > [Options] ) - I'JfEfil QuickTest ¢ /iUl @ v
oo fgp rﬁ %F:f’ﬁzﬁé” "~ QuickTest [IV Object Repository f:LI'] {+ ﬁfﬁiﬂ T BTy

2. IRV

Eﬁ*fﬁ\’%ﬁfﬁcﬁ%ﬁﬁf@‘}ﬂﬁé [P ER FHEAE » QuickTest ?77} Keyword View f[iI'] %frﬁﬁfﬁﬁh‘
R SRR IR o B (R T RRHRL D = 8 T SRS PO > AR PREE - W8
st Clink) o FRLEF g e -

3. AR A
W R L R R R QA P Rl R
AT RL A L -
B EARIORIER (hard code ) BERT IV o FlH | LRE IO HRIIRE o e RS -
m P (logic) FYALIE[T (conditional ) gt » T 154 S PIHIFIURS «
4. SHURYHIE P24 (debug)

T PSRRI R 1 o O S TSR (A (o 1 bR £ o
WO -

5. T FVIYEE R AT BT R 4
EETERE - QuickTest (v BN EY AL AR RIS - Ay iR PR oy
AR

6.  JIFTHIESEN
73 P = sk > $5 0 ET;E\E'J?E?“EIUF}FJEE@?& °

7. [pl’ﬁ;ﬁﬂfég (defect)
P ey 8" Quality Center ( TestDirector) - fl[Jfv 'l }}{ij’ éﬁfﬁflﬁfﬁji%[ﬂiﬁéiiu Quality
Center ( TestDirector) EIU?}’%S[?’IHI > Quality Center ( TestDirector ) L. Mercury EIfJiE[J%;ﬂa"FFE,I

— £t
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QuickTest;ﬁE‘F'i,T
T A F ?F[%ﬂgﬂﬁlu %H—Z[: I/F , mJ“E?ﬂ‘ 3 R QuickTest l;[ jﬁJF{,[ o
P pUR E iRl QuickTest o= il «

Title bar & Recording - QuickT ezt Profezzional

Menu bar
File toolbar
Debug
toolbar
Testing
toolbar
Action
toolbar
wwielcome: Mercum Tours
val,_j Welcome: Mercury ..
: u- uzerMame "mercurny' Enter "mercury’’ in the "uzeiMame" edit box.
- pazswornd SetSecure :"4082386e35ea... i Enter the encrypted sting "4082986e392a469e70d
Test pane— -] Sigreln Click. 2.2 Click the "Sign-In'"' mage.
- -4 Find a Flight: Mercuny
I omPort Select "Mew Vork" Selectthe "Mew Yok item in the "fromPort” list.
frombdanth Select "Dec" Selectthe "Dec" itemn in the "frombdanth"™ ligt
Select gt Selectthe 23" item in the "fromDay" list,
Registered users can sign
Data here to find the lowest fare
Table — participating airlines.
User Marme:
4

Status bar Active Screen

QuickTest i = i) &y A* Flp7 i
B Title bar : = | lﬁrﬁEU%’«]{aﬂi fiY €74
B Menu bar : B QuickTest fuIf -

u File toolbar : ﬁ,lygﬂ W& F{ CIER




oldsidney 5 =%l http://www.oldsidney.idv.tw

Open  Print Data  Results  Options Object
Table

Repository

New  Save Active Debug Test Quality  Object
Screen  Viewer Settings Center Spy

Connection
B Testtoolbar : G4 F{fJ‘E'JEIij ST
Split Start Analog
Record Stop Action  Transaction Recording
it
Start New  Insert End Low-Lewvel
Run Action Checkpoint Transaction Recording

B Debug toolbar : SRE[ZVH] 4 B?%ﬁﬁj’ﬂjpfjj S

Step  Step  Clear All
Into  Out  Breakpoints

Pause  Step  Insert/Remowve
Over  Breakpoint

= fieaT- VG QuickTest [ Debug toolbar fiL 1 ¢ &=y o 0 IR [View] >
[ Toolbars] > [Debug] # Debug toolbar ' -
7= P ST ERRYAL A BRSO DS TR AU > 52 ¥ QuickTest

Professional User’s Guide -

W Action toolbar : & i HIEUIPREEE: - 1) R RS (action) o £
(list) {0 ohgmp BRI 1o e o
Action List Display selected action

|ﬁ Test Flow

Back
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s f BT SRR QuickTest R Action toolbar fL 7 ¢ 2= i o v IRk [View] >
[Toolbars]) > [Action]) & Action toolbar ‘i

Hi T EVAI A Flp e reusable FY external action - ]| Action toolbar ik FIESEH=. - B[
FIIEI%E'/][ FIEYR %xﬂ QuickTest Professional User’'s Guide -

B Testpane: @& il Keyword View '] & Expert View -

B Active Screen pane : & FA' Active Screen -

W Data Table : {j SR8 A S B~ & b2 BranRipuds » 557~ i Global o
It > &— {f# action Pj%’“ IR 2 o

B Debug Viewer pane : o iSRS 4 Bﬁfﬁﬁ (debug) - Debug Viewer pane E”fbl Watch
Expressions ~ Variables I'] ¥ Command -

=L H s SRS QuickTest f Debug Viewer (L @1 BE= - fiv o B0 'R [View] >
[ Debug] Z Debug Viewer 3 o

lﬁiij["” l%ﬁ'ﬁ YUY % 24 QuickTest Professional User’s Guide -

B Status bar : 2 J[FVHIF poTE -

B depuRd I}E_J%A == Test I'}% Standard = £'Fj[| -

[} Debug toolbar %’7 F chkTest Professional User’'s Guide iy " Debugging Tests | :ﬁ’[ Qﬁf[l%ﬁ?ﬁ%ﬁ
BE o

Z¥* Action toolbar F‘?& Vﬂﬁ’iﬂﬂ?ﬂﬂ%‘%ﬂ?{: = U*?y ZiE = F]l;.1JF

=7 S50 T9t > QuickTest ~H{# [ﬁ@% ,@y[m;ﬁg@gﬂ e ﬁ%ﬁr 4 QuickTest

Professional User’s Guide fiv " QuickTest at a Glance ; #i] -

B TR ORI GE - T QuickTest uffl ™ [ /7 fFipe! !

24 {f1"] Mercury Tours i
Mercury Tours ATSIAFHFRL - THHLIH T BB IFSFOLT » = PIFOTTE B0 + AL Mercury
Tours & R LA FTAVERS -
i (R REGE - ™ Mercury Tours YR -

241 [ZORBPTEEE
gL ? | Internet Explorer FrH - ﬁ%fﬁci?wﬁ] TRy ) pUTIRS > R BRI e
RS o 1 SRR R ]"Eﬁﬂ%‘?wg&@m e o
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24.2

AP IS O
1. F'#J?%‘Internet Explorer ¥ Eﬁ [Z:])> [nﬁﬁ fRE SR ] > [m*ﬁ'] .
2. %T Cilat ~ =@ ] phipy CFiahskons ) $6 0 ‘E?[E' I Y F% e [EFJE/[ °
3. KIEUE'J IS 5 ] Vi LR Aol 1 E AR ] 2
3
EEED%EE] Erie i LTS A BY1E B P R T REEERTE
—1EH BT
v fddkin)
¥ ZE
[~ SRE F e R O
|l E )
—ialsEEhTTRE LR
EEEC | EREEL |
EEREEL - 253 EPEREMETR] - T ]
TZEE THY GEkRLEE] =
e | Ew |
4. Eﬁi‘ (Ed] #& l'n%w%iﬁ" T&ﬁf hfﬁfuﬁj[fil
7= j’/fﬁ‘/-"/Mercury Tours 5’5?7777[?7;/‘
rj: fay

,[El“ Mercury Tours ﬁf”ﬂ{ﬁfﬁﬁ PTEl R MI[iBF ?4 &

ifﬁf? IE:l“

]

1.

Mercury Tours # {5 ?{ﬁff’,‘ :

[#I5 Mercury Tours i

» Pl 47 Mercury Tours #ifyli

s r"n:ﬁ@%ﬂﬁ%gﬁlﬁ“ IFJ"NPYURL : http://newtours.mercuryinteractive.com

%’-‘f{ [iFMercury Tours# i FiE! -
i

glﬁ * M| Mercury Tours r’f’c/U\ZEJEI%I:P'J P =S -

& Mercury Tours (Ui FIFE [REGISTER] £ > ¢1f) J’? [Register] sffi1 -

7+ [User Information] ﬁ]a’ﬂ P | H =R -WF% ™

T -

EF@:LJF@E (H PO o o T

-10 -
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Eﬁp SUBMIT ###* - Mercury Tours rF“LI' ’p&%ﬂf} Flo E%Eﬁ [ SIGN-ON] #& » %"F'ﬁj‘?ﬂ,‘

[Sign-on] ! - fij 'JﬁJEﬂJﬁ%P TR R R - 3 [SUBMITY ## = [Flight
Finder] Fff! ﬁ?&ﬁ:ﬂfﬁ o

3. %% Mercury Tours #fJigHy
- [Flight Finder ] AfF il - #h It i s BERHT R -

=¥ > 7 Book a Flight S » = P SfolE B gpube &gt )W FH L8 B p IR
T BLAT SR Fl R AR ORI T (e TR R R g
8888888888888888) -

4. FRTRIE

}“"}""’"S‘l‘u”?‘??%‘léﬁf%fé » % [Flight Confirmation] A B [LOG OUT] # & pyfipie s
1 i [SIGN-OFF] ## -

e T [Sign-on] AffEIES %9?{3 7 Mercury Tours ﬁlﬂﬂﬁf’!,‘
5. F*?Hf?%%ﬁﬁ

ST = ESABE P $5 [= Mercury Tour ﬁcﬁ%ﬁﬁh 2L STl EJ@F}{EIE'J QuickTest &G HIZ il
F70 1

-11 -
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3. #EIHFHI

3.1

3.2

E.}’fﬁ;*&%&ﬁﬁf}fﬁﬁ%ﬁ[E'J’f?ﬁ'ﬁ@?“ﬁ?j » QuickTest gﬁ%ﬂ%&fﬁ\'ﬁlﬂﬁéfﬁ*ﬁ%’ D 2 | 3

ﬁl for e [ HER IR R A % %ﬁ?}?ﬂ QuickTest 7+ Keyword View f[iI" }%;rﬁﬁfﬂj;&‘%iﬁ IR foogsh
[EHTR (steps) -

b R R
R H F'Jﬁ: I QFEFHrﬁ FI JF‘EFIJ%E =R Qu|ckTesti_‘?‘ fay Fl ”Elu §=—]L‘EJ

&F%EJ?FIYTF = P pYRRE B %:& E§J[ N

W el Mercury Tours AR~ [P mIH =T @i T O ST Mereury

Tours #J] “ﬂn{ﬁ*’!‘ g
B YL R Internet Explorer T - ﬁ%f’ﬂ\'iﬁ:‘wﬁ] TR pUTIge ﬁ%% M
[T p Nt

I P

SFEIHEVRTA
Bk ekl IRV - 7 Mercury Tours AT - 9=1ER7 (New York) 2]
&1 (San Francisco) [IUSEI -

1. %~ QuickTest ™ fF 'E?SL ffst = SRV £

BRI 'E’F?chkTest %‘%ﬁ fif] i{F[] > [#4=YE ] > [QuickTest Professional] >
[ QuickTest Professional] -
7t [Add-in Manager] Zs# [Web Add-in] » = 2Vif 43y add-ins - ’Zﬁ&&ﬁg [OK]
jf%’;%r%raﬁfj [ Add-in Manager] ﬁlffi:r » %7 QuickTest Professional }ﬁﬁﬁiﬁf o

1=#i : QuickTest Professional rﬁ‘ﬁa&fﬁnﬁf J&§* e IAY add-ins -

e [Welcome] il - Eﬁp [Blank Test] -
i H - Ko [File] > [New] - fvilyd ™ = 29[ i [New] #% -
QuickTest Professional %“ B = SRR A Al o

B {5Y[ QuickTest Professional =5% 'E‘Tifv ﬁ@‘ [Help) > [About QuickTest
Professional] #F1fj#l * 2 IEadd-ins < 1<% @ [Web Add-in] - far.e4? FIEﬁ
Efji?gl %ﬁﬂ?ﬁrQuickTest Professional - §k 7 [Add-in Manager] >3 [Web Add-
in] -

-12-



oldsidney 5 M35l http://iwww.oldsidney.idv.tw

gﬁﬁ [File] > [New] - FykLfF ™ <% i [New] ###* - QuickTest Professional
FAI, [ = P E R A A

FEC B #0= QuickTest Professional [H - 4 #[7% [Add-in Manager] - il
[Tools] > [Options]) - i+ [General] FI#5># [Display Add-in Manager on startup] >
“ — xRS QuickTest Professional Bﬁﬁ{[‘:iﬂ [ Add-in Manager] Elgf[ﬁﬂfﬁ’ 1o

2 %Jﬁiéﬁfﬂfﬂﬂ%ﬁauzt

E [Test] > [Record] ﬁ&ig’r“* 21l Fpy [Record]) #& %’7 f'1% [Record and Run
Settlngs] ?TFTEJEV[

m 7 [Web] [i& > 2Z [Open the following browser when a record or run session
begins] -
ff- [Type] ™ % HEEE 2 [FUBBTAR > = = 7% [Address] i

ttp://newtours.mercuryinteractive.com -

ﬁ%ﬁgﬁ [ Do not record and run on browsers that are already open] == [ Close the
browser when the test is closed] iﬁ_ uf_,p?ﬁuli;f SR .

Record and Bun Settings

Mizrazaft Internet Explarer |_

hitp: A Anewtours. mercunpinteractive. com |_

® 7+ [Windows Applications] FI#% > %/ [Record and run on these applications
(opened on session start) ] - [f ”j IV |ﬁp Y [FE o

IR I ot SR H R R (41 Outlook ) (o[«

-13-
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Record and Run Settings

B [OK] -
QuickTest F’ﬁlr'ﬂ?ﬁf’q’%@ﬁj‘%ﬁ'%ﬂgﬁj Mercury Tours Fﬁﬁ‘fﬂ? I Fﬁ]ﬁfi%?ﬁﬂ?ﬁ?ﬁﬂi °
3. ﬁ * Mercury Tours Web site
7 [User Name] = [Password] FE?J‘ fﬁ\‘fg{ﬁ’?’lﬁ:%?]ﬁ@ﬂ'ﬁ” ;S{-{ﬁ;‘ﬁfﬁ o
%’,‘fﬂj [Sign-In] -
F'ﬁj’?% [ Flight Finder] ﬁfﬁfl o
4. fa? FE[T BIERR|
TR
Departing From : New York
On : Dec 29
Arriving In : San Francisco
Returning : Dec 31

Service Class : Business class

A A EJ[Jﬂ[’ﬁi“F?,’?EIF%@ ’ ‘IF&%!T% [ CONTINUE] F'#JFIJ% [ Select Flight] Afff! -

-14 -
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3.3

et PRI SR UBGEE [View Calendar] & LG Y E G T W Javafiuf]

B o [0 12 E R 0 Java Add-in - g%@ﬁ?u@ﬁ?@o
Fo gy &1 Pﬂ[fﬁiadd—ins %Eﬂ*‘%‘? [Help] > [About QuickTest Professional] - foldsaggi * iy

add-in » v AE TFJFJf fowckTest Professional -
SR

|J5|«7f gl%@ ) E’!‘p [CONTINUE] #&* » F'#J?%‘ [Book a Flight] FI[1 -
i R

R O SR B 6T R (O R
gy - 8888888888888888) -

7+ [Billing Address] /3% [Ticketless Travel] -

£ AfF iy [SECURE PURCHASE] #% » Biffiy [Flight Confirmation] FF! -

L R 595?%[ fhf=

ﬁ%ﬁ SRR &ﬁg [BACK TO HOME] [p'Z] Mercury Toursiﬁﬁjﬁf’!ﬁ’lﬁﬁlﬁl °
@»LF%&“QJ

7+ QuickTest » Bls# ™ £'%j[] HiY [Stop) ##&" » fiiH6ad -

RIS RS I TR R BSEIYEN(E  QuickTest =IFEAGI Y &5 [Record]
s E|E [Stop] D [FTE AU o

fer o VA

EH [File] > [Save] F&i&ﬁ“ 2 Hpy [Save] #E: F'#Jffl% [Save] % ﬁ:"ﬂ;ﬁ‘ylﬁiﬁ o
b~ fli [Tutorial] P& SKREVTS i £15% [Recording] -
253 [ Save Active Screen files] -

B [ 5 RN £7% (Recording) @07 QuickTest i i ATl -

ST Keyword View | I3 4

fi

LN Eﬁ QuickTest fﬁj'” )~ [ (e e > 207 Keyword View I'J 4 (T

Excel ~ I‘P%Elﬁj?“mé? AR R R -

“ Keyword View [iup] 15 gt i e £ i35 -

[item] : I FETF@%?“Ev%ﬂﬂ@?iﬁllﬁ'ﬁéf%ﬁﬁ?rH'JEUElfJﬁ (F QHF [+ (test object) ~
E'"Pi% (utility object) -~ ﬁ{%’ﬂl‘—‘ﬂu (function call) ﬁ‘)’}’ﬁ‘ﬂi (statement) ) -

[ Operation] :Elfiiﬁﬁrﬁﬂj YR Fiﬁmﬂjgm‘ﬁ JpEkEE (Click) ~ #3v (Select) -
[Value] : (1% (argument) ’?Jﬂ'ﬁ'}'i’ﬁ’%%ﬁ ORI R 5 SRR T 5 -

-15 -
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®  [Assignment] : ffi" [E[vA@EE -

B [Comment] : ™R HERRIA Flrp Elﬁé}fjéo

B [Documentation] : [ IEs % B e fffirh gt (e BRI Y -

=y (R N E%LI B g PR o o PUR TR R RS S BB 2R

= ];M;h%]j‘»jd‘ﬁ}iﬂ (I

T2 [View] > [Expend AT A IR 4 o s {1 -

Ikern

-

,_‘ Welcome: Mecay Tours

- ﬁ Weleomz: Mercury T ours

I g ame
- pasEwond
; '__| Signdn
v ,,'__"1 Fitnd & Fight: Hemcwry
- 5= FaraParl
= fiomM onth
&= farD ay

i) firFights

Cperatichr | Y alue

ar_'] Select aFlight Mercury

] reserveflighis

- ‘E‘] Btocis a Fligri: Mercurny

e R tickeiless
@ buylights

- Jj Flight Carfirnation: Mercury :

-8 harme

ESet E"memur}l"
‘Cetfecire ANERENNTEE
Dick 2.2

Seect Mew Tok!
Sdect 'Dec”

=PI e

ESeled 'Een Francisca!
Gmect  Dec”

iSeect DT

‘Seen CRusies
iOick 22

Cich 12,2

Ga “Micale”

ESB: E'Unnes"

S 1734

i5e N

Click 2.2

;Chck

q'__“| Welzoma: Mercury T ours ESync

Diacumentation

EEnbsr "mzncry'' in the "uzsiM ame" edil bow
Enter the encrypted zhring "'40828201 2351 2e8be N 11722020
Clck te " Sigreln” image.

éSeEcl ilern "Hew k" nthe "fromPor” s

Sel=ctilem "Dec” nthe "lromorkh" Il

[ B lsct itern "20" in the romD oy fat,

' Selectilarm "San Fiancizzo" ik e taPart'! izt

ESelal::t ilern "Dec" nthe "okl anth" ist.

Selzctitern 31" in the toDlan” lisk

Select radio button " Busnes:" inthe “wervClazs’ radio button oroup,
*Click the 'findFlighis” image.

Click the tescrveFlights” mage:

Enter “Micoke’ in the “papeFiztl" edit box

Enter "Jaoresz" ik the Vparsl 220 edit bow

Enter “12345 "in the “creditrumbes edit box

{5el e state of The "tickelless' check bos to"ON'"
Clck the "bupFlighi=" image.

Click the "homa" imaga.
;"-'-'ait for e Wb page to synchronize befoie conbnarg the run.

B, Keyword View & Erperl Wiew

m¢ww

| = R ~H\E[ TR o

R

Hl%’!fi

himiy

, & @laﬁﬂ 35 (it
[reserveFllghts]

i

I%q%l[Hl °

- [T Keyword View ([ 1| S 45

[II:[J BB PR ]ii%lfﬁmﬂ)q%ﬁl—]

TR > 71 Mercury Tourﬁe[ﬁif’!ﬁ’lfi [ Select a Flight: Mercury] lﬁ A |

[tem

Cperation

" alue

Dlocumentation

v‘{,—j Select a Flight; Mercury
- ™3] reserveFlights

Click

2.2

Click the "rezerveFlights" image.
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S LR R

L2 wl]
i Action] Actionl kL [[HE {1 £
A wieleome: Mercury Tours Welcome: Mercury RLPAEIFRS VA Y
£ -
43 Welcome: Mercury Tours Welcome: Mercury Tours f‘\i_%ﬁ:‘ﬁ' [ £

userName %L edit box i £ -
Set fL7t il edit box VR -
mercury FIfRLbGjE = Ui -

-‘,'“ BE | zert ame iSet 'mercun"

B password SetSecurs!"4082820183 . | password *fL edit box iu €74 -
SetSecure i{&iﬁ]’[ﬁ* edit box = VRS [
P {esE JJJ[I'"L‘%[‘EIUT‘}JFJ‘: o

4082820183... H[l kL [ i «

5] Signin Ok 22 Sign-In RU! g Y 7% -
Click RLe 35 ! e -k froh =
2, 2 FILRLE W R X, ¥ i -

TR 311 BT Keyword View F7gfian (Rt » 2 s ISR (i TS - A1
FIRIE BT -

Y& Keyword View %’TF;I%’E'% FIEYF ﬁ%ifj% QuickTest Professional User’'s Guide
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4. FS IRV
Hi o R B > QuickTest f BT 1A= pafii i g sgUpogi (= 0 = v ok

4.1

%

IR 4 o R -

RN
B o e oy TERGIHIRVRTE ) SR AR A -

1.

= QuickTest  (ITHIEASIFV VR 4

571" QuickTest M'EJ?T %ﬂ‘% (F'ﬂﬂfi] > [#='& ] > [QuickTest Professional] >
[ QuickTest Professional] -

m BRI - R [Open Existing] -
B B2 Iﬁ‘@kkﬂﬁjﬁ% i [File] > [Open] fhlRliiE™ 215[ Hiv [Open] #%: «
7 [Open Test] S/t - 2 I " Recording , UK+ » SRR (HITF] -

TR D 7 s I N

QuickTest fi'I'] ﬂ'ﬁ}{ﬁ’ﬂ’ﬁ prE pln—%f" TRIEAFEN I o T A BHE ﬁ”rﬂﬁ@%{ﬁwﬁﬂ%l%&?‘ﬁﬂu
R -

Eﬁf{ [Tools] > [Options]) :#4{% [Run]) FI# > i+ [Save step screen capture to test
results] :EFifl1 o #& [Always] -

RHirZ [OK] F—j‘%ﬁfJ [ Options]) % %@Eﬁ .

e e = = ORI

RipE [Run] 2 - @ihlEEE [Test] > [Run] - F':,%Jffl% [Run]) %ﬁ:ﬁ@pf, .
%33# [New run results folder] > & %' ﬁtg'?’gﬁ'fffﬁﬂ?r@% e

Rt [OKY fitfl [RunY St -
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;ii’iuit:reit F'#J?T "f'fEffJ?i%HEﬂ;'%E' G T ?_EU;%‘%M [ R RE S QuickTest g1 i i kIl
ﬁi]o_ fllF 2 QuickTest {1 Keyword View ¢ ehihl ffi f <1 g » 453 |1 = froafass
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4.2

S PrEEN

#i QuickTest ¥ St Il 4 - f PRI S =

Results tree —

Test results details

E- Recording [Resl] -

Test Results

. E& Recording Tkeration 1 (Row 1)

Recording Results Summary

Test: Recording
Results name : Fes
Time Zone: Eastern Standard Time

Run started: 4/17/2004 - 14:04:25
Run ended: 4/17/2004 -14:04:38

Iteration summoar

Status summary

lteration #

1

Status

Passed
Failed

Warnings

= B RS 53 = R DR T A

W LR testresults tree o BT 19 AR RN A T PO TR © i RIGE(+)
B - R mﬂﬁsﬁnﬁwﬁ‘iﬁ?r [ =83 o BT RE QuickTest I'f i
_'g}”l':’ B Ll;[j@g,w‘fﬂbw i~ %g (iteration) - F"JE'QI’E{K’%?B

ORI AL,
FT@ ESF CE Vv Pl 4 p e -
WA R PR RS JF“P/\E[}@’ ° Tk 8-

5 PR

W#QW%WHF”@%EW%%WﬁF%FM%Wi’m+ﬁﬁﬁwﬂﬁﬁwoﬁm$ﬁﬁ@%
QuickTestﬁm”ﬂﬁ[{?}é%lwﬁur,_'fl“@%g\l | L’gl ,a

1 AR R

R Y

i) -

b P P TS ~ P B
O - 57 A FILRHE RO B ALY » PRLRLR o - 1) 29

PR AR R R ey -
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i test results tree » % [f|(+) [ Test Recording Summary] > [Recording Iteration 1 (Row

1)] > [Actionl Summary] > [Welcome Mercury Tours]) > [Find a Flight: Mercury] -

# IV test results tree ([ 11V ["fromPort":Select "New York”] -

Results tree

Test results details

Active Screen
image

B Aecording [Res1] - Tesxt Aezults
Fie “iew Toos Help

FETRRARA +~~ 7|

= T Test Recording Summay ;I
@ Rur-Time Data Step NEIITIEZ
= Recording Treration 1 L s
= D Recording evation | (Row 1) "fromPort":Select "New
El- 48 Actionl Summary -
= ﬁ Welcome: Mercuey Tours YD rk.

- {j Weleome: Mercury Taurs

s | I W TR I

g ek
o "fromPart " Sekect "New Yar Object Details Result  Time
E-:l "Framfontn" Select "Dec"
o= "FromDay" Salect 23" "o mPot"Select ?:I'E':‘ 44182004
E—j "tePort" Select "San Franrisco” Wz il Y E:: -18:03:42
E—j "teMonth" Select ‘Do o
E—:l "temay™ Select "3 1" LI
ﬁ "zervidass" Select "Busimess" FLIGHI FINDEHR ﬂ
| “findFlights" gk,

o8 Sslect & Flight: Meroury lJze our Flight Finder to search for the lowest fare an pa

19 Book aFight: Marcury you've haooked your flight, dan't forget to wisit the Mercur,

19 Ficht Confirmation: Marcury reserve lodging in your destination cily.

ql’j Welcome: Mercury Tours

Flight Details
Type: & Round Trip < One

P assenigers: IEI

Departing From:§ Mew ¥ork hd

For Help, prass FL

One ﬂ,pr | |18 =
Arriving In: | Zurich 'I

Returning: | Anr "I 19|= |:4|j
| r

[Rzady [ | 4

PIRIRSSE: e = i - T3 BB -

B SRR Testresults tree & F— EW ERRLERY

u ‘F[f“bﬂ Test results detail : ¥LE VA ER > IS
B kL Active Screen @ B IPREE ERER R RREV Y R

F',”%ﬁ‘éj test results tree _FAYAE qg[qu , f’n\’ﬁr} [ Active Screen] ff 1 Z][#hk "’;Eﬁﬁfj:ﬁf}?l . ’5,[
'QEﬁfﬂi test results tree FAVHIFESHH R (5 [EPF FEGE SRS o [RETS E'}’Eﬁﬁ@%ﬂf&'l

gt Fi’dfiﬁ%’??ﬂé”}??\f SIS o T PRI Eﬁf{ test results tree iy
["fromPort":Select "New York")] - [Active screen] %‘7%@? BeAE==pY [Departing From]

i -
2. B R
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Eﬁfﬁf’_ [File] > [Exit] -
ST o e IR T S AR

.
N

-22.



oldsidney %3»?»?'; ' http://iwww.oldsidney.idv.tw

5. B HARY
TR (R > et T [ R Mercury Tours BT B S IOTTCRSEIRVETE © B
y Ia;{ﬁ]’&ﬁﬁ ﬁﬁﬁgﬂ‘ ﬁ%‘*;ﬁ#ﬁ[ FhE A RLT 4FEEIJ

5.1 U'Ejg;[fgﬁg*, %’JTEIU@Z?FT
QuickTest Professional # i I'] ™ El%ﬂﬁ E’!,‘

wanmE | #e |

BN | AP | R radio button KL ks

BB | AR EORIE | A VR e

R R e R e R KART O

MERET | WA | B ORISR LR £y o

(link)
ey ﬁ@‘, %ﬁgl RS R ﬁ@\, F:f B .“g‘;ﬂ_}l\, Dl ',;;UIF:I* By Thpud 3
wﬂ]}ﬁiﬁ&ﬁ%ﬁ%ﬁ E{z[ |:/L 3[ 1
R I

WRGART | GEVETOEEET | S (SR A0 AL TR
A L

i
TR | B TOREOT | SR EVRI A AL T
[N T
= f 1L F‘%

Accessibility i | |dentifies areas of | Check if the images on a Web page include ALT
ﬁl %!T a Web site to properties, required by the W3C Web Content
check for Section | Accessibility Guidelines.

508 compliancy

XML )ffgg} Elﬁ 7&%3\, XML {Fpy | =30 XML fr‘éﬁi?}g‘%@ E’!ﬂﬁ'ﬂéﬁ%@’ﬁj AU XML %

M XML B B 40 AT o
XML % [ -

o ) S SRR S S R e 5 OB B
(P THRRE A | SRR e i
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=31 : When QuickTest creates a checkpoint, it assigns a name based on information inside the
checkpoint—the checked value, for example. The checkpoint name remains unchanged, even if
you subsequently modify the information on which it was based. Keep this in mind when looking
for checkpoints displayed in the Tree View. However, note that QuickTest may shorten the name
displayed in the Tree View.

fela— W g ’Iﬁ:ﬁ[@ﬁ ﬁ%?ifj% QuickTest Professional User’s Guide ©
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WPl
rjlﬂlﬁ%%,ﬁg > far ij: Book a Flight Affff 1 - ﬁf*ﬁg\gﬁ éﬁ)ff@\ g’giﬂ 1\4}%3 AP o
1. %~ QuickTest ™[ J?S‘ I'Recording | JH[Z0 %+

00 QuickTest 2k F'EJ?S" E’!‘ﬁ [F'ﬁJiIF'}] > [#H=V£& ] > [QuickTest Professional] >
[ QuickTest Professional] -

u f@ﬂ[‘ﬁﬂ?#@&’fﬂﬁlﬁiﬁ‘ ; Eﬁp [ Open Existing] -
m IR Féﬁg [File] > [Open] A RLGET 219 (v [Open] #% -
7+ [Open Test] a:j‘ﬁﬂﬁllfi,l S MIMISE]RY T Recording | HEVEIA o SREEGE [Open] -
2. JR{MIZVEIA b5y €155 T Checkpoint , JIZEI 4
2 [File] > [Save As] - J{iHIEHI 4 % fi=5 T Checkpoint ;-
3. FEI?J [ Active Screen] flLfF lpf]gu

M52 ¢ %1% QuickTest 7 %Y [Active Screen] - Rl 2! H{i [Active Screen]
e Fu&f\_ 2 [View] > [Active Screen] -

4. EIVRIEC A BT
PoEer v U R > O [ RS A First Name edit box (i ©

7+ Keyword View |1 > 5[|(+) [Action1] > ["Welcome: Mercury Tours"] > ["Book a Flight:
Mercury"] -

OB P B OREEREL [passFirst” Set... ] gl R | SEE
[“passFirst0” Set... ] ™ [ B0 | iR 467 i o
{%?Viﬁfﬁ?ﬂﬂ%*ﬁﬁiﬁéz » 7 [Active screen) F‘%E? [Book a Flight] Afff! » [fij ' kL Ivpops
ﬁcﬂjrﬁ%ﬁz@@ﬂs o sy i I 2 BF & U KT First Name edit box fl1

5 gi- [[ﬁ‘@ﬁ‘éﬁﬁﬁgﬂr

#f [Active Screen] f[ifiJ First Name edit box Eﬁ%{%@% # WV [Insert Standard
Checkpoint]) - F‘F'EJ‘T’PF [ Object Selection - Checkpoint Properties] fj’ﬁ [ﬁlgil

Il
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Object Selection - Checkpoint Properhies

E---E_ﬁ "wiebT able : Home
=58 webTable: 5IGN-OFF
El---ﬁ "WebT able : Pleasze review your travel itinerare and

Elﬂﬁ "WebTable | Please review your travel itinerary a
El---ﬁ:_;ﬁ WebTable : Summary
E---ﬁ "WebT able : First Mame:

ﬁ%l?—,’d [ WebEdit: passFirst0] ¥y » Eﬁfé‘_ [OK] -
F’ﬁﬁﬂ?i{ [ Checkpoint Properties) faéfﬁ?,;ﬁlgﬁ o

#" Checkpoint Properties

dizabled 0
hitml tag INPUT
innertest

name pazzFirstl

readonly

ST PR
(] [name] ﬂiﬁ[’lﬁ'?’l N RG]
B [Class] RLgil#FFORH] - WebEdit F i i L[ edit box -
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7 [Type] e flis [ABCY [ ot sl R AL R {0
S5 [P > QuickTest f 2 SRRV RS (=Bl FORFE - 11 I ig rBf gt -

T fif e

htmltag | INPUT INPUT fiRL HTML RUiffs (15 INPUT A2

innertext Eriﬁﬂﬁfﬁﬁﬁjﬁi > innertext fIYfifl RL4f% o ﬁ%ﬁ,
R %’7 Ao B IR g T L R LA

name passFirst0 passFirst0 lﬁﬁ edit box fiJ £

type text text £ HTML }aLtJF‘[ﬁEH r@[ﬁi INPUT $sFp4
AR

value <fEx> ?iiﬁ['[ai edit box iy * [l 4 -

(SRR 4 [ ooy pog )

}%a‘%ﬁ?;“ﬁ@r%y@ ’ %a&ﬁfﬁj [OK] - QuickTest F‘* e (AR VAR FiE - (R
i

¥ ‘,rj Book. a Flight; Meru:ur_l,l :

: - passFlrstD Set é"Niu:u:uIe" Enter "Micole" in the “pazzFirztd" edit box.

: B ] CheckPaint'pazzFirst]’’] Check whether the “'pazzFirstd" edit box has the proper
- passLastD Set E"-J ones'’ ‘Enter "Jones" in the "pazslast]" edit box,

6. R
%’!ﬁf (Flle] S [Save] Wi_g’!rsej tlrlj F]EIJ [Save] Hf—_‘
MO ———
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5.3 WA E
RFHHETE » COR B~ TSRO B AEE R B S A PO Clink) ) P o)
R SRR - B -
Lo EVRE AR
i+ Keyword View 1 > 5ff(+) [Action1] > ["Welcome: Mercury Tours"] -

i =T

7V Keyword View f[1fiv ["Book a Flight: Mercury"] 5fff1 - 7 [Active Screen] %’iﬁgm 1,.4,[4
AHEI VR e

2. git- ﬁaﬁ{ﬁ‘g’[ﬁ%gﬁgﬁ
7 [Active Screen)] F{=- By HiF™ ?’F”E%‘F,% » ¥ [Insert Standard Checkpoint] - %" 1]
FIS‘ [ Object Selection - Checkpoint Properties] amT—F[;ﬁlgi,l o FHAE fes Eﬂm‘ (Il amT—F[ny
T RV T R

Object Selection - Checkpoint Properties

E"'ﬁ Fage : Book a Flight: kercun
E---E_ﬁ wehTable - Home
E---ﬂﬂ “webTable : SIGM-OFF

Eﬁ WwiebTable : Please review pour travel itinerary and mak;
=k Eﬁ YWiebT able : Please review your travel itinerary and
Hﬂ Ww'ebT able : Surmmary

Eﬁf{ [ Page: Book a Flight: Mercury] (7-i8 F'&) ‘Iﬁ.&&ﬁfﬂi [OK] -

# %F'ﬁj‘?ﬁf [ Page Checkpoint Properties] %ﬁﬁﬁl@f °
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&' Page Checkpoint Properties

load time

nurnber of images
nrnber of link.s

I HTL source. EQRHTMESooces. |

= BT LE0E =l A S e

F{l}.{s\»ﬁﬁ,"::mUE:ngﬁ » QuickTest ﬁ?}tﬁg\[;\lﬁfl Elfjigﬁ_[,% ,T?qg'[l):ﬁ E[SJg\%E RS Emﬁﬁﬁ?ﬂ , wtvm—ﬁjé_:\_‘[_ﬁ_ﬁ
T R -

QuickTest s fi i link s URL I'f 5 [l FFURHILEL ) 7 T <

HosE o K [0K] -

QuickTest F"ﬁi Book a Flight: Mercury sfftf1 ™ 1t~ {146 f gﬁ

vnE'I Book a Flight: MEFCUF}'E Check. gEheckF'l:-int["EDDk... gEheck whether the "Boak a Flight; Mercuny' wWeb page has the
3. EEHEVAA

Eﬁfé’. [File] > [Save] ﬁ&ﬂ&ﬁ&?j =15 Hiv [Save] HE -
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54 fified
&;F%I’[ai%ﬁﬁ o %ﬁ@j@ ER Jﬁf‘ﬁg}%ﬁ firfh & ["Flight Confirmation"] A1l [fL_F}H'EFJ
["New York"]) -

1. EVRIgEg iﬁﬁg\, %’!ﬁlf‘l,ﬂﬁfj
7t Keyword View |1 > 5f](+) [Actionl] > ["Welcome: Mercury Tours"] -
3V Keyword View f[ifiy ["Flight Confirmation: Mercury"] Fff! - i [Active Screen] %’7%7
2. @j@b{ﬁg}&ﬁ
7+ [Active Screen] f[i - #3V%: Departing, ; > HpY "New York ; -
SEREIVAYY 3#]@6?[% Eﬁf;:?_ [Insert Text Checkpoint] F'ﬁj?{ [ Text Checkpoint
Properties] ;Tﬁ:f,ﬂ}ﬂ ffirf o

&" Text Checkpoint Properties

Checked Test |_

o iz

Fil}‘ [Checked Text] 15l ™ £+ =& H HIE\JJ‘ » 7 [Constant] #i# p%’g% o3 TV A Y
o iﬁ% #iEhL QuickTest v = = 4 E\Hj‘ﬁ’?g',w[ﬁﬁ o o
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2 [OK] IS
QuickTest 7 JRVRI A o1 b i S b i S5l S0 g He ["Flight

Confirmation: Mercury"] AffFi ™ »
v{j Flight Caonfirrnation: M... EEheck EEheckP‘uint[”Ne... EEheck whether test in the "Flight Confirmation: Mercun' Web p
3. W IR

E’![‘E [File] > [Save] FvRIEEET 29 iy [Save] #E: -
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5.5

W 245
?iig%f[a;i ) rﬁj{j%‘*@ﬂ - |ﬁ%#‘ﬁ%§‘%ﬁ 1;%3 [ Book a Flight: Mercury]) nﬁgl Ft[ﬂ[ﬁﬁllﬂﬁ?ﬁlfjf%?
£ o

1 EIVEES g BOSHE
i+ Keyword View 1 > 5ff(+) [Action1] > ["Welcome: Mercury Tours"] -

# IV Keyword View f[1f% ["Book a Flight: Mercury"] nﬁE[ o 7 [Active Screen]) %" 2. %ﬁEJ
U -
2. A RASRAE

7t [Active Screen] {1 > 757~ w%ﬂrgu]g%f (New York to San Francisco) —270— %ﬁ
:a-i{f% (S JREEIV [Insert Standard Checkpoint] -

Ff {1 [ Object Selection - Checkpoint Properties ] a:iﬁﬁfi[fi,l 0

— B JtzF B IVpUREL WebElement: 270 » lﬁﬁf EN F;IE’J*EE F— gy WebTable $7{F » 5V
WebTable: New York to San Fransisco -

Object Selection - Checkpoint Properties

E---E_ﬁ WwiebTable : Home
=-5H webTable : SIGN-OFF
El---ﬁ WwiebTable : Please review vour travel itinerary and

: Eﬁ “WiebT able : Please review your travel itineram a
Eﬂ ‘WebT able Summar_l,l

EEC 8 EE [Active Screen] b oIV J%ifﬁ%ﬁk&ffﬁﬁl# o B [OK] -

%%F'ﬁ?ﬁr [ Table Checkpoint Properties] ‘%TE—F@?LT » B %Zﬂﬁiiffﬁpq[ J“'Fk[' o
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2385 Table Checkpoint Properties

v 12/29/20
v CLASS v PRICE
¥ Buzinesz |v 270
v 12031720 |

v CLASS v FPRICE

v Business [» 270
o1 o

L+ Mew ok to San Francizco IE

e

ﬁ]%ﬂg fl:ﬁ‘#ﬁf“_"ﬁﬂﬁ@f\ifé » FA ’;I”Tfjﬁﬁfi'ﬁﬂﬁfmﬁ SETENES RN flﬁ‘ﬁ;ﬁf"i’%’!ﬁ o VI
PR S RLEIITRRAR I BT e -

75 O PORIRTIRG T & » SV RO > R ST T - SYSTIT  0 f 270 %
S l?ﬁé’.ﬁﬁ%\'i o E![J%im"?ﬁ\ﬂj QuickTest Fﬁfa:%ﬂ%h‘ﬁﬂj’@ ]’#ﬁfﬁg‘] o

Mew Yok, 12429420
FLIGHT CLASS P'EHEE
Blue Skies  Coach v 270

San Franc 12434520
FLIGHT CLASS PRICE

Blue Skie  Coach 270
1

Pacerninean

B L Ry SR S o F) R A R -

%‘Tiif [OK] Ffrdﬁﬂfﬂéi‘ﬁlﬁpﬁﬂﬁi“f °
QuickTest Fﬁfﬂﬂﬂ%ﬁ’«}'ﬁ‘ﬂi fl1 > ["Book a Flight: Mercury"] FIf1™ b ﬂ#%ﬁﬁﬁj‘, Eﬁ
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gEheck gEheckF'u:uint["B oo. . gEheck whether the "Book a Flight: Mercun Web pag

vﬂ Eook a Flight; kercum
Eﬂ Mew York to San Francizco Check, EEheckF"Dint[”Ne... EEheck whether the content of specified cellz in the "M

Enter “Micole" in the "pazsFirst0" edit box.

Set "Micole"

3. @RV
B [File] > [Save] poRLEf# ™ 25 1Y [Save] #4 -

1=
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5.6 .%(LW*

R RO
&iﬁl’[ﬁ‘uﬁ,ﬁé”\ﬂ% R 07 6 ORI S - 0

H'V

1. B Keyword View Ao B IRV 4

2V [View] > [Expand All] FSRLFIH] [% ] LF% (i o 27l Keyword View i 'ﬂ”#r{

AR

R S

I

Item

Operation | alue

Documentation

- jWeIcome tercum Tours
w48 Welcome: Mercury Tours
q"m uzertame Set "mercuny’’
i q“m paszsword SetSecurs: "4082986239. .
i b Signdn Click 2.2
¥ q',__"] Find a Flight: Mercury
&= framPart Select  "Mew York”
- 52| fromi anth Select  ("Dec"
- ] fromDap Select  "29
-] toPort Select "San Francisc...
-] tobdonth Select "Dect
-] toDay Select e
8 servClass Select "Business"
i b findFlights Click 2.2
- ",—j Select 5 Flight: Mercury
. -1 reserveFlights Click. 2.2
Page checkpoint — q',_j Book. a Flight: Mercury Check CheckPaint["...
Table checkpoint ﬁ Mew York ta San Fr..: Check CheckPaint[". ..
M pagsFirst] Set "Micals"
Standard g'? passFirstD Check CheckPaint"..
checkpoint -1 passlastd Set "Jones"
--TBE creditumber Set "12345"
- ticketless Set "o
o] buyFlights Click 22
Text checkpoint — é__"'l Flight Confirmation: Mer... : Check CheckPaint["...
_ T home Click.
------- Lo I welzome: Mercury Tours | Sync

2. BER SRR

K2 [Run] 4L [Test] > [Run] > @I [Run]
results folder] -

HiZ [OK] -

3. AR

yvg%‘lﬂ o
HARESE LB QuickTest ¢ F I

SR

Enter "mercury’’ in the "uzerM ame'" edit box.
Enter the encypted string 40823862 3%ea469e 71
Click, the "Sian-In" image.

Select itern "Mew York" in the “fromPort” lizt.
Select itern "Dec" in the "frambdonth list.

Select item "29" in the "fromDay’ list.

Select itern ""San Francizca' in the "'toPort" list.
Select itern "Dec' in the "tobdonth' list.

Select item 31" in the "taDay' list.

Select radio button "Buziness" in the "servClazs"
Click the "findFlightz" image.

Click the "rezerveFlightz" image.

Check whether the "Book a Flight: Mercuny' wWeb
Check whether the content of specified cellz in th
Enter "Micole" in the “pazsFirst]" edit box,

Check, whether the “pazsFirst]" edit box haz the [
Enter "Jones" in the "paszsLaszt0" edit bow,

Enter "12345" in the "creditnumber” edit box.

Set the ztate of the "ticketLess" check box to "OF
Click the "bupFlights" image.

Check whether test in the "Flight Confirmation; ke
Click the "home" image.

‘Wit for the Web page to synchronize before conl

253 [New run

IR U
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Hi: QuickTest ¥/ K IZVRIH » WIS SR b1 7 F BRI » ) = Ve i U
FQTM%L_ Passed » UL » B E [[IOA Eﬁ?ﬂi_ Passed ° [y puffEtaH kL Failed » #5-F)
ﬁ%ﬁ‘[ %ﬁFailed °

4. WA B
T+ test tree 5fE|(+) [Checkpoint Iteration 1 (Row 1)] > [Actionl Summary] > [Welcome:
Mercury Tours] > [Book a Flight: Mercury] -

+ 3TV [ Checkpoint:"Book a Flight: Mercury") -
rﬁ,i%gm [ Details] giﬁﬁ e NIRRT Mﬁ@ E,hzf JPw\E'X?%\' » T E lﬁ@* Eﬁﬁ@ﬁ el fing

HF 455y [Details] ﬁiﬂrﬂ v o I RER RSV R A
IR E I E S AT ! > R AL > 5 R A E b RfaE UL passed ©
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E Checkpoint [Hez1] - Test Hesults

== 7|
Mheckpairt Summarsy

- Tine Dtz Standard Checkpoint "Book a Flight:
o R Mercury": Passed

_ ¥ welcome: Mercury Tours Date and Time: 4/19/2004-10:37:27

qrj ‘alcome: Meroary Tours
qrj Fird a Flight: Mzrcury i
&1 Select aFicht: Mercury Details
- o ) Bonk & Flight: Mercury

Fage Check
E- w# HH Mew vork bo San Franciseo
TE 'paccFirctn":Sek "Niccle” Property Name
,f! passFirski [oad time
q- 'passLastd’: Sek "lones
B ‘Credimumber'; Ses * 123495
&7 "HickefLess™ St 0N
G 38| "busyRichts™ Cick Checking the links captured addresses vs. the expecied one:
H- o* o] Flight Corfirmation: Marcury :
{j ‘Weloome: Meroury Tours Hiil 5 =T

number afimanges

nurmber of links

Home
Fligghts
Hotels

5. ’lﬁﬁj?«)fﬁ’lﬁﬁ‘[ R
i test tree iV [Book a Flight: Mercury] FifF1fil(+) [New York to San Francisco] -
F# 9V [ Checkpoint:"New York to San Francisco"]) -
7 [Details) s 0 ') € 2 AR i BIFOREAFIRR = ') SR AR O
PR PO I B PR RS Y2 F Rl PORANE T e R ) F["'f{\i?f[ﬁ'?‘
ﬁﬂiﬂ\l %!ﬁi%ﬁl (R i o B RO R AT o B A %ﬁﬁlﬂﬁf'ﬂ £, passed o
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Standard Checkpoint "New
York to San Francisco":
Passed

Date and Time: 4193/2004-10:37:27

Details

Yerification type: String Content. Settings: Exact match -
OM; Ignore space - OMN; Match case - OFF. Results:
Checked 1 cells; Succeeded: 1; Failed: 0

—
—
.
T
—
—
—
—
—
—
4| |

6. Aw AR AR
7t test tree fiy [Book a Flight: Mercury] #ffE1 5tif(+) [passFirst0] -
™ 3# 3V [ Checkpoint:"passFirst0"] -

7+ [Details] E{‘ﬁ?"'ﬂcﬁ‘ IR, %ﬂﬁlf%—ﬁ%l?‘%ﬂﬁ# > Yk PR o T B
([ o ISR b BT E ) Tt RS RIS - B TR RO RL passed -
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=
Standard Checkpoint "passFirst0®:
Passed
Date and Time: 4/15/2004-10:37:28
Details
passFirstl Results
Property Name Property Yalue
html tag MFLT
innertext
narne passFirstd
Type temt
value Micole
[

7. Mapd 3*’1;%@ E’!ﬁuﬁ‘,%‘\l

1 test tree fiUF|(+) [Checkpoint Iteration 1 (Row 1)] > [Actionl Summary] >
[ Welcome: Mercury Tours] > [Flight Confirmation: Mercury]) -

+3#3V [ Checkpoint:"New York"] -

7+ [Details]) gi,lfr*‘rﬁ prlEEd )[ﬁj E’ﬁzur,fl:%%\' ) HJV}@HQ/J 7[}%3 E’ﬁa RSeS|
[}j?ﬂ 1 BT ﬁ%g\ E’!“p JﬁHé,J L passed -

Text Checkpoint "New York": Passed

Date and Time: 4/15/2004 -10:35:08

Details

Text Checkpoint captured *New York®™ betwean Departing and
to San Francisco 12/

batch case: OFF

Exact match: OFF

lgnore spaces: Ok

8. FRPfRRIRS B ot
Rt [File] > [Exit] tfRHIZSRHH i -

f
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6. ("

6.1

B (R ’frﬁ VR P 278 R IRNE R o S SHRMR e By =i R

R F['f’ TR 10?'7 fi E'Jﬁféﬂ e Tﬁw%@?ﬁf YIPRE o B RTEIY T ZORL A T

El%f}[jzﬂ 10 A T [filerh] TLJT%[‘“*@J*? Al (B < Jﬁ%ﬂ v | ‘ }H%@?‘FEJ L= Sl

o0 SRESAE QuickTest fruseg| ﬁl S :101“'7[ meH Z//] i S chkTesti’#Lﬁ H
AR Vd‘f 153 W xﬂ 107 'E‘*?H = 10 #39?@ TS

TR R

?i;[/ﬁ']ﬁfl%\'%’fiiﬁlfﬁ‘?ﬁﬂ:‘?"ﬂi?r e AR EE PV E > R o R Hi_[[*ﬁ il
) SRR + TRV SR © SRR « R - K ﬂﬁu
Y }H?E‘[Ja?@"]ﬁﬂ?[?H'FU”'EE%%V’*E’TI Y= TR "]ﬁﬂjfﬁjj‘@tf N F'J”'éﬁ“‘mﬁgﬂ"" ?
%[ 1o

1. %= QuickTest ™[ JFIF I Checkpoint | JHZ¢Hl 4

571" QuickTest M'EJ?T %ﬂ‘% (F'ﬂﬂfi] > [#4='& ] > [QuickTest Professional] >
[ QuickTest Professional] -

YR F;@«JJEFJFJ/I Eﬁ [Open Existing]) -
W BT - B2 [File] > [Open] FiliiaE ™ S by [Open] £ -

7+ [Open QuickTest Test] tfﬁf,ﬁ}ﬂ[fil 1Ay T Checkpoint | JHIEVI4 - ’Zﬁ&&ﬁ_
[Open] -

2. JKHIRSEIA BYEsb €55 T Parameter | R4

R [File] > [Save As] < K1+ S A5 © Parameter ;-

3. ?ﬁgfd [ Active Screen] jgf'ﬁj?ﬁﬂ@

(2L A UchkTestJF "~ Hv [Active Screen] > Lﬁ#,‘ﬂf* 23] Fp [Active Screen]
e ?'k/i-%f [View] > [Active Screen] -

4. ?ﬁgfi [Data Table] ﬁr'ﬁjflgiﬁfj

8477 QuickTest ™ 4327t fl [Data Table] - ik~ =5 1Y [Data Table] #4: »
j«cgﬁ_ [View] > [Data Table] -

5. ENVRIZHA(AUY S

7t Keyword View f[1 - 5ff(+) [Actionl] > ["Welcome: Mercury Tour"] > ["Find a Flight:
Mercury"] -
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+ Keyword View F]l&#‘““"fromPort"*F WY [Value] 6t - JREF] &#‘ﬁ'% el qgﬂl—l . %'7
T@T [ Value Configuration Options] gmfﬁfpﬁlgi,[ o

Yalue Configuration Options Ed

6. IR
R Parameter » 1= e » it 7 BTk s (New York) SaflHiGeff -

% ;s [Data Table) jf_,,[[n = iF%I A TE I ll—&gﬁu@lﬁ §-QuickTest iy Data Table f[1
‘a‘vqg

1= [Name] #f ¢ %“L i p_ltem » ﬁ% % X (55 departure -

DrataT able |_

hE [OK]) Ffﬂﬁfbﬁﬂ?iﬁ‘ > QuickTest F’-‘fﬁi Data Table [ 15§} departure ZHefich > =7 5 F5 7 —
i New York fifii - [l New York g@&@?ﬁﬂ%ﬁﬁﬂ‘lp SRR PO Y- [ i
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6.3

- ‘ Achonl
- i‘ﬁfaburnac Mercuy Taurs
." o Wekame: Maroury Tous |
‘_J Frdd & Fight: Memup

iSalect EDalaTable{"d... ESBIed itam £the valus of the apecisd Data Table coumne b he * fomPok”
lect E"Dec" 'Selev:'t item "Diec' ' in the "flomd oeth " list.
E frarnDay S-:Ind inag {Selectitem 20" in Boe "lromDay ot

0
New York, ] Flight Detailks

rIF-pnrhuP |_ Type: & R

i —
Global AER, Aclive Smeen

IR - ™ T Keyword View [IIfIUR8 = « & S5V ] » 1R BRI
["fromPort" Select "New York") - FiF > iFHWEUE:% ARy 0 [fromPort Select
DataTable(“departure”, DTGIobaISheet)] ° F{' &F [ Value]) ﬁ@%"fﬁﬁﬂj » [Value] #ighb
F’T@F’M[l* H%"[[F”ﬁ o Fe PPIERH R *ma‘wgm RERNI N fifi}L7$-Data Table f[1fY
departure gt f[1IZVE o

New column in
Data Table

6.2 EaceE Sl e
ypfeErfl - QuickTest ﬁfi Data Table [ 12+ 25l - 7 F=FA > fﬁcﬁ& Data Table |11 P1 %
SrehALREeR] > F QuickTest i [l LGSRl 7 R4 -

1. 7 departure h}ﬂfiﬁﬁﬁj‘ BRI 27%vER
Y departure i pus7= 5 > @ TPortland ;-
MY 5 i‘??p’a’nj‘ Seattle | -
# ™ [Enter]) -
2. @R
Eﬁ" [File] > [Save] fhLiiE" 2% Ffiv [Save] #6*

st ;,fuféfg'r OB
AR o F %“Iuﬂﬂ»pﬁsu %ﬁ%é‘ﬁ%l SRRV (R N e &
RO mgﬁwéﬁ I guw%ﬁ‘wg\n [ -

Ji i
K

1. (& Jﬁ%@ Eﬂ,‘
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7t Keyword View |1 > 5f](+) ["Welcome: Mercury Tours"] > ["Flight Confirmation:
Mercury"] -

ﬁ;&&ﬁ%?ﬁ%f,% » 33V [ Checkpoint Properties] F'aﬂ?% [ Text Checkpoint Properties]
S -

& Text Checkpoint Properties

Checked Test |_

et

o

2. B IR B
+ [Checked Text] v [Constant] ## ﬂjp][ﬁ%ﬁﬁ "New York ; » i JH[ZVAI4 2 Vg
[ > Sy A i REFOSFITED T New York )
uhE [ Parameter] o

Eﬁfé’_ [ Parameter Options] 4" » F'ﬁj’?? [ Parameter Options]) %ﬁlﬂ;ﬁﬁgﬁ 0
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Parameter Options

DataT able |_

7 [Name] * #(EE]EHH' L) FdepartureJ EFF'[ L;Lr_,,[[_{—«lf 3@@[ &l!l—fﬁ[ "] departure ﬁ%fj H lEIfJ
f > A5 RLbG RO -

fi LOKY ISIR  1=s Fie R

s W

52 [File] > [Save] L £/ 1 [Save] i -

6.4 ETTOIM D BRSO
F o (BTG S5k sy pY T Parameter | JIEVAIE 7 - QuickTest ﬁ[ﬁl t| Data Table 1
departure fig¢ fofifi > ¥ = EIEETA

1.

2.

5 " Parameter ; JHIEVH4
215 HAY [Run]) ﬁ&i&f [Test] > [Run] - F'aﬂfflif [Run]) fﬁfﬁjﬂﬁlgﬁ °
$#7U [New run results folder] - JEI%?’E'HEI%EEI °
RrE [OKY Bl |IZHI 4 - F‘i‘hﬁﬁ“uﬁ' ’ F’TE' I fy?ﬁﬂﬁw’?%ﬁfjf.’il
A A
B |teration 2 :

it results tree |1 > HfH(+) [Parameter Iteration 2] > [Actionl Summary] >
[ Welcome Mercury Tours]) > [ Flight Confirmation: Mercury] -

TV [ Checkpoint:"New York"] -
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B Parometer [Resl] - Test Results

File “iew Tools Help

FETRRARAQ |+ =

Test Parameter Summary
B run-Time Data
-,.r['h Parameter Teeration 1 (Fow 1)
-3¢ Parameter Leration 2 (Fow £
M- ﬁ SkartUp Browser
- X ' dckionl Summary
=] xi Wielcare: Mercury Tours
gr_"l Welcame: Marcury Tours
qrj Find 2 Fhight: Mercury
H- q,rj Select a Hight: Marcoury
- xﬁr_ﬁ Book a Flight: Mercury
=] ,,-q.r_"l Fhoht Confirmation: Mercury
o i'f Checkpoink "New ¥ork”
W "home"- Smart Identifica
™ "harme": dick
B & Welcame: Mercury Taurs
H& Pararmeker Ikaration 2 (Row 2

4

For Help, press FL

|

?
N - || d
Text Checkpoint "New York™:
Passed
Date and Time: 4/19/2004-14.44:09
Details
Test Checkpaoint: coptured "*Fordland® between
Departing end to San Francisco 12f
latch case: OFF
Exact metch: OFF
lgnore spaces: QR
-
Flight Confirmation & 2004-04-19311965
Departing A
Portland 10 San Francisco
1202972004 g 5:03 w' Blue Skies Airlines 560
Busineze -
o | ;

Ready

[ I 2

I Jhﬁg\, %’!ﬁ'l@ [ Details ] ﬁi;f#‘ » B

L Portland -

Iteration 3 :

it results tree (1 > Hff|(+) [Parameter Iteration 3]

Portland E53FHHRH U [ Eﬁ»ji«g:, B > F e 3

&7 HpY [Application] [fi[F‘HI s BT BB SR

> [Actionl Summary] >

[ Welcome Mercury Tours] > [Flight Confirmation: Mercury ]

# IV [Checkpoint:"New York"] -

?ﬂ;@\ Eﬁm [ Details ) gﬁf,fr*‘ Fl1 > B Seattle 5 [ﬂ Eﬁ”u%_féﬁ BEff > Bl 3

B R - G

£ ™ Hpv [Application] TF'L[F‘HI o BRSBTS BB

L Seattle -
PJ R SRR o 1 A gy BEORER
Iteration Expected Text Actual Text Result
#1 New York New York Checkpoint Passed
#2 Portland Portland Checkpoint Passed
#3 Seattle Seattle Checkpoint Passed
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o BERE VRGOS > I BV PORLE Y o (LRLTS TREEETS SRS AEN IR
EURRE o ALV LT SRR RESRR S ey T AA R BT PV RS S Aiheh Rirk
B i gt il pURH SO @ SRR B 3 QuickTest FIEIR TR AS A i Bl
ORI SR A DR R

3. I BRI i
RipEt [File] > [Exit] RARfRRIRSSE fw!ir «
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7. E L

7.1

T DR HUHIN > PAZs i Y |2 Y Data Table FHIEVEI A I 07T FJF'U‘?EIJ%?H@I ° fﬁJ’F%i
By o ety I R R e RR[ 2] Data Table o iy ' P pRIEEF T IR A o PR |
Z[ - QuickTest n"}{ﬁj’ VYRR 7 Runtime Data Table -

BGIHFL » TEEE ER ﬁg[ IR R o B - TR
AR 2] Data Table - SR |8 HTS Y- (HREEL CARTSESRROTRIRE N -

- (i
B TR ) B PG R BT SR [RFOTIRERY » 2 B T PR
F WY S R R LA -

B r"ﬂc}[ﬁ’%’ﬁ ¢ [ Select a Flight: Mercury]) E{ﬁEJ IV SR E]‘%; » 3 S TSV USRI f%"f%‘ﬁ[;@?
iﬁﬁ@ RIFOFFITRRN © D= e > PRSI A R 1 #7 [ Select a Flight: Mercury ] Affp1 =2
RS E f%?% » 4 k@5 [Book a Flight: Mercury) _F&= frugg f%?% o

1. #u7 QuickTest ™[ JFIP( ' Parameter | JH[ZVHl 4

B0 QuickTest 12 F'EJ?S" E’J‘i’ [FﬁJﬂF",] > [#H=V& ] > [QuickTest Professional] >

[ QuickTest Professional] -
u f@ﬂ[‘?ﬁ]ﬁ?@iﬂ]ﬁﬁﬁiﬁ > K [Open Existing] -
m IR R BE [File] > [Open] @Rlfii™ Sl iy [Open] #7% -

7+ [Open QuickTest Test] tfﬁf,ﬁ}ﬂ[fil MY T Parameter | JHIEVRIA - ’HilaﬁﬁL
[Open] -

2. JFHEVEIE by 5% T Output , HEVETE
£ [File] > [Save As] - JKHIEYHI % 5 M55 T Output,
3. ﬁ“ng?i [ Active Screen] j@_ﬁﬂ?ﬁm

032 % 71%] QuickTest |, iy [Active Screen] - [~ 215 iy [Active Screen]
e gl‘/fﬂc%fﬁ [View] > [Active Screen] -

4. EVEIEEY S

7+ Keyword View f[1 - 5f(+) ["Welcome: Mercury Toirs"] & =" Bi# ["Select a Flight:
Mercury"] 5 “[ﬁ Fl o I[Jlﬂl[ﬁ [ﬁ [rf“ k7 [Active Screen] -

7+ " Active Screen | f[1 - #E‘Vﬁf[# 270 > {EELT B¢ $ﬁﬂﬁ7 DN~ #EEF'% DINE LY
[Insert Text Output] - nFF ?S{ [ Text Output VaIue Properties ] rfﬁf[ﬁlﬁil
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& Text Output Yalue Properties

upu Tot |

5. ?éﬁﬂ%[’:ﬂj
E’!,‘g [ Modify) #&* > F'#Jff!% [ Output Options] ;’“‘:’ﬂﬁﬁﬁfl@f o

Output Options

DrataT able |_
Select_a_Flight_M eru:ur_l,ll

7+ [Name] #ight %’75%;7—7 Select_a_FlightOutput_Text_out > }{ﬁ’iﬂ 454 depart_flight_price -
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Ao ’J@EF%EEJ ’ %ﬁ,ﬁ [OK]  QuickTest %’7& Data Table f[1[1* depart_flight_price 4
_f.

1= : 7+ Data Table I depart_flight_price fijfiik fuay— (= ¢ 8= (R R -IVIH pofia |
fifl—270 o T #=H > 57— 7~ QuickTest BELE IV H - BVl —270 > {HRLE 4372 ~ =
o i R Y VR - 75 b E]| Data Table fl1 -

QuickTest F’-"f.‘i SRR B [ b R -
6. I"%I—%F‘,ﬁﬁﬁ B
& Keyword View f[1 > 5f# (+) ["Welcome:Mercury Tour"] > ["Book a Flight: Mercury"] -

7 [Checkpoint "New York to San Francisco"]) _'—E’!,‘giﬁgﬁ[% 3#IV [ Checkpoint
Properties] - F'ﬁjfflff [ Table Checkpoint Properties] % i*,;ﬁrﬂgirf 0

%!1_:)1—‘ o BT (HLASERUREE ) > 7 [ Configure value] HI%,F [ Parameter) - ki
# ™ [Parameter Options) %" - BF JFT [ Parameter Options] H—Fﬁg" °

Parameter Options

DrataT able |_
MHew York_to_5 an_Frar‘u

& [Name] _"}"‘FEFI'HI £V depart_flight_price -

Eﬁfé‘_ [OK] - [H'?U [ Table Checkpoint Properties] a:fﬁf,ﬁlgi,] il Ulﬁ'ﬁﬁ‘ﬁ Eﬁl Y
U RS
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33| Table Checkpoint Properties

v 2 J s

Mew York 12/29/20
FLIGHT CLASS
Blue Skies  Business Parameterized value
San Franc 12431420
FLIGHT CLASS
Blue Skieg  Business

I:'.:wm:hnnnr

™ [OK] Fér%ﬁfj [ Table Checkpoint Properties] fﬁfﬁ:ﬁﬂﬁlgﬁ o
7. [REHEVRA
%’,‘ [File] > [Save] ﬁ&i&l!‘“* S Fpy [Save]) $E -

72 HE ST ERRRE 4
HN o oS RS AR -

1. %5 TOutput , I+
7S [Run] Stk [Test] > [Run] - Rl [Run) Sl -
=T [New run results folder] > ﬁﬁv‘%t'ngl%ﬁaj °
R COKY FUFh = HRERI A o g5t F{E""J TR o -
2. ek EUEE] (run-ime data )

A MEEEH R ] i results tree (Y Run-Time Data » ') ,ﬁzﬁﬂu IR
TVEfER > 5 depart_flight_price A5 HIEES TRIFVESEIFEAR -
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B Output [Res1] - Test Results

Test Output Summarsy

B antineoza [oe [
B v [ Output Tteration 1 (Row 13 | |departure | depart_flight_price| ~

f[h Oukput Tkeration 2 (Row 23 270/ [N
- o @ Output Tteration 3 (Row 3) Fortland

| 3 |Seatte
4

3. W BB
E’!ﬁg [View] > [Expand All] -

%9y [Output Iteration 1 (Row 1)) > ["Book a Flight: Mercury"]) > [ Checkpoint:"New York
to San Francisco"]) -

EEd T [Details] i1 > B A Ao BURLER Y -
[l - g Iterations 21I') % 3 » 7 [Details] gi,ﬂ‘ﬁfll ; J]ﬁ—s*g} B~ R -

4. AR B
Fiiz (File] > [Exit] AR Bowp -
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8.1

8.2

REIEE IS 4

& CEH AR AR B Bt e ﬁ@%ﬁ ﬁﬁﬁ#ﬂﬁiiﬂ & QuickTest i I ¥
fJFIJJ FATIE jEu ’}f[]er‘E[ £ ﬂgj[ﬂ: E[ SRR kEIJ‘l@]

Fyo R e

iﬁiﬁ}ﬁﬂjﬂ*ﬁ F 3 o QuickTest [ I'JFP [P FIFVEHEAHIT 1+ - i P T [IpL 3 o TRt
PIFFROTTE ~ TR PRy RSO A R E‘JF’JJE'Jﬂ"ﬁ SR

e

TR R SRR OPRC) ~ BB ~ e Y [[r%([]) il fgmp gE

I o fora— 7 i fjl E'Jﬁiﬁf'ﬁ"ﬁ F A3 ﬁ%ifj% QuickTest Professmnal User’s Gwde

IE’FI ]‘FJ Fl _] Yi
ﬁ[‘—kj\ /E{«:]' y_gﬁ - lﬁde ﬁﬁg’!‘ H| —Hﬁﬁﬁ‘é%mﬁ lﬁF PJ[I—“E[’E!‘F pfa%r aswvﬂ ﬂﬂﬁ;rj
i

s o i

QEJ °

[J”EIHEJFIJJ TR I;%‘-L‘J/J ﬁggﬁj—?}zﬁ@ H=F 1HA o F]Jﬁc = , Tijﬁgxﬂ E[

£ F= rﬁﬂﬁ';ﬁlﬁl Eljﬁglu,»i FAE l%,ﬂ;&;{ﬁ@ ElgEjlé[fjﬁ[ﬁﬂi_ N fF":

7 QuickTest ™ JFIF "' Recording ; Y=l 4
571" QuickTest M'EJ?T %ﬂ‘% (F'ﬂﬂf}] > [#='& ] > [QuickTest Professional] >

[ QuickTest Professional] -
B (B g’@«ﬂfﬂﬁlu KisZ [Open Existing] -
W BRI g - KEE (File] > [Open] fkifiiz S1) Hf [Open] ##: -

7 [Open QuickTest Test] tfﬁf,ﬁ}ﬂ[fiv. MRV T Recording | JH[EVRI A - 71%&%;%
[Open] -

SRR A P37 b €88 [RegExpression] R4 4
£ [File] > [Save As] - J{iHIEHI 4 %5 " RegExpression ; -
ﬁ“ngf.% [ Active Screen] j@_ﬁﬂ?ﬁm

(2L A UchkTestJF "4y [Active Screen] E,!,‘“f'* 23] Fp [Active Screen]
e g‘/i%ﬁ [View] > [Active Screen] -

VR ﬁﬁﬁ] %’Jﬁlfﬁl} P

7+ Keyword View f[1 - 5ff(+) ["Welcome: Mercury Tours"] & %' E’!,‘g ["Select a Flight:
Mercury"] A [[Jlﬂl[ﬁ{[ﬁ Flé i [Active Screen] -
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“t [Active Screen] - I'HFERAE( gk ZAH10 | 11 12/29/2004 - F |13 R T (SRR 2V
[ Insert Text Checkpoint] - F'#J’?% [ Text Checkpoint Properties] ‘@Tﬁﬁﬁfﬁiﬁ o

5. ] ]‘E'JJE'J&% ERR L R EE Y
7 [Checked Text] Eﬁf{ [ Edit Constant Value Options]) #&* > F'qﬂfﬁr [ Constant Value
Options] ;’“’éq‘ﬁ:jf,ﬁlﬁij’ o

Constant Yalue Options

7 [Value] % - & [0-1][0-9)[0-3][0-9)/200[0-9] - ¢ QuickTest || MM/DD/200Y ¢

FS o I b
3% [Regular expression] i QH'&J%F;LFEJ fﬁ\’E}lTEI&EJﬂﬁVﬁJ"ﬂiﬂ“ﬁ ﬁr]ﬁpf’@,?ﬁ;&’ Eﬁ
# [No] -

B RiEE [Yes] QuickTest Ui FiTEd 7~ - 40t (D ~ (=) I'J* (D = 44
7o PEERP R

ot “LL?EF%"“[’@_’[ ) Eﬁf%’ [OK] E‘%Efj [ Constant Value Options) ;’“’é%ﬁﬁl@f JpIE [Text
Checkpoint Properties] ’;‘:TI?F,EJ Firf o
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& Text Checkpoint Properties

Checked Test x| = = =

(0-1][0-9)/[0-3][0-9)/200[0-9] |;T

HiZ [OK] Fﬁﬁf] [ Text Checkpoint Properties ] éﬁﬁ%ﬁlgﬁ o

QuickTest Fﬁ&?ﬂﬂ%ﬁﬁ'ﬁ‘ﬂi fIt> ["Select a Flight: Mercury" AfFIf™ 1% & S 4 Rl
fer e VA

R [File] > [Save] Rl « 25] i [Save] #¢ -

83 BTSRRI e PR
B SRR R A o 2 R TR -

1.

2.

7 T RegExpression | V4

R 2905y [Run] % - prRlRE [Test] > [Run] F%FJ?% [Run] é“?i«iﬁ:ﬁﬁ‘rlffi‘f °
IV [New run results folder) i?ﬁfg'%ﬁ?ﬁlf@nf?ﬁ%\' FIeg &7 o

R [OKY - il R 4 - F{'}’ﬁtf?%'fé" ’ ‘FE“*J fﬁﬁ[}aﬁqﬁ\'ﬁ%

AT A A R R A

-54 -



oldsidney % ??ETF—‘,H http://www.oldsidney.idv.tw

T+ results tree » " ff(+) [ Test RegExpression Summary] > [ RegExpression Iteration 1
(Row 1)) > [Actionl Summary]) > [Welcome: Mercury Tours]) > [ Select a Flight:
Mercury] -

&9y [ CheckPoint:"[0-1][0-9]/[0-3][0-9"] -

B HegExpreszion [Hesll - Test Fesults

Tect RegEvpression Summary
BE Aun-Time Data
E’. RegExpresdon [beration 1 [Row 1)
- ,; @ ictionl Summary
= Jﬁ Welooms: Meroiry Tours
E rj Wielcarme: Meroury Tours
BE "ucorhlame®:Sek "meroary”
B "pacosordiSersace "H0220850
i A "sign-In":Jick.
E qrj Find 2 Flight: Marcury
IS "FromPort"Salect aw ork"
L5 "FromPonth Sslect *Dec
= "rorDay" Selact 20"
15 "eoPoet'iSelect "San Franciszo"
o=| "boManth":Zelact 'Dec"
I=] "oyt selact 21"
JF "eopuClacs"iSelect "Business"
fbe B RndRlighes" i Chek
|: ,rqr_hl Salact 2 FllgH: Mercury

Text Checkpoint "[0-1][0-9]/
[0-3][0-9]/200[0-8]": Passed

Date and Time: 4/19/2004 - 18:78:05

Details

Tt Chackpoirt: capiured "12/29f2004" hetween
san Francisco and SELECT

Fegular Expression ; OR

Iaich case: OFF
Exact match: OFF
Ignare spaces: O

rn flight from the selections below Yourtotal price will
ect to fly on a diferert airline for both legs of your

12/29.2004

oo
nes 360 5:03 non-stop
E e roine o

E "rcscrchllghts".Cick
qr_hl Boak o Flight: Mercury
qr_hl Flight Confirmation: Meroury

qr_hl “Welcarne: Meroury Tours

rr?w@WﬁE%W%ﬁu%Fﬁﬁ‘wﬁ“ Foh A R R R Y
Fo Y T BT -
pum_f.ﬁ;%l:aj*éﬁﬁﬂ P TR P I R B R
3. BRI B
A GORS GO
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9. SRRV A e

9.1

9.2

9.21

7 QuickTest f[1 Action k.- fifi'I'J BEETHII® | (reuse) pufd | Hiok El’,’fﬁ\’@i* ffit 2 =R
FE o WEVRTA R CE - W Action £753 Actiond fﬁ'\’Fl‘J‘Jﬁﬁ’?fﬁ‘?ﬁﬂ%%ﬂi”%ﬂg‘? % Actions » &
it e 'EI Fk PLRLERRTIS -

i) e

[Tt AN [ Nk R S 'F’Tﬁfi‘ PHOERR A o %’[J’?}’-‘i‘l'[ﬁ"#ﬁ IS5 S22
Ao

LI RE 0

R

LI

IR 1 ET 2 SR RS PR A - SRS T TR W\%E FIFEE 2] Ay L

1%E1Mqﬂix@w CEH > BT AR TS S W A
R T R RS (W e PR WP SRR 5*"%&‘%‘ AR R

Lfr
L[I

BORIZRHI £ IS B il BB K (BT = (= 45 SR R
[~ PR AL =I5 v U [ o

TR U AL EAY I i e A vy it S av R s O s PR A Lt i

i

[

] Eﬁf{ [Insert] > [[New Action] ﬁ‘}ﬂj 219 Fp9 [Insert New Action] " -
] E’![‘E [Step] > [Split Action] ﬁ‘/ L7 2% Fp [Split Action]) $#4: ©

| &ﬁ% [Insert] > [Copy of Action] F‘}iﬁi Action F¥ ,Eyﬁ%&f,@% » IV [Insert Copy of
Action] -

| E’!‘ [Insert] > [Call to Action] F{&f\_ri Action l—g’;‘ YFJEVI% E9 [Insert Call to
Action] -

ot e
B8 T (6 (IR -

HEHIZ R T
1. %~ QuickTest ™ fF 'E?ﬁ ffit = SRV £
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ﬁ?‘iﬁj@é FERENRIEA A L R L
2. F'ﬁjtrﬁ%@;{ Mercury Tours #3 ﬁﬁﬁf’![‘

BRI SR (19 SRRV ) SRR POREEE © T T
17) %5 actions » 533 IRRIBVRI 1o 7+ BB | PO ORES 4 e

T :r_:f;rgj.gr;ﬂﬁ% OB -
Eﬁfé’_ [Test] > [Record] fRLEGE T 29 Hpv [Record] #%: }{%‘J’F'#J’ii% [Record and Run
Settings] %Tﬁ%ﬁlﬁif”[ o

Record and Bun Settings

Microzoft [nternet B xplorer |_
hittp: A riewkars. mercuryinteractive. com |_

B 7 [Web]) Fr&s Eﬁf’aﬂ [ Open the following browser when a record or run session
begins] -
7+ [Type] EHIHEE G0 FURETE - = [Address] A flifa; *
http://newtours.mercuryinteractive.com -
252 [ Do not record and run on browsers that are already open] I'] % [Close the
browser when the test is closed] i -

B 7+ [Windows Applications] FI#5 > ~J:# [Record and run on these applications
(opened on session start)] - |fi| = ﬁ?ﬁ‘ér,ﬁﬁﬁf[li%ﬂ = e A .

B [OK] -

QuickTest F’ﬁf’ﬁj?#@@’ﬁ%{ > BT Mercury Tours FiE! > 2 il sRShIEHIE -
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3. ﬁ‘ Mercury Tours

7 [User Name]) I'] ¥ [Password] ﬁi?” EN [/H'jﬁ:tF ff=s Jfﬁ?

%{Gﬂ_ [Sign-In] -

F'ﬁj’?ﬁ‘ [ Flight Finder] ?l'ﬁfl 0
4. ﬁﬁa’?‘ R

By SRR

[ Departing From] : New York

[On] : Dec 29

[Arriving In] : San Francisco

[Returning) : Dec 31

lﬁ%twg[%@ ) Eﬁ# [CONTINUE] - F'ﬁj?{ [ Select Flight) {[ﬁfl o
5. EEMET

}%;E?@ ’ Eﬁp [CONTINUE] - F'aﬂ?'sf [Book a Flight] sfff1 -
R

i R R

Eﬁp “]'ﬁ FI'h 1y [SECURE PURCHASE] F';:FJ‘T?,‘ [ Flight Confirmation] {]’ﬁEl o
7. |p'E[ [Flight Finder] ;{ﬁgl

“ [Flight Confirmation] Afff1 ™ % » fi# [BACK TO FLIGHTS] - [p'%] [Flight Finder]

W -
[ [Flight Finder] Afff1 it | M350 » SRIFIG ==t oDRLIl - Frpen - gt Rl
HR TR

8. e

R S5l Ep [Stop] HE i) -
9. EHIEHI A T ActionA

RHrZ [File] > [Save As] - JRHIEVHI# @i =5 [ ActionA

9.2.2  JTHERIF A
[RUEL ORI B0 3 2 IR SR SRR T RS o (e
)FEIF{II Flfﬁ[ °
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Lo R W AT
7+ Keyword View > 4 ff/(+) [Action1] > ["Welcome: Mercury Tours"] -

2. SRHIRVEIA 51H5 2 gh(E
#3v ["Find a Flight: Mercury”] A1 - j&ﬁg [Step] > [Split Action] Ji5 LR ™ 15| -
i [Split Action] $#&* » q'ﬂ‘?if [ Split Action] ééfﬁ%;ﬁ‘ylgr{ o

Split Action

3. T Pl g
7t [1staction] flif [Name] ﬁaﬁ"ﬁﬁj‘ 2 Sign_in o
7t [1staction] f[if% [Description] )h“ﬁh_"ﬁi?]“ : Enters user name and password to sign
in o
7t [2nd action] f[ifiy [Name] ﬁ;ﬁ@ﬁﬁj‘ : FlightOrder -
7 [2nd action] f[if% [ Description] )h“ﬁh_"ﬁi?]“ : Chooses and purchases a flight -
FUEREE P FHRE T - B [OK] Fér%ﬁfj [ Split Action] fﬁfﬁ:—"ﬂﬁﬂgﬁ > 7 Keyword View ngt'?
A i
%’,‘fﬂj [View] > [Expand All] ffﬁfﬂ@[’[ﬁ‘éﬂfﬁfﬁlm?{ - =¥ > [FlightOrder] E*JI"EfIUF'ﬁEJiIF'E‘?E&F.
ﬁJ’EEFEf/ﬁBﬂ [Find a Flight: Mercury] AffE1 -
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9.3 45 FEN(E
B {S\ﬂéj’ﬁjﬁ - ORI (  T2 SREIRIE] Mercury Tours FiEIIOHER > FISTRIZVRIE 0
SN R [l FUF

1. jﬁ‘ v =
Eﬁfg [Insert] > [[New Action] ﬁ‘/ﬂ g T 2] Py [Insert New Action] " » F'ﬁ]?ﬁf
[ Insert New Action] ’éi%fﬁjﬂ;ﬁ’ﬁl ?irf °

Inzert Call to Mew Action

A ction]

“ [Name] %t ([ ifi * {i5(=¢7% ReturnHome - ;2 [At the end of the test] W.agﬁg
[OKY ~ HISHFI: « 7RI 5 1 {7 IR ReturHome (-

2. YEHHYIR A
THEARIBR 2 W [Flight Finder] Affr -

ﬁ%E?J‘ Mercury Tours fisfit- Chttp:/newtours.mercuryinteractive.com ) i“'f}ﬁ‘ ’ EJ[J%’?F'#J?%
[Flight Finder] !

R T IR QuickTest (R il » 1R I 0 = (b g -
3. 7@l [Record and Run settings]

E'H™pv [Record and Run settings ] ﬂ?iﬁz’& [ Open the following browser when a record
or run session begins]  F+'] QuickTest %‘7 EIﬁﬁf’ﬁj’?ﬁ%ﬂﬁﬁﬁiufﬁ\ﬁﬁmﬁfﬁf° T R RL
For s S HHIORBINTES - » SRR T | ot AR

E’!,‘E [Test] > [Record and Run Settings]) F'#J’?sf [ Record and Run Settings] ;TFF%@

P -
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Record and Run Settings

Microzoft Intermnet Explorer |_

hitp: A Anewtourz. mercurpinteractive. com |_

7t [Web] FI35 > %V [Record and run test on any open Web browser] - ’IF&E#,‘E
[OK] -

4. #5] ReturnHome F)[™=
it Keyword View f[1 » ZTV#i{iy ReturnHome F{™
Eﬁ_ [Test)] > [Record] ﬁ&i&ﬁ“* S)I-fY [Record] $& -
“t [Flight Finder] AffFr b R %32 158y [Home] - [pIZ] Mercury Tours U1 El
REBEET S5 [Stop] HHE L -

5. [plrgg [Record and Run Settings ) F%Jt

IS ikl "S5 ReturnHome E7['5f &R 1+~ [Record and Run Settings ] Em]%y& ) fﬁlﬂiﬁfg—i
(A g,@g QuickTest I 4 iU, = « BRI 4 H32 - #fifer QuickTest 7Y
s VEINTTTRIBET AR~ TBIBE Mercury Tours FiF1 > 5l | k] [Record and Run Settings]

%‘—Ecl;r[ﬂl"ﬁ’r_lk ]g[ J]:%';‘—E o

E’!‘L [Test] > [Run and Record Settings] - [ J‘TPr [ Run and Record Settings] hT—F[;ﬁI
e

[ﬁjfr;—i.i [Web] FI&5 > 22 [Open the following browser when a record or run session
begins] - ¥ ff‘eﬁ http://newtours.mercuryinteractive.com i+ - [Address] #g" {1 > E#,‘g
[OK] -
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6. @ HIEVRA

i [File] > [Save] FRlbfpse « =9l Hiiv [Save #8 » G IRV T -

9.3.1 }fgé/’%%é‘ﬁﬁ’f//ﬁ/E//ﬂf/gf//t— (Reusable Actions )
El’?FEFJ'EIfJF[JFJI'FDE'J]E'ISJE*J["E (Reusable Actions) ﬁ'ﬁﬁ'ﬁ?\?ﬁ?vr%’%ﬂlﬁﬁﬁ’@? (function) - ’5[[ 508 | {3
A > T SRR H%B%’?BJ?UE% ET J‘Hﬁiﬁl’[ﬁ‘%‘%ﬁﬂféﬁ@* i F R Ve =
(Reusable Actions) = R[] r“i’ﬁTELl RSO AR A Lo PRI
fel B (g o I LR AR 4 L = | ’iﬁfﬁéﬂﬁ‘:/“~iﬁﬂ~ i T {2 I (= (Reusable
Actions) - 1 > Iﬁ:’é@?ﬂﬁ'%ﬁfgﬁlﬁ’?@j fiY Sign_in I'| % ReturnHome f (%= » 73 H ARG 4
I SR e pARIop = 5o D5 CEs i f) 2 I9pn = (Reusable Actions) - -

1. }{ﬁ’ Sign_in g f‘EF%{L_F‘}FI‘ FIF™[pYEs = (Reusable Actions )

7 Keyword View J‘J?ﬁ@&?,; Eﬁf{ Sign_in $Rx:ZE TV [Action Properties] > rﬁ’ﬁﬁﬂ?ﬁf [ Action
Properties] %ﬁzjﬂ@ﬁiﬁ o E’!?E’ [ Reusable action] Rz ™ [OK] - f&iﬂ[lmﬁi?{ﬁbﬁlﬁiﬁ =
- NEEEPUFEL ﬂin&&ﬁ{éﬁ [ Do not show this dialog box again] - k™ [OK] - [

PR @ & iy e Am s R 4
2. fE Sign_in (e
o BT SRR T Keyword View Ff Sign_in g = o
E'}’ RS T (g i | {7 [pOEs (= (Reusable Actions) # - ﬁ(%’ﬁéﬁfih} Keyword View

A - I'[E'EVJ ],E/%Eff ’ (%EEHH L%ﬁ? fj;ﬁ[’[ﬁ]ﬁuﬁ}:@%ﬂi H IFI%JF[H:EJF'JF“E:[EIJFWE’IJ = (Reusable
Actions ) ) J‘) KH E’I]L[Flfjfﬂ, ?ZIBEI}J [le .

ﬁ Test Flow j

ﬁ Test Flowg

(= Reuszable Actions
@,, Sigr_in

folhimy) Sign_in gﬁl"Eflme?&[’ B N PR E T pE IV Sign_in g SRR T .

it [Action] ™ FFiEHIf1 > 23V [Test Flow] #ikp ') [HIZ[FU4 iy Keyword View " o

3. }{ij’ ReturnHome “JI%TJ&F‘}P‘FJ i~ [pvEs = (Reusable Actions )
%f ReturnHome (b= EitEH R 1272 -
4. IR

HrZ [File] > [Save] fhLiE ™" 29[ HiY [Save] #% -
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0.4 IHT T UM
Fil far ,itf_lé — _I,\/IJIEIJjEH?;E]'[E{iE%ﬁ ’ F[J'H: FTBE&F‘[?JE;‘E}J],E s ‘é/l:[ﬁ R Fl H:T‘i |‘L ]EI JIEH IE{iHlﬁﬁnﬁy E'J
£ E'UF{' oy — '”‘?E‘H: il L SREECN I AR s IRl AR R 2 T
RN e Hl o= pupars.

BT RIS 0 e I T e g*gﬁl‘%iﬁi |2 RS R Rk
U E el s "Aﬁégxﬁl*ﬁiﬁt FJ, o0 | = pL A rtj:hjﬁ‘ gm‘ﬁ’ lﬂﬁghl‘ﬁgﬁi%p\%;jp@m‘ﬁv
AN A N e s L T T e U A A U [ [ B IE‘H A LR PR
i R > PR A AR RS o RS UG PR A i

TN T PP F“@ﬂ = {3 ActionA FypE%ll £ - Ef1 Sign_in I') % ReturnHome E[™=
AR FUTA R A (1P L= P R el 4 plIpgs ) oy 2 FlightOrder g =67 {7l
ERIE TR

9.4.1 47y (call) fopft
P B PIEERLAY 2 > 21 ActionA fl1fiY Sign_in = ReturnHome Es{* » Jﬁ‘ ActionB f[1 -

1. [T ActionB JEVHI 4
Rz [File] > [Open] - ActionB if} ™ [Open] ## -
2. 3t PERURY Sign_in BT

Eﬁp [Insert] > [Call to Existing Action] > Hﬂ?ﬁ‘ [ Select Action] %T%ﬁylrﬁ °
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Select Action

<Current Tesgty

® boort 7]

%’,‘fﬂj [ From test] *F[i%]ém () £ - 250 [ActionA] IRV H <k [Open] - [1F)
P’ijﬁlgjfl@éﬂﬁi (reusable actions ) %‘Efﬂ “+ [Select Action] ;:Tﬁf—'r,ﬁfflffi,m[ o
HIV Sign_in fih®ix o 7 [OK] - Sign_ |n[Act|onA]F#J|":%"H',, TRV A P s

%I—Tp@)}i}* .

i ST Keyword View U Sign_in @5 > Ribgi Sign_in g =517
[Action] EHI &2V Sign_in @h( o ke g (af IFRLIETRRY > SO0 R fSEsauss - U R
FPRCREORIEEE (ActionA) FfiEsifsast -

ZIV [Action] & HTF 1Ifv Test Flow [l EUdfiv Keyword View -
3. jﬁ P LAY ReturnHome Fm‘E

fz'*ﬂﬁﬁ%‘u ] }{ﬁ' ActionA I 4 (1Y ReturnHome > jﬁ‘ HIEEIA o™ o
4. EFHEVEE

E’!,‘ [File] > [Save] ﬁ\/ﬁ:%!—““ S5 -py [Save] ##&: -
5. F%”EIV'F@!F[E\J ReturnHome {5 (™=

Eﬁfé’_ [File] > [Open] - IV ActionA 14 > /=™ [Open] -

$} ReturnHome g7 |‘E£|!r: NI R £ [‘J”'Fk,‘ o
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7+ Keyword View > 37V ReturnHome E#Jf‘EEIquaH , w.&&ﬁé{ [Insert] > [Step] >
[Comment] - F'#J’?% [ Insert Comment] %ﬁﬁﬁ;ﬁmﬁ > At ﬁéfﬁji o

Inzert Comment

]

ok ] coced | Heb |

ﬁE?J‘ : Return to page used in first step of the test » 3% [OK] -

ap Fé_tﬁjé’:yp‘k :

o FetumnH ome

{,,E_:' Comment éHeturn to page uzed... Comment
v & Find a Flight: Mercury ¢ Retumn to page uzed in first step of the
|| best,

3 Home Cick Click the "Home" link.
b J;j Welcome: Mercury Tours | Spnc Wit for the ‘Weh page to spnchronize befar

6. R
kisZ [File] > [Save] frRiipE ™ =15 iy [Save] #E -
7. B RUf) ReturnHome S sy U] O 4
Mz [File] > [Open] - 2V ActionB J{Z[+ - # [Open] -

%f ReturnHome[Action Al [l B~ ™ I AR [y > it )20 ] =i R IR 4
(ActionA) flip ElfJﬁ%_tEfé“JH SR PT P  PSEIEEI A (ActionB) e

7+ [Action] = &7 > %#,f:ﬁ [Action] j& i # 5V Test Flow [fIZ['F14 iy Keyword View e

9.42 77~ [HEHHIHF
#7 % B FlightOrder vkl 1 -

1. F'?ﬂ’?sﬁ (R 4
Tﬁii}['fsx‘%\ﬁg"‘ﬁ’ﬁﬁf'%’ ﬁ%ifj%‘ RGN A L PO ERL -
2. ]T;’ﬂ FlightOrder g { =ik 4
&ﬁé [Insert] > [Call to Copy of Action] - F'#J’?% [ Select Action] ‘;ET%—‘"F,;,?;JEV”, o
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Select Action

<Current

@ Actort 7]

Rl [From test] figt | 32fw [RIBT] £ - =% [ActionA] HZHHI4 iRE [Open] -
I [ActionA] ?EU;%‘%MFIIFFJ‘JWHIE'JEIfJEI*JI"EF?%H & [Action] FEHI1 - =7 > BaEIvpy
E*JI"E‘E'U?SEF'EJQ%Ti it [Action description] f|1 -
Z TV FlightOrder gii{ » ’ﬁTE’F:’—I’i [Location] % [Atthe end of the test)] & [OK] -
[ Sign_in [ActionA]] & l"egﬁsl RPN POy o R IR T o S P
B B I S e R -

3. [%d¥ Copy of FlightOrder f’ [

7+ Keyword View f[1 - 5f(+) [Copy of FlightOrder] > ["Welcome: Mercury Tours"] >
["Find a Flight: Mercury") - Ef:Z 7 "fromPort"fiy [Value] it g‘-{%‘]’ﬁﬁfﬂilﬁfjfﬁaﬂ’%

London & > ¥ Keyword View £ 4% -

4. JKj Copy of FlightOrder g {*=4v%(| Sign_in gis{=1 i
fﬁc?fj CEPIEVRIT A $ho s PO EIELLE SR Sign_in FI=V = F ¥~ Copy of FlightOrder fi5(™= > {fIhL
SO - B RE]- [ F 7 [9EY (% (Reusable Actions ) i » RELTIF] i fiv
fih(% (Reusable Actions ) 71 BLP=[ILIAVH] 4 FIURLPEREIRY > Bl | a2 = T 5 R ‘Jfﬁiﬁéﬂ
jﬁﬂfﬁﬁ [EfIVIE: o
7t Keyword View H#2v Copy of FlightOrder fs (™ » ;-[51' HHGHE] Actionl FU{ED % > JREF
1 Sign_in B =4 $550E] Actionl gh{=Y & iﬁﬁ—i— SO .auI;;}[‘—‘]’ Copy of FlightOrder (%
BEE] Sign_in fih[El T o
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5. MIE=RIERRIE 1P Actionl

5 BITEER TR 41 ¢ R Actiond (=« [IRRVHI A [l LRI% b (i
=X F”rl }wd~'glffjﬁ * Copy of FI|ghtOrder e ‘H%&?F P18k Actionl fihf o 37 »
] )}H Action1 {Jp& " o

7+ Keyword View [1 > E’!‘E’:ﬁ’ Actionl RV [Edit] > [Delete] ﬁ‘)ﬂﬁ’* SR iy
[Delete] % - ”EE"“ Fj"” Bl [Yes] -

6. @ HIEVA

2 [File] > [Save As] RLpiz T =L Hfy [Save] #E - HRVHI 4 7%
[ActionB]) -

7. AR FlightOrder f skl iy = ki
Rl [File] > [Open] -3V ActionA > K2 [Open] -

B [FlightOrder] > ["Welcome: Mercury Tours") > ["Find a Flight: Mercury"]) > iﬁﬁﬁp
0 ActionB SRR 4 F]lpxcl;rgﬂl',g@f%%ﬁ, T ActionA JFIEVHI 4 H[f\_ F&l S|
(ActionA fitat! Egﬁﬁ%ﬁ?ﬁzﬁ& New York) -

95  EiiE{ERy

iy 2] ActionB JZVRI 4 R # (Data Table) f > fﬁ\'gﬁéﬁifj[wlﬁa{j {E : Global -
Copy of FlightOrder ~ Sign_in [ActionA]l'] & ReturnHome [ActionA] -

AU [gpea2 € ek % (Data Table) - [ [View] > [Data Table] mﬁﬁ%ﬁ%‘ Ay S

7 Global I‘P%HIEJE*HJQM (IR [0 2 Y - 53 Global wyRl Al 1E) 5 Zrevf] - [IHEfahi]
?Mfﬂ#m 5% e pIYt o e 0 B [ R T [ o B0 [*;I*Jl‘ef’?%‘t}‘ﬂ??ﬁe@ [
s—ffraﬂ T WA T L T 5

=EC Sign in [ActionAJ== ReturnHome [ActionA] ]"ﬁ%h%ﬁ% ER 7 1> R g WD (EALLER
Vo PNEg S W (B R PRI A Py > RS Wﬁitzp PV Fpeises -

B frf 45 FlightOrder (g — (v » 1)1 B! PHZ N R D - 00 [
LIPS IR

_"'L

1. Eﬂ’??,‘ActionB FIEH 4
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F'aﬂflgi,f [ Value Configuration Options] ’;‘mj‘ﬁf,ﬁl gi:.‘ °

Yalue Configuration Options Ed

San Francizco

L Enmrent actian sheeh{|EEal|

iy =R
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EIY [File)] > [Save] H *fﬁ_&ﬁf“ 2 Hpy [Save]
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3.

B ActionB [Res1] - Test Results

ﬁ Tesk ActionB Summary
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Copy of FlightOrder Results Summary

- @ Sigr_n [Actiona] Summary
= B ory of FlightOrder Summary

Action: Copy of FlightOrder
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Iteration # Results

1 Done

p Done

Status

Passed
Failed

W¥arnings

PR R
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10.2

10.2.1

10.2.2
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=¥ QuickTest Professional User's Guide °
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[ HL il (defects)
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(TestDirector ) ¥ () -

IV HFEG PR
FIIVEH %%%ﬁ:” QuickTest Professional fiugy@t » ' [ SBR[ BSRLISLHERR -

L i
&5 4 =] > QuickTest Professional “Jf{H I'| ™~ fud {F :

QuickTest Professional Installation Guide

FUHE b 5E QuickTest Professional -

QuickTest Professional User's Guide

I'}] step-by-step v = {1 "] QuickTest Professional i~ fléﬁf“‘\]ﬁﬂ%ﬁ%ﬁﬂ[ o [P R =)
(User's Guide ) H4fff =4 =] (Tutorial ) EIF%%EIEKJ?}’?* °

QuickTest Professional Object Model Reference

HifH QuickTest Professional fufs{F - VBScript 5% ~ methods I'] = #&3fy]

EI}Z[
QuickTest Professional Shortcut Key Reference Card

FETI TP S g4

AL ERRT
B SR SRR R

ReadMe (available from the QuickTest Professional Start menu program folder)
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Provides the latest news and information about QuickTest Professional.
B What's New in QuickTest Professional (available from Help > What's New in QuickTest)

Describes the newest features, enhancements, and supported environments in the current
version of QuickTest Professional.

B QuickTest Professional Context-Sensitive Help (available from dialog boxes and windows)
Describes specific QuickTest dialog boxes and windows.
B QuickTest Professional User’'s Guide (available from Help > QuickTest Professional Help)

Provides step-by-step instructions for using QuickTest Professional to test your application
or Web site. The User’s Guide describes many useful testing tasks and options not covered
in this tutorial.

B QuickTest Professional Object Model Reference (available from Help > QuickTest
Professional Help)

Describes QuickTest Professional test objects, lists the methods and properties associated
with each object, and provides syntax information and examples for the methods.

B QuickTest Professional Automation Object Model Reference (available from the QuickTest
Professional Start menu program folder and from Help > QuickTest Automation Object
Model Reference)

Provides syntax, descriptive information, and examples for automation objects, methods,
and properties. It also contains a detailed overview to help you get started writing QuickTest
automation scripts. The automation object model assists you in automating test
management, by providing objects, methods and properties that enable you to control
virtually every QuickTest feature and capability.

B Microsoft VBScript Reference (available from Help > QuickTest Professional Help)
Includes Microsoft's VBScript User's Guide and VBScript Language Reference.

B Mercury Tours sample Web site (available from the QuickTest Professional Start menu
program folder and also from the QuickTest Professional Record and Run Settings dialog
box) and the Mercury Tours Windows sample flight application (available from the
QuickTest Professional Start menu program folder)

The demonstration applications for QuickTest Professional and the basis for many of the
examples in the documentation. The examples and instructions in this tutorial are based on
the Mercury Tours Web site (http://newtours.mercuryinteractive.com).

B Technical Support Online (available from Help >Technical Support Online)
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Opens Mercury Interactive’s Customer Support Web site in your default Web browser. This
site enables you to browse the knowledge base and add your own articles, post to and
search user discussion forums, submit support requests, download patches and latest
documentation, and more.The URL for this Web site is http://support.mercuryinteractive.com.

B Support Information (available from Help >Support Information)

Presents Mercury Interactive's Web site and Customer Support site, information on user
discussion forums, and links to information on Mercury Interactive's offices worldwide.

B Mercury Interactive on the Web (available from Help > Mercury Interactive on the Web)

Opens Mercury Interactive’s home page in your default Web browser. This site provides you
with the latest information about Mercury Interactive and its products, including new
software releases, seminars and trade shows, customer support, and educational services.
The URL of this Web site is http://www.mercuryinteractive.com.
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